LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-16-2004, 09:56 AM   #1
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Rep: Reputation: 0
Unhappy Problems with booting slackware after installing


Ok I installed Slackware 10.0 without bootdisks (directly started the install from CD(I used the ISO's)) on a hard disk with

1 NTFS partition (windows 2000 advanced server)
1 fat32 (data)
1 Linux swap
3 Linux ext2 (I mounted /, /home and /usr on these)

But I didnt install lilo or any other bootloader, so when I boot from that HD I just get the windows 2000 bootloader which has no linux options.

So how can I boot slackware, or how do I install lilo (might lilo damage that win 2000 partion... had some bad experiences with that before...)
 
Old 09-16-2004, 11:01 AM   #2
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
For now you can boot with your CD and boot your newly installed Slackware.

At the "boot:" prompt, just enter:

root=/dev/hdxx <---where /dev/hdx is whatever your root linux partition is (the ext2 one).

There are ways to set up the bootloader on the superblock of the linux partition and have Windows' bootloader point to that bootloader......which is how I triple-boot at home.

For now, just try the booting with the CD method and make sure that your install is working. Then you can look at getting the dual-boot setup. There's at least a few good threads and/or webpages about dual-boot setup.
 
Old 09-16-2004, 11:34 AM   #3
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Start CD 1 again.

Skip all the install stuff, go directly to lilo poriton
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Booting Slackware and Other Linux stevesk Slackware 26 12-15-2004 01:17 PM
Slackware 9.1 Kernel 2.6.9 Booting Problems PSHLOS_007 Slackware 11 12-06-2004 12:39 PM
Installing Slackware 9.0 on a Dell Latitude CP, problem with CDROM booting... davec Linux - Laptop and Netbook 7 05-03-2004 10:12 AM
Severe Problems instaling/booting Slackware ubers0ldat Slackware 2 03-06-2004 07:58 PM
Slackware 9 booting and graphics problems. (newbie) :-) Whitman Slackware 3 06-15-2003 07:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration