-   Slackware (
-   -   Problems to run Minitube on Slackware 14 32 bit (

TobiSGD 10-01-2012 12:41 PM

Problems to run Minitube on Slackware 14 32 bit
I try to run Minitube on one of my older computers running Slackware 14 32 bit, but I get errors.

I have tried it with sbopkg, using the SBo-git/current repository, it compiles fine and starts, but as soon as it tries to play a video it crashes with a network error, followed by a floating point exception error. The version of Minitube compiled by sbopkg is 1.8, this is the exact error:

Network error: "Error downloading - server replied: Forbidden" 202
"Error downloading - server replied: Forbidden" ""
zsh: floating point exception  minitube

Since there is already a 1.9 version I downloaded that and used the SlackBuild from SBo to compile that, compiled also fine, starts, but doesn't play videos, it loads the description and then just sits there indefinitely without playing anything. There seems to be a problem with Phonon, this is the console output:

Playing "/tmp/minitube-1683150946-tobi"
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

The same behavior occurs when I try it with the pre-compiled binary downloaded from the Minitube website:

Has anyone a clue what is going on there and what I can try to get this working?

ponce 10-02-2012 06:49 AM

I think minitube works fine only inside a kde session.

TobiSGD 10-02-2012 07:09 AM

I tried in in KDE now. Minitube 1.8 still crashes with a floating point exception. Minitube 1.9 now doesn't give the Phonon warning anymore, but still doesn't play any videos.

That is quite strange, some time back, I think it was with Minitube 1.3 I ran it on an older computer with Debian and LXDE. No KDE at all and it worked absolutely fine. What would be the point in writing a program that allows you to use Youtube on computers that otherwise couldn't, just because Flash is such a resource hog, and then make it dependent on a different resource hog (KDE)?

ponce 10-02-2012 07:55 AM

1.8 has a problem, yes, but 1.9 works fine for me using the vlc backend with phonon-vlc (in kde, System Settings -> Multimedia -> Phonon -> Backend).
With the gstreamer backend I still have problems in playback of h264 video (other videos works fine).

regarding the phonon/kde dependency, I'll ask the developer.

ponce 10-02-2012 09:16 AM

he answered me that probably there was a problem with the phonon package in slackware.

so I looked around and found this:

archlinux applies this patch: I rebuilt phonon with that and it seems to solve the issue.

as a workaround you can also export the QT_PLUGIN_PATH variable like this before launching minitube (/usr/lib64/kde4/plugins if you are on slackware64):

export QT_PLUGIN_PATH=/usr/lib/kde4/plugins

TobiSGD 10-02-2012 09:44 AM

Thanks, with VLC backend and the workaround it works now with version 1.9.
Also special thanks to the developer of this great program his immediate help and of course his development work.

All times are GMT -5. The time now is 05:35 AM.