Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-25-2003, 02:49 PM   #1
Registered: Feb 2003
Location: Texas
Distribution: slackware 11
Posts: 90

Rep: Reputation: 15
problems starting X

I've been lurking for a while, gotten a lot of great answers from just searching, but I'm having trouble with starting X on one of my systems.

It's a P120 w/64 MB of RAM and an ATI Mach64 (264VT) video card.

I installed slack8.1. I ran xf86config and set everything up correctly as far as I can tell.

When I type startx, the screen goes black like is initializing, but after about 4-5 seconds, the power light turns from green to amber like the monitor is going into power save mode or something. It never turns red for no signal, but the screen just stays black.

When I look at the X log, the last line is XINPUT: Adding extended input device "Mouse1" (type: MOUSE)

I never see any errors though. The mouse works on the command line, I can cut and paste, etc. I've tried different mouse protocols and still no luck on X though. It's an IO Gear 4D Web Cruiser mouse that came free with my KVM.

This onboard video card only has 1 MB of video ram, but I've set the default to 800X600 and I know it can push that. At one point I did use Mandrake on this system with KDE and it had no problems, but that's been a couple of years.

Any suggestions ?
Old 02-25-2003, 08:01 PM   #2
Senior Member
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
I would think the easiest and quickest would be to use framebuffer mode. If you are running a stock Slack kernel then you should be able to set the vga=771 in the /etc/lilo.conf file and then run "lilo" to write the change. Reboot and you should get a console at 800x600 w/256 colors. The different values should be listed in the lilo.conf. You might even would want to start at vga=769 for testing purposes, 640x480x256 mode. Or another option would be vga=ask. It should then request the value when you boot. That might be the safest to start with.

For the X config use the /etc/X11/XF86Config-fbdev config file, just copy it to XF86Config in the same directory. It should use the /dev/mouse as the mouse device so you can set that symlink to what you need it to be. I think it should be defaulted to /dev/psaux as the PS/2 mouse port.

Perhaps it will help. I have a close cousin to it running Slack 8.1 but I think it is a 4 MByte ATI 3D Rage II chip with the video outputs and AMC channel etc. I seem to recall it being called a Video Expression+.
Old 02-26-2003, 10:44 AM   #3
Registered: Feb 2003
Location: Texas
Distribution: slackware 11
Posts: 90

Original Poster
Rep: Reputation: 15
Thanks. That did put me in framebuffer mode and now I can start X.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems starting X Dreamcatcher Slackware 8 11-14-2004 05:00 PM
problems starting X Diminished7th Linux - Laptop and Netbook 1 06-21-2004 04:59 PM
Problems starting X aidankitch Linux - Software 4 04-21-2004 02:25 PM
problems starting X on RH 7 Dynamo Linux - Newbie 16 08-16-2001 08:30 PM
Problems starting up 6.1 elrond25 Linux - Distributions 3 10-17-2000 08:41 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:40 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration