-   Slackware (
-   -   problems running php on slackware 9.1 (

uglyugly 01-29-2004 05:11 PM

problems running php on slackware 9.1
i have install full slackware gnu/linux 9.1

apache is running. i have checked it at hxxp://localhost

when ever i try to run a php file it gives the bellow error


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@midas.slackware.lan and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

here is the error log entry


Apache/1.3.28 Server at mailserver.localdomain Port 80

[Fri Jan 30 02:38:28 2004] [error] [client] Premature end of script headers: /var/www/html/omail/
[Fri Jan 30 02:39:51 2004] [notice] caught SIGTERM, shutting down
[Fri Jan 30 02:53:32 2004] [notice] Apache/1.3.28 (Unix) configured -- resuming normal operations
[Fri Jan 30 02:53:32 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Fri Jan 30 02:54:21 2004] [error] (8)Exec format error: exec of /var/www/html/squirrelmail-1.4.2/index.php failed
[Fri Jan 30 02:54:21 2004] [error] [client] Premature end of script headers: /var/www/html/squirrelmail-1.4.2/index.php
i have setup the Diretory entry and other entry to properly point to the paths

when is browse to the parent path it shows a directory listing of all the files.

i have chmod 755 the .php file

ScriptAlias is set to cgi and php

php module is loaded

the php script is of squirrelmail web based mail and rest of teh settings (qmail, apache, courrier, vpopmail, vqadmin and qmailadmin are working correctly) are ok

I am lost :confused:

JohnKFT 01-29-2004 06:22 PM

I cannot remember now the errors I got but I could not get php to work on Slack 9.1. Neither can I remember exactly what I did to fix it but I am fairly sure it was to uncomment this line right near the end of /etc/apache/httpd.conf :

Include /etc/apache/mod_php.conf

This is line 1065 in mine.

Good luck.

All times are GMT -5. The time now is 07:55 AM.