-   Slackware (
-   -   Problems installing lilo with RAID/LUKS/LVM - 13.1(64) (

NyteOwl 03-09-2011 02:13 PM

Problems installing lilo with RAID/LUKS/LVM - 13.1(64)
Basic Problem: I have been trying to install 13.1 (64-bit) and have not been able to get lilo to install.


1) partitioned drive /dev/sdc 1GB (Linux RAID) and 499GB (Linux Raid)
2) copied partitioning scheme to /dev/sdd
3) set up RAID-1 arrays md0 (sdc1-sdd1) and md1 (sdc2-sdd2)
4) write random data to partitions
5) set up LUKS on md1 (swluks)
6) set up LVM on swluks (80GB /, 375GB /home, 20GB swap)
7) ran setup, chose partitions, installed software
8) setup lilo (mbr, selected /)
9) TRIED to install lilo

Now the problem. The installation screen for lilo just sits there, no response. When one eventually ctrl-c's out of it lilo.conf has been written.

10) run mkinitrd and edit /etc/lilo.conf (md0 unencrypted is /boot)
11) run lilo

Apparently no /etc/fstab is being written and if you then try an boot all you get is LI 01 99 99 99 ...

All procedures were followed per the appropriate readme files (RAID/CRYPT/LVM/initrd). The same occurs trying to do a 32-bit install.

It's probably me missing something but for the life of me I don't know what.

Any thoughts or suggestions (polite ones :) ) are appreciated.

mostlyharmless 03-09-2011 02:57 PM

I haven't tried lilo from the install screen procedure recently. I recall having a similar problem once, however, which was solved by rebooting from the DVD, manually mounting raid, luks etc, chrooting and running lilo from the console.

However, these days I use grub (found in /extras) which works great, and supports RAID-0 on boot also.

Hope that helps, a bit.

NyteOwl 03-09-2011 03:13 PM

Thanks for the reply. The mkintrd and editing lilo.copnf were done from chroot. I tried rebooting from the DVD and working thorugh, run lilo manually but get the same result.

Never tried grub as all I've ever needed is a basic bootloader like lilo. RAID-0 is a non-starter (actually not even properly RAID but that's another topic :) )

mRgOBLIN 03-09-2011 04:49 PM

I've not had much experience with LUKS on RAID but usually have no issues with Lilo on RAID.

I always chroot in to the new install to set up the initrd and lilo.

Something like this usually works for me.


raid-extra-boot = /dev/sda,/dev/sdb
boot = /dev/md0

NyteOwl 03-11-2011 04:09 PM

yes, those are usually im my lilo.conf when using raid1 as well.

I have tried everything I can think of and I cannot get Slack to finish its install by installing lilo.

The last time I tried it appears that there was no /etc/fstab created either.

All times are GMT -5. The time now is 07:21 PM.