-   Slackware (
-   -   problems building fontforge from SBo (

gtludwig 05-12-2010 10:45 AM

problems building fontforge from SBo

I'm using Slackware64-current here and have tried to go multilib using alienBOB's how-to I got here.

AFAIK, it installed ok but when I try to install Wine's dependencies fontforge and webcore-fonts using SBo's SlackBuild, I get the error log I posted on this pastebin.

Kinda lost here... Thoughts are welcome! =)

Thanks in advance!

ponce 05-12-2010 01:24 PM

you need two fixes for fontforge on -current, you can have a look here for a patch (for the new libpng) and a small correction to the slackbuild (for the new bash).

gtludwig 05-12-2010 01:35 PM


err, I'm sorta of a newbie on patching... what files I need and how do I apply the patchs?


ponce 05-12-2010 01:40 PM

easiest way is to download the slackbuild's .tar.gz (everything you need is inside), unpack and then use it like the SBo's one. :)

gtludwig 05-12-2010 02:03 PM


Something else is broken... pastebin is here. gdraw??

thanks so far! =)

ponce 05-12-2010 02:37 PM


/usr/include/cairo/cairo-ft.h:47:22: error: ft2build.h: No such file or directory

$ grep ft2build.h /var/log/packages/*

maybe you are missing the standard freetype package from slackware64, try installing/upgrading that before building fontforge.

gtludwig 05-12-2010 02:48 PM

I uninstalled it because I thought only the -compat32 was enough... obviously not!

fontforge installed!

thank you!

ponce 05-12-2010 02:52 PM

I think include files for building are only in the native packages, not in -compat32 (I suppose to avoid the same files in two different packages).

glad it worked :)

All times are GMT -5. The time now is 11:39 PM.