-   Slackware (
-   -   Problems booting from Aliens Mini-iso made using -current (

TSquaredF 02-22-2013 02:57 PM

Problems booting from Aliens Mini-iso made using -current
I run -current on both an HP desktop & a Toshiba laptop. I recently decided to re-install -current on the desktop. Since I have the entire -current tree mirrored on the second drive on the desktop, I used the laptop to make a Mini-install disk from Alien's program. I took the disk & booted the desktop. During the installation, I realized that the disks on the desktop were appearing as sde, sdf (the internal drives) & sdg (an external usb drive) instead of sda, sdb & sdg. I checked the wiring & the internal disks were plugged into SATA0 & SATA1. I tried a System Rescue disk & it showed the disks as sd{a,b} & sdg, which is what I would expect. I tried my official Slackware-14 DVD, & the drives were sd{a,b} & sdg. I then went back to the Mini-install disk went through the installation. On the first boot, the software cratered when it got to running the fsck on the root partition, saying the partition could not be found. I booted from the System Rescue disk & finally changed all references in /etc/fstab from /dev/sd{e,f} to /dev/sd{a,b}. The system then booted & ran perfectly. After a couple of days, I went back in & changed references in /etc/fstab from /dev/sdX to LABEL=whatever, & again all is well.
Also, booting the laptop with all three of the disks I used on the desktop shows the one disk as sda, as it should.
What is causing my Mini-install disk to misread the disks in my desktop?

slackass 02-22-2013 04:21 PM

It's also doing it with a Slack64-Current DVD. It lists my sda drive as sde. (useing grub leg)
I tried installing current form my local mirror with the Slack64-14.0 disk and got a kernel panic.
When I install to a box with only 1 hard drive and lilo as a boot loader and no card readers the -Current DVD works.

I installed Slack-14.0 to the same partition and used slackpkg to upgrade to -Current and also got the kernel panic.

TSquaredF 02-22-2013 05:53 PM

For what it's worth, I'm using grub2 & gpt partitions. I'm going to redo my Mini-install disk on the desktop to see if that will change anything, but I'm betting it won't.

Edit - Made no difference at all. Mebbe some quirk with kernel-3.7.1?

slackass 02-22-2013 06:39 PM

Ok, I just did a re-install of Slack64-14.0 on the same partition and hooked slackpkg up to my local -Current mirror. This time I blacklisted the kernel and upgraded to -current and the problem went away. The system boots now. I guess the kernel don't like me...

slackass 02-24-2013 02:36 AM

Ok, I had some time to mess around with this and here's what I found.
Using a 86_64 -Current dvd burnt 02.20.13 the installer listed my 1st and 2nd drives as sde & sdf.
I unplugged my card reader and then the installer listed them correctly and did an install which worked perfect.
I shut down the box and plugged in the card reader and booted to the same old familiar kernel panic that I've been getting for the past few days.
This box has:
AMD quad core
Asus mobo
Lian-Li card reader

sda1 Win7 64
sda7 Slack64-C
sda8 Slack64-14.0
sda9 Slack64-14.0
using grub leg

Yesterday I installed Slack64-14.0 to sda7 and upgraded to -current without the new kernel and it worked perfect. I then upgraded the kernel and got the panic back.

All times are GMT -5. The time now is 04:09 PM.