LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-21-2004, 07:44 AM   #1
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Problems after upgraging to Slack 10: mouse, sound


I upgraded to Slack 10 from 9.1 today. I have a few problems:

1) I cant use scroll mouse inspite of adding "option" "ZAxisMapping" "4 5" to the XF86Config file. This is what the section looks like:

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"

Option "ZAxisMapping" "4 5"

Option "Resolution" "800"

EndSection

2) I can't play sound. I changed the permission of the stuff related to sound in /dev/ but I later realized that I cant play sound even as root.

I had changed the kernel booting in LILO while upgrading. I boot "vmlinuz-ide-2.4.26" I have a feeling I'll have to recompile this. Can anyone help me solve this without a kernel recompile (if it needs one, that is)? Any suggestions?

Thanks
 
Old 07-21-2004, 09:09 AM   #2
tveiga
LQ Newbie
 
Registered: Jan 2004
Location: Portugal
Distribution: Slackware 9.0
Posts: 16

Rep: Reputation: 0
For the mouse scrolling you have to add the following line:
Option "Buttons" "#"
where # is the number of buttons in your mouse, in my case its 5.

Hope it helps.
 
Old 07-21-2004, 09:30 AM   #3
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
For your sound problems: what sort of sound card do you have? Can you give us the output of "lsmod" too?
 
Old 07-21-2004, 10:49 AM   #4
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Original Poster
Rep: Reputation: 30
I added the line for buttons in the XF86Config file and restarted X. But the scroll still doesnt work. This is what I added: Option "Buttons" "3"
The mouse scroll worked in Slack 9.1 even without the "buttons" option.

As far as the sound problem is concerned, my card isn't being detected. Here is the output of 'lsmod' :-
Module Size Used by Not tainted
soundcore 3396 0 (autoclean)
uhci 24444 0 (unused)
usbcore 59308 1 [uhci]
tulip 40352 1
crc32 2880 0 [tulip]
pcmcia_core 39972 0
ntfs 51424 3 (autoclean)
ide-scsi 9328 0
agpgart 43940 0 (unused)

edit: I have an on-board card, Intel-i845 mobo, AC'97 sound card

Last edited by akudewan; 07-21-2004 at 10:58 AM.
 
Old 07-21-2004, 01:00 PM   #5
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
Try "modprobe snd-intel8x0" or "modprobe i810_audio". If either one of these works*, edit /etc/rc.d/rc.modules and find the line in there that would load it and remove the "#" from the beginning to activate it. This will cause it to load automatically when you reboot in the future. If the line doesn't exist, add, at the end of the file, whatever it was you originally had to type to get it working (you may need to replace modprobe with /sbin/modprobe).

*To get it working, you may need to adjust the volume settings. If it looks like everything's working, but you don't hear any sound, try running "alsamixer". If that fixes things, run "alsactl store" to fix the volume permanently.

If, at any point along the way, you get an error message or other problems, post them here.
 
Old 07-21-2004, 02:07 PM   #6
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Hi,
For your mouse problem, you need to be looking for /etc/xorg.conf as Slack 10 uses Xorg instead of Xfree86 as the Xwindowing system. Just ad the lines for your mouse there, or even easier is to copy your x86config.conf to xorg.conf.
For your sound, if you can send the results of an lspci, it will tell whether the kernel is detecting your onboard card. It seems to be a fairly well documented problem when changing kernel. You may need to uninstall ALSA and reinstall it to get it to work.
 
Old 07-21-2004, 08:03 PM   #7
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Original Poster
Rep: Reputation: 30
Thank u vdemuth, my mouse is scrolling away!!

But sound still doesnt work. I did a "modprobe snd-intel8x0" and "modprobe i810_audio" as oot said. I got a "Can't locate module snd-intel8x0" for the former and I got no output for the latter (that is: modprobe i810_audio).

So I figured that the i810_audio thing worked. Then I edited my /etc/rc.d/rc.modules but there was no line that was related to i810_audio. So I just added the line at the bottom. I rebooted the PC and found that there is still no sound working

This is the output of lspci:
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 05)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 05)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 05)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 05)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 05)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 05)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
02:0a.0 Ethernet controller: Accton Technology Corporation EN-1216 Ethernet Adapter (rev 11)
 
Old 07-22-2004, 01:16 AM   #8
SBing
Member
 
Registered: Mar 2004
Posts: 519

Rep: Reputation: 35
Have you run:

# alsaconf

(The # indicates the command must be run as root)

It is a far easier way of setting up your card, especially if it's a generic well supported card, like the intel8x0 chipset cards.
 
Old 07-22-2004, 07:46 AM   #9
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
Try running "alsamixer" now... for some reason, the volume tends to be way down/muted by default. When you are done with alsamixer, run "alsactl store".
 
Old 07-22-2004, 09:35 AM   #10
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Original Poster
Rep: Reputation: 30
When I run alsaconf, I get the blue screen thing and it tries to look for the card. But then I get a message "No Supported PnP of PCI card found. Would you like to probe legacy sound cards/chips?" I selected "Yes" first but it was useless, as I got a list of some ancient soundcards.

I can't run alsamixer, I get this error: "alsamixer: function snd_ctl_open failed for default: No such device"

Would reinstalling alsa correct this?
 
Old 07-22-2004, 09:46 AM   #11
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
Quote:
Originally posted by akudewan
When I run alsaconf, I get the blue screen thing and it tries to look for the card. But then I get a message "No Supported PnP of PCI card found. Would you like to probe legacy sound cards/chips?" I selected "Yes" first but it was useless, as I got a list of some ancient soundcards.

I can't run alsamixer, I get this error: "alsamixer: function snd_ctl_open failed for default: No such device"

Would reinstalling alsa correct this?
I don't know what sound card you have installed, however I may have a suggestion. I NEVER could get Linux (Mandrake, RH, Fedora) to detect my wife's 7+ year old IBM Thinkpad audio card. When I installed Slack 10 on it recently I did the "alsaconf" thing and it listed "neomagic", the chipset for her video/audio/modem board. Unfortunately, EVERYTIME I used that driver, the audio did NOT work. (That's exactly what happened in all the other distros) Soooooo, I tried "alsaconf" again and had it check for legacy cards. Well, when it was done detecting it gave me a list of 1 sound card. To my knowledge the card was NOT correct, but I figured I would give it a shot. BAM....it worked. My wife's laptop had sound for the FIRST time under Linux.

Moral of the Story:

If the "right" driver does NOT work, try a legacy driver....even if the driver doesn't sound right to you. As long as your sound works....you should be happy.
 
Old 07-22-2004, 10:40 AM   #12
Crashbox
Member
 
Registered: Jun 2004
Location: USA
Distribution: Slackware
Posts: 137

Rep: Reputation: 22
ok, we know yorur card is supported. it is a pretty common card. now, i had this same thing happen when i upgraded a box from 9.1 to 10 and the solution was prety simple (in fact, this solution seems to correct all of my alsa problems).

since alsaconf didn't find your card and you know your card is supported, here is what you need to do.....uninstall the alsa packages (there should be 4: alsa-driver, alsa-oss, alsa-lib and alsa-utils...use the pkgtool to remove all four at once) and then reinstall them. make sure you use the most current ones. if you have the Slack 10 cd's, use those, if not go to one the mirrors and look under slackware-current. the easiest way IMO to do the reinstall would be to copy the 4 files to /tmp then cd to /tmp and run 'installpkg alsa*.tgz'

once the reinstall is done, run alsaconf and you should be fine. after that make sure yo adjust your setting with 'alsamixer' and then save those settings by running 'alsactl store'


good luck

-crash

Last edited by Crashbox; 07-22-2004 at 10:41 AM.
 
Old 07-22-2004, 11:16 AM   #13
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Original Poster
Rep: Reputation: 30
This is sooo weird...I upgraded to Gnome 2.6 today (was using 2.4 earler) and sound started working!!! I have a few problems with Gnome but thats in no way related to any of this, so I'll start a new thread for that.

If anyone has an explanation as to why my soundcard prefers Gnome 2.6 and not 2.4 post it here.

Last edited by akudewan; 07-22-2004 at 07:54 PM.
 
Old 07-24-2004, 10:36 PM   #14
wrchipman
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 3

Rep: Reputation: 0
Lightbulb

I had the same EXACT problem. What you need to do is add snd-intel8x0m to /etc/hotplug/blacklist .
Then reboot. This will stop linux from loading the modem sound drivers and alsamixer will run just fine.

The only prob I have is there is no sound from netscape when running a flash video. Any ideas????
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse problems in Slack 10 Diminished7th Linux - Hardware 3 07-01-2004 01:29 AM
USB Mouse problems + SuSE not happy with Slack dhbiker Slackware 5 02-11-2004 08:33 AM
Mouse problems with Slack 9... G3M1N1 Linux - Software 2 03-28-2003 02:29 PM
USB Mouse problems in Slack Sinestral Slackware 5 02-23-2003 03:29 PM
Mouse Problems with KDE 3.0 (Slack 8.1) Sparky Linux - Newbie 33 02-19-2003 06:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration