LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-07-2005, 09:24 AM   #1
sys7em
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Slackware
Posts: 158

Rep: Reputation: 30
Problems after upgrading php and apache :(


Here's the thing I have upgraded apache and php from slack current and now when I try ti start the web server it gives me the following error:

Syntax error on line 6 of /etc/apache/mod_php.conf:
Cannot load /usr/libexec/apache/libphp4.so into server: libidn.so.11: cannot open shared object file: No such file or directory
/usr/sbin/apachectl start: httpd could not be started


How should I fix that ?
 
Old 09-07-2005, 10:08 AM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,325

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Did you try to upgrade libidn package as well ?
 
Old 09-08-2005, 12:36 AM   #3
sys7em
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Slackware
Posts: 158

Original Poster
Rep: Reputation: 30
Interesting but there was no libidn package installed at all ....

After installing it ... everything is going well

10x
 
Old 09-08-2005, 12:46 AM   #4
sys7em
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Slackware
Posts: 158

Original Poster
Rep: Reputation: 30
I needed to upgrade also the mysql package ... because there were some incompatibilities ...


Cheers )))
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading PHP without disrupting stable Apache 2.0 install Jake_B Linux - General 7 07-07-2004 09:39 AM
Upgrading Apache/PHP on Redhat 9 Djelibeybi Linux - Software 3 07-06-2004 01:09 PM
upgrading PHP on a RH9 server with default apache installation praefex Linux - General 4 06-29-2004 09:48 AM
Upgrading Apache MySQL PHP on RH9 TheLimey Linux - Newbie 0 05-22-2004 03:51 PM
upgrading apache & php on RH9 FunkFlex Linux - Software 0 04-28-2003 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration