-   Slackware (
-   -   Problems after slackware upgrade to current - can't boot (

adrian2009 04-07-2010 03:52 AM

Problems after slackware upgrade to current - can't boot
I just upgraded Slackware 13.0 to current on one of my machines, but i can't boot to linux now, it says "VFS cannot open root device "308" or unknown-block....Please append a correct "root=" boot option, here are the available partitions" and below are the partitions on my computer but with sd* names instead of hd*, hda8 is sda8, hdb1 is sdb1 etc.

I tried this: I boot using the slackware cd-1, then i did this:
mkdir /mnt/slack
mount /dev/hda8 /mnt/slack
mount --bind /dev/ /mnt/slack
mount -t proc proc /mnt/slack/proc

chroot /mnt/slack /bin/bash

Then i tried changing the lilo.conf file and changing the names from hd* to sd*, but when i did lilo -v it showed me error, and when i tried booting again, the lilo setup was not changed, so it means lilo did not execute properly. (It showed some warrnings/errors when i ran lilo, something like "Warning: LBA32 addressing assumed")

I don't know what to do now, please help me, thank you.
Please tell me

linus72 04-07-2010 04:25 AM

yes, its kinda disconcerting heh?

So, you gotta change your /etc/fstab and /etc/lilo.conf

and this is how I chroot into my install; if mounted on /media/disk, change for yours-


mount --bind /dev/ /media/disk/dev
mount -t proc none /media/disk/proc
mount -t sysfs none /media/disk/sys
mount -t devpts none /media/disk/dev/pts

export HOME=/root
export LC_ALL=C

and chroot in


chroot /media/disk
then edit /etc/lilo.conf and /etc/fstab
change any hdxx to sdxx, you know

then do


then exit and umount


umount -l -f /media/disk/proc
umount -l -f /media/disk/sys
umount /media/disk/dev/pts
umount /media/disk/dev

I usually use a livecd for this...

Alien Bob 04-07-2010 06:14 AM

You ran into the issue described in (thanks to Robby Workman for writing up the fix procedure)


symatic 04-07-2010 06:46 AM

I found that UUID is very useful when using the new libata. Soft raid sata and ide mixed nightmare in this box. If Slackware supports UUID I would look into messing around with that, ive never used it with slack. Works wonderfully in other distros though.

Alien Bob 04-07-2010 02:35 PM

Using UUID or LABEL to define your root partition in /etc/fstab works (I use "LABEL=" myself). It works too in /etc/lilo.conf where you define "root = <devicename>".


All times are GMT -5. The time now is 10:19 AM.