LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Problems Accesing Content on Apache (https://www.linuxquestions.org/questions/slackware-14/problems-accesing-content-on-apache-213636/)

brokenflea 08-05-2004 02:43 AM

Problems Accesing Content on Apache
 
i just finished installing Apache, php4, mysql and openssl on a slack 10 box. when i open mozilla and go to link http://localhost/index.php , it opens the page alright, but when i use another computer on the network and use http://ip_addr/index.php, it tells me that the connection was refused.... what am i doing wrong ? i've been scratching my head for ages now. any help would be gladly appreciated.

TIA

brokenflea 08-05-2004 02:56 AM

nm, port 80 wasn't listening and i changed it to another port , and its working now.... thanks anyways

Cedrik 08-05-2004 02:59 AM

Do you run any iptables script ?
Also it may be a setting in /etc/apache/httpd.conf that deny access or an .htaccess file in the directory that contains index.php. Did you look at your error log file ?

try : tail -f /var/log/apache/error_log , and try to access to the web server with the other machine, then look in the log.

If your index.php is in /home/www/ directory for example , try add to httpd.conf (if there are no directive for /home/www) :
<Directory "/home/www">
AllowOverride None
Order allow,deny
Allow from all
</Directory>

[edit]
Great, it is fixed ;) But it is weird that it does not listen the port 80, what have you for Listen directive in httpd.conf ?


All times are GMT -5. The time now is 12:52 PM.