-   Slackware (
-   -   Problem with yafray.SlackBuild (

brianL 10-30-2008 12:09 PM

Problem with yafray.SlackBuild
What's going on here?

root@BrisSGL2:/home/brian/Downloads/yafray# chmod +x yafray.SlackBuild
chmod: cannot access `yafray.SlackBuild': No such file or directory
root@BrisSGL2:/home/brian/Downloads/yafray# ls
README  slack-desc  yafray-0.0.9.tar.gz  yafray.Slackbuild
brian@BrisSGL2:~/Downloads/yafray$ ls -l
total 332
-rw-r--r-- 1 brian users    301 2008-08-31 02:52 README
-rw-r--r-- 1 brian users    783 2008-08-31 02:52 slack-desc
-rw-r--r-- 1 brian users 316033 2008-10-30 13:36 yafray-0.0.9.tar.gz
-rwxr-xr-x 1 brian users  3068 2008-08-31 02:52 yafray.Slackbuild*
-rw-r--r-- 1 brian users    254 2008-08-31 02:52
brian@BrisSGL2:~/Downloads/yafray$ su root
root@BrisSGL2:/home/brian/Downloads/yafray# ./yafray.SlackBuild
bash: ./yafray.SlackBuild: No such file or directory

It's obviously there, but chmod can't see it. Strange?

bgeddy 10-30-2008 12:20 PM

I wonder if the file has odd characters in it's name ? Have you tried tab completion to chmod it or mv it to something else ? Perhaps single quoting and globbing to achieve the same ?

brianL 10-30-2008 01:07 PM

Thanks, bgeddy. Tab completion worked. Just typed in chmod +x ya<TAB>, got yafray, .Sl<TAB> and got SlackBuild. Then ./yaf<TAB>, and it completed and built. Never come across that before.

keefaz 10-30-2008 01:09 PM

Look closely :)
yafray.Slackbuild => exists
yafray.SlackBuild => does not exist

brianL 10-30-2008 01:22 PM

Aaaah...YES!! Must get glasses changed!!! I'm that used to typing in SlackBuild, that I just took it for granted. (Brian kicks himself) Thanks, keefaz. :o :)

keefaz 10-30-2008 01:26 PM

It happens :)
Note however that official filenames for slackbuild scripts are <package>.SlackBuild
(eg uppercase B in Build)
Not a big deal though...

brianL 10-30-2008 01:55 PM

Yeah, that's the first lower case b I've seen in SlackB...uh..builds.

pwc101 10-30-2008 01:57 PM

Tab-autocomplete: I worship at thy alter! ;)

In a non-religious manner, of course.

All times are GMT -5. The time now is 06:46 PM.