-   Slackware (
-   -   Problem with uniform look for Qt and GTK apps (

alexbrui 04-10-2011 08:18 AM

Problem with uniform look for Qt and GTK apps
I'm running Slackware 13.1 with Openbox as WM and want to setup Qt and GTK applications to have unifom look. As I understand, for Qt apps this can be done with QGtkStyle.

I setup GTK theme and icons, then run qtconfig and from GUI style combobox select GTK+. At this moment I receive error message in console

QGtkStyle was unable to detect the current GTK+ theme.
I google around it and find several topics that suggests to add to the ~/.profile next string

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
So I add this line, but this don't help. Even after reboot I get same error when try to run qtconfig again.

Any hints how to solve this issue?

dugan 04-10-2011 08:55 AM

When I want a uniform look, I just get matching GTK and Qt themes, e.g. by downloading an Oxygen theme for GTK2's widgets and icons.

brixtoncalling 04-10-2011 09:13 AM

You can use the QtCurve-KDE4 and QtCurve-Gtk2 packages from Slackbuilds.

alexbrui 04-10-2011 12:42 PM

Maybe QtCurve is a solution, but QGtkStyle is already available in system, so why not use it?

brixtoncalling 04-10-2011 12:50 PM

Maybe QGtkStyle doesn't work. I know for sure that QtCurve does... It's just a suggestion.

alexbrui 04-12-2011 02:49 PM

Seems that problem in Slackware's Qt library, it compiled without --gtkstyle option. Anyone know why?

solarfields 04-12-2011 04:38 PM

check AlienBob's blog:

rg3 04-12-2011 05:28 PM

In the same line as QtCurve, I use Oxygen-Gtk:

I load it from ~/.gtkrc-2.0.

All times are GMT -5. The time now is 06:47 AM.