LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   problem with kfmclient (https://www.linuxquestions.org/questions/slackware-14/problem-with-kfmclient-4175698409/)

Toutatis 07-28-2021 02:11 PM

problem with kfmclient
 
kfmclient openURL ....

(in slackware64-current) in KDE
It does not work from an application or the command line. It seems that konqueror tries to run (it appears is the task manager). It is impossible to get rid of it. If I quit X and go back to the console, and then restart kde, konqueror is not in the task manager. But kfmclient is still running and htop shows that is uses a lot of CPU.

enorbet 07-29-2021 10:17 AM

Are you on a "Full Recommended Install"? I haven't used kfmclient in ages but I tried it from CLI because of your thread and it works for me on a Full and updated Current install.

Toutatis 07-29-2021 10:36 AM

I don't use kfmclient, but it is used by some other programs (for example signal) to open web pages.
It works now since I have replaced konqueror with firefox (as default browser). I don't know why it fails with konqueror. It should work better with kde applications.

I have a full slackware64-current (except the kernel that I don't change evey time). But maybe I should start a new configuration of kde (after deleting my user .kde/).

enorbet 07-29-2021 10:48 AM

I can only speculate that the support for konqueror is so convoluted and widespread the dev team just haven't bothered to dismiss it as a web browser despite it's rather primitive function as a web browser. Mine works... it just looks ancient and has problems with some web pages and file formats.

FWIW browsers have evolved rather radically over the years and Konq has not kept up. It's actually fairly amazing it still works in that area at all. The biggest problem I've witnessed in running older versions of Slackware is the inability to update Sea Monkey or Firefox to versions that have full modern function. Kong is by no means fully modern but it is substantially better than, say, Firefox 2.0.0 from Slackware 12. That one barely functions anymore.


All times are GMT -5. The time now is 10:01 PM.