LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-02-2018, 09:22 PM   #1
GreenFireFly
Member
 
Registered: Jul 2013
Posts: 217

Rep: Reputation: Disabled
Question Problem with gstreamer not playing video.


Hello Everyone,


I'm running slackware 14.2 32bit. When ever the package gstreamer-1.6.4-i586-1.txz is installed the videos on wine-3.0.2 Metal Gear Solid 2 will not work.

Here is a video of Metal Gear Solid 2 without gstreamer-1.6.4-i586-1.txz installed. The movies play.

https://streamable.com/d4jgm

Here is a video of Metal Gear Solid 2 with gstreamer-1.6.4-i586-1.txz installed. The movies don't play.

https://streamable.com/fgpme

I have tried installing gst-plugins-bad,gst0-plugins-bad,gst-plugins-ugly and gst0-plugins-ugly. The only difference with those
plugins installed is i get this error on the terminal.

** (wine:9945): CRITICAL **: gst_base_parse_finish_frame: assertion 'size > 0 || frame->out_buffer' failed

Any help in fixing this issue is greatly appreciated.
 
Old 09-02-2018, 11:34 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,456
Blog Entries: 15

Rep: Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157
Hi:

From the description you gave it sounds like gstreamer is/could be conflicting with the interface of the game itself. (educated guess)

I looked up the error on google and it's a bug or a least it has been in the past.
https://www.google.com/search?q=CRIT...nt=firefox-b-1

I noticed in the video of Metal Gear Solid 2 with gstreamer-1.6.4-i586-1.txz installed that the terminal was returning:
Code:
failed to restore range
Any idea what range it is complaining about or referring to?

******--------------------------------------******-------------------------------******-----------------

Here's a link to the games forum. Maybe have a look in there and consider registering to ask them about this:-
http://www.neoseeker.com/forums/431/

https://www.linuxquestions.org/quest...h-wine-906981/
 
Old 09-03-2018, 12:50 AM   #3
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,785

Rep: Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752Reputation: 3752
I don't know why gstreamer is causing issues, but I do want to point out that if you have gstreamer installed and it's causing WINE problems, then you can just disable it from winecfg. It's a DLL called "winegstreamer", and you use the Libraries tab.

For Trails in the Sky (and most other Falcom games), I disable winegstreamer; install quartz, amstream and xvid with winetricks; and do "wineboot -u".

Last edited by dugan; 09-03-2018 at 01:12 AM.
 
1 members found this post helpful.
Old 09-03-2018, 01:46 AM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,456
Blog Entries: 15

Rep: Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157
Thanks dugan:-
 
1 members found this post helpful.
Old 09-03-2018, 03:02 AM   #5
GreenFireFly
Member
 
Registered: Jul 2013
Posts: 217

Original Poster
Rep: Reputation: Disabled
I checked online to see which version of wine is said to have worked with Metal Gear Solid 2. So i downloaded wine-1.9.10.
And now Metal Gear Solid 2 works with gstreamer-1.6.4-i586-1.txz installed.

So this is a wine bug.

Thanks to all for your replies.
 
Old 09-03-2018, 09:09 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,456
Blog Entries: 15

Rep: Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157Reputation: 1157
Quote:
Originally Posted by GreenFireFly View Post
I checked online to see which version of wine is said to have worked with Metal Gear Solid 2. So i downloaded wine-1.9.10.
And now Metal Gear Solid 2 works with gstreamer-1.6.4-i586-1.txz installed.

So this is a wine bug.

Thanks to all for your replies.
A bug indeed:-

You're welcome-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen capture while playing video yields to blue window where video is playing kayasaman Linux - Desktop 10 01-19-2012 09:54 AM
Playing video problem (sort of) Rob83 Linux - Software 3 12-16-2010 03:39 PM
Problems playing mp3s with gstreamer apps sharkus Linux - Software 4 10-06-2007 04:15 AM
Video Playing Problem in Ubuntu pwo Debian 2 10-08-2004 08:06 AM
Problem playing video files - please help! Vladlen Linux - Software 4 06-27-2003 08:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration