LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-19-2017, 08:13 AM   #1
gildbg
Member
 
Registered: Aug 2017
Posts: 39

Rep: Reputation: Disabled
Problem with fonts after last current upgrade.


Hello,
I use slakcware current on x86_64. After last upgrade from today Mon Sep 18 19:15:03 UTC 2017
All texts on web pages become very ugly. My kde setup is activated 96 dpi and subpixel. I don't have problems with kde fonts, only with mozilla, terminal.

My custom config is:
Code:
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintmedium</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="autohint">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

Any one can point me some solution ?
 
Old 09-19-2017, 08:31 AM   #2
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,128

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
For firefox maybe it's this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1393467
 
1 members found this post helpful.
Old 09-19-2017, 08:39 AM   #3
gildbg
Member
 
Registered: Aug 2017
Posts: 39

Original Poster
Rep: Reputation: Disabled
Thx,
It's seems this wont be fixes in version 55 of firefox.
 
Old 09-19-2017, 09:28 AM   #4
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,128

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
I will try to rebuild firefox with this patch:

https://git.archlinux.org/svntogit/p...ckages/firefox
 
Old 09-19-2017, 11:26 AM   #5
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,128

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
It seem that it is little better with this patch, but not perfect, for me
 
Old 09-19-2017, 11:39 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,880

Rep: Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915
Quote:
Originally Posted by gildbg View Post
I use slakcware current on x86_64. After last upgrade from today Mon Sep 18 19:15:03 UTC 2017
All texts on web pages become very ugly. My kde setup is activated 96 dpi and subpixel. I don't have problems with kde fonts, only with mozilla, terminal.

My custom config is:
Code:
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintmedium</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="autohint">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

Any one can point me some solution ?
as the latest updates contained a new freetype package could it be that you have mistakenly overwritten your custom configuration in /etc/profile.d/freetype.sh ?

Last edited by ponce; 09-19-2017 at 11:41 AM.
 
Old 09-19-2017, 11:41 AM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,898
Blog Entries: 27

Rep: Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185
Member response

Hi,

My .Xresources file for reference;
Code:
cat .Xresources

XTerm*faceName: Inconsolata
XTerm*faceSize: 10
XTerm*cursorBlink: true
XTerm*cursorUnderLine: true
XTerm*saveLines:  32768
XTerm*locale: true
XTerm*reverseVideo: true
XTerm*utf8: 1
XTerm*termName: xterm-256color
XTerm*autoWrap: true

Xft.dpi: 96
Xft.antialias: 1
Xft.hinting: 1
Xft.hintstyle: hintfull
Xft.lcdfilter: lcddefault
Xft.rgba: rgb
Xft.autohint: 0

URxvt.font: xft:Inconsolata:pixelsize=16
URxvt.saveLines: 65535
URxvt.scrollBar: false
URxvt.reverseVideo: true
URxvt.depth: 32
URxvt*cursorUnderline: true
URxvt*transparent: true
URxvt*shading: 20
URxvt*cusorBlink: false
URxvt*termName: rxvt-unicode-256color

Rxvt*cursorBlink: true
Rxvt*visualBell: true
Hope this helps.
Have fun & enjoy!
 
Old 09-19-2017, 11:53 AM   #8
e5150
Member
 
Registered: Oct 2005
Location: Sweden
Distribution: Slackware and Alpine
Posts: 123

Rep: Reputation: 91
The new freetype defaults to infinality-ish subpixel hinting setting FREETYPE_PROPERTIES to truetype:interpreter-version=35 reverts the behaviour to the sane old hinting engine.
 
Old 09-19-2017, 12:31 PM   #9
andygoth
LQ Newbie
 
Registered: Sep 2017
Distribution: Slackware
Posts: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by e5150 View Post
The new freetype defaults to infinality-ish subpixel hinting setting FREETYPE_PROPERTIES to truetype:interpreter-version=35 reverts the behaviour to the sane old hinting engine.
Running "FREETYPE_PROPERTIES=truetype:interpreter-version=35 firefox" doesn't seem to make any difference. Is there something else I need to do to test this change?

The problem I'm experiencing is the rightmost column of pixels is not being displayed, so for example, depending on the font, "q" looks like "c". Is this the same problem everyone else is having, or do I have some other issue? It started just minutes ago due to me updating to the latest -current, which included a freetype change. My last update was a few days ago, and everything seemed fine then.
 
Old 09-19-2017, 12:36 PM   #10
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,880

Rep: Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915
Quote:
Originally Posted by andygoth View Post
Running "FREETYPE_PROPERTIES=truetype:interpreter-version=35 firefox" doesn't seem to make any difference. Is there something else I need to do to test this change?

The problem I'm experiencing is the rightmost column of pixels is not being displayed, so for example, depending on the font, "q" looks like "c". Is this the same problem everyone else is having, or do I have some other issue? It started just minutes ago due to me updating to the latest -current, which included a freetype change. My last update was a few days ago, and everything seemed fine then.
set it in /etc/profile.d/freetype.sh, logout from your session (and X) and login again.
 
Old 09-19-2017, 12:38 PM   #11
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,693

Rep: Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979Reputation: 2979
Quote:
The problem I'm experiencing is the rightmost column of pixels is not being displayed, so for example, depending on the font, "q" looks like "c". Is this the same problem everyone else is having, or do I have some other issue?
I'm having this issue. So far, Firefox is the only app I've had it with. I don't have a fix.

Quote:
set it in /etc/profile.d/freetype.sh, logout from your session (and X) and login again.
After I set it, I launch xfce from sddm (from ktown), I launch a terminal, and check whether it's set. It's not. I'm going to try to check why not later tonight.

Last edited by dugan; 09-19-2017 at 12:39 PM.
 
Old 09-19-2017, 12:42 PM   #12
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,880

Rep: Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915
here I'm using the new renderer and things seem to look fine
Code:
$ set | grep FREETYPE
FREETYPE_PROPERTIES=truetype:interpreter-version=40
 
Old 09-19-2017, 12:42 PM   #13
andygoth
LQ Newbie
 
Registered: Sep 2017
Distribution: Slackware
Posts: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
set it in /etc/profile.d/freetype.sh, logout from your session (and X) and login again.
I made this change, restarted X, fired up Firefox, but there is no effect. Screenshot:

http://andy.junkdrome.org/forum/badfont.png
 
Old 09-19-2017, 12:44 PM   #14
andygoth
LQ Newbie
 
Registered: Sep 2017
Distribution: Slackware
Posts: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by dugan View Post
So far, Firefox is the only app I've had it with. I don't have a fix.
I'm also experiencing the problem in Thunderbird. No surprise there. It doesn't seem to be happening in vim (gvim).

Quote:
Originally Posted by dugan View Post
After I set it, I launch xfce from sddm (from ktown), I launch a terminal, and check whether it's set. It's not. I'm going to try to check why not later tonight.
I confirmed that this variable is in fact being set for me.

Code:
$ echo $FREETYPE_PROPERTIES 
truetype:interpreter-version=35
 
1 members found this post helpful.
Old 09-19-2017, 12:47 PM   #15
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,128

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
I have rerebuild firefox + this other patch:

https://git.archlinux.org/svntogit/p...ckages/firefox

and the font are really better now .
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Xorg problem after upgrade in CURRENT x86_64 phoemur Slackware 99 10-13-2015 07:59 AM
[SOLVED] Current: Problem with Cisco anyconnect/pango (fonts) vbisis Slackware 2 02-06-2013 03:02 PM
upgrade slack-current with slackpkg, problem with Xorg specialized Slackware 24 07-07-2009 03:32 PM
Problem with evdev and full screen opengl game after upgrade to current dive Slackware 2 02-02-2008 08:43 AM
xfce flickering problem after 2006-02-10 slack-current upgrade firebird Slackware 2 04-08-2006 08:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration