LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-05-2009, 10:53 PM   #1
mfduqued
Member
 
Registered: Dec 2008
Location: Colombia
Distribution: Slackware 12.2
Posts: 33
Blog Entries: 1

Rep: Reputation: 15
Solved: Problem with dvips at slackware


Why dvips does not work, and is as

lpr: Error - scheduler not responding

Last edited by mfduqued; 07-13-2009 at 06:40 PM. Reason: This problem was solved
 
Old 07-05-2009, 11:54 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,278

Rep: Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500
probably you haven't turned on the cups scheduler?
 
Old 07-06-2009, 02:10 PM   #3
mfduqued
Member
 
Registered: Dec 2008
Location: Colombia
Distribution: Slackware 12.2
Posts: 33

Original Poster
Blog Entries: 1

Rep: Reputation: 15
Mr willysr, how to i turned on the cups scheduler?, help me please
 
Old 07-06-2009, 02:26 PM   #4
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,198

Rep: Reputation: 172Reputation: 172
Quote:
Originally Posted by mfduqued View Post
Mr willysr, how to i turned on the cups scheduler?, help me please
As root, do this at the command line:
Code:
chmod +x /etc/rc.d/rc.cups
/etc/rc.d/rc.cups start
That should do it!
 
Old 07-06-2009, 03:12 PM   #5
mfduqued
Member
 
Registered: Dec 2008
Location: Colombia
Distribution: Slackware 12.2
Posts: 33

Original Poster
Blog Entries: 1

Rep: Reputation: 15
stormtracknole,

I do your suggestion but when I do dvips filename.dvi, result as

lpr: Error - no default destination available.
 
Old 07-06-2009, 09:56 PM   #6
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,198

Rep: Reputation: 172Reputation: 172
Quote:
Originally Posted by mfduqued View Post
stormtracknole,

I do your suggestion but when I do dvips filename.dvi, result as

lpr: Error - no default destination available.
Once CUPS is running, you need to define a printer.
 
Old 07-06-2009, 10:11 PM   #7
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,278

Rep: Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500Reputation: 1500
try open http://localhost:631 and then define your printer there
 
Old 07-06-2009, 10:16 PM   #8
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 70
You need to do one more thing, though. Suppose you named your printer in CUPS "lp". Then, run the command
Code:
lpoptions -d lp
in a terminal. After that, dvips will work normally. It just sets the default printer.
 
1 members found this post helpful.
Old 07-07-2009, 02:22 AM   #9
cmk77
Member
 
Registered: May 2006
Location: netherlands
Distribution: slackware, centos, scientificlinux
Posts: 128

Rep: Reputation: 25
maybe you want to print to a postscript file? If so use:
Code:
 dvips filename.dvi -o filename.ps
 
1 members found this post helpful.
Old 07-07-2009, 06:54 PM   #10
mfduqued
Member
 
Registered: Dec 2008
Location: Colombia
Distribution: Slackware 12.2
Posts: 33

Original Poster
Blog Entries: 1

Rep: Reputation: 15
cmk77, thank you

problem is resolved.

Why is it necessary to specify the output file?, this option was not mandatory after compiling a file latex in slack 9.1
 
Old 07-08-2009, 02:05 AM   #11
cmk77
Member
 
Registered: May 2006
Location: netherlands
Distribution: slackware, centos, scientificlinux
Posts: 128

Rep: Reputation: 25
You don't need to specify the output file unless you want it to have a different name. You *do* need to specify the -o, otherwise dvips tries to print directly to the default printer. I guess the configuration of dvips changed since 9.1?

This is from the dvips man page
Code:
 -o name
              The output will be sent to file name If no file name is given (i.e.,
              -o  is  last on the command line), the default name is file.ps where
              the .dvi file was called file.dvi; if this option isnít  given,  any
              default  in  the configuration file is used.
 
1 members found this post helpful.
Old 07-08-2009, 05:36 PM   #12
mfduqued
Member
 
Registered: Dec 2008
Location: Colombia
Distribution: Slackware 12.2
Posts: 33

Original Poster
Blog Entries: 1

Rep: Reputation: 15
cmk77

Thank you for your response.
 
Old 07-08-2009, 08:20 PM   #13
mfduqued
Member
 
Registered: Dec 2008
Location: Colombia
Distribution: Slackware 12.2
Posts: 33

Original Poster
Blog Entries: 1

Rep: Reputation: 15
cmk77

Thank you for your response.
 
Old 07-09-2009, 03:14 AM   #14
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 620

Rep: Reputation: 406Reputation: 406Reputation: 406Reputation: 406Reputation: 406
You can use command "texconfig" to change the default way to print out. texconfig -> DVIPS -> DEST. The default is now '|lpr'. If you just press return, printing will be disabled and the output saved to a file by default.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.0: boot problem & sudo / wifi-radar problem War_Ensemble Slackware 7 01-15-2008 09:49 AM
dvipdf not picking up fonts, but dvips is? f0rmula Linux - Software 5 12-13-2004 11:00 AM
dvips/apsfilter problem bass Slackware 6 09-22-2002 02:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration