-   Slackware (
-   -   Problem when upgrade to kernel 2.4.24 (

little_ball 01-08-2004 08:26 AM

Problem when upgrade to kernel 2.4.24
Hi, recently I upgrade to kernel 2.4.24. I download it recompiled from it upgrade fine, but every time I boot my machine i get this messages in all the boot proccess:

Note: /etc/modules.conf is more recent than /lib/modules/2.4.24/modules.dep

I got those messages in all modules dependencies boot. I don't think thats Ok, maybe is not a big, big problem. but there is a way to resolve this?

waever 01-08-2004 10:28 AM

hmm... did you do make dep while recompiling the kernel?

little_ball 01-08-2004 11:27 AM

No i didn't do that because i download the package kernel-2.4.24.tgz from for install those packages you just have to do:

upgradepkg kernel

I did it before whit version 2.4.23 and didn't have problem at all. So it surprise me that now, did that. I didn't download the kernel source, because i haven't need it upgrading the kernel the way i say before. anyway if someone had the same problem and know any solution for this bug?? maybe could reply.

mrpdaemon 01-08-2004 12:14 PM

run 'depmod' as root.

little_ball 01-08-2004 03:26 PM

I run it depmod as root, but nothing happens it doesn't say nothing to me. I restart my box and still have the message:

Note: /etc/modules.conf is more recent than bla bla

Someone told me that this was a modutils bug, I don't know my worried is that this problem could leave a bug in my box than other people could used to hack me. If this doesn't make any problem like a big bug or something, I don't mind continue receiving this message, cause my Box still works fine, I haven't had any problem at all.

Tinkster 01-08-2004 03:33 PM


Originally posted by little_ball
No i didn't do that because i download the package kernel-2.4.24.tgz from for install those packages you just have to do:

upgradepkg kernel

Someone else jump in here, since I've never used
this way to upgrade a kernel before ....

Will upgradepkg touch his lilo-configuration
and actually make the machine boot the new
kernel without manual interaction?

Little_ball, what output does
uname -r
give you?


little_ball 01-08-2004 03:37 PM

Hello, I got this on:

root@Marian:/home/marian# uname -a
Linux Marian 2.4.24 #6 Turs Jan 8 13:44:46 PST 2004 i586 unknown unknown GNU/Linux
root@Marian:/home/marian# uname -r

Tinkster 01-08-2004 03:54 PM

K, so it does pick up the right kernel.

what does
ls -l /etc/modules.conf
ls -l /lib/modules/2.4.24/modules.dep
give you?

Maybe your problem is a
with a creation date in the future?


poison 01-08-2004 03:58 PM

did you also install the kernel-modules package for 2.4.24 ?

little_ball 01-08-2004 03:59 PM

root@Marian:/home/marian# ls -l /etc/modules.conf
-rw-r--r-- 1 root root 0 Sep 24 2003 /etc/modules.conf
root@Marian:/home/marian# ls -l /lib/modules/2.4.24/modules.dep
-rw-r--r-- 1 root root 136201 Jan 8 03:08 /lib/modules/2.4.24/modules.dep

Excuse me, but what is a creation date? I'm a little lost here. :cry: anyway I hope you people could help me, like you already had before :)

little_ball 01-08-2004 04:02 PM

By the way, I think that yes is true, is the date :cry: I know look at my date, and it was Jan 1 1999 I update it know but the modules kernel still old look:

root@Marian:/home/marian# ls -l /lib/modules/2.4.24/modules.dep
-rw-r--r-- 1 root root 136201 Jan 1 1999 /lib/modules/2.4.24/modules.dep

how can I update it too? does I have to download it again? and install it :(

poison 01-08-2004 04:07 PM

and download
the do an
upgradepkg kernel-modules-2.4.24-i486-1.tgz
this could solve your problem
if it's still naggin you...
<everybody insert the sentence he knows i wanna say> ^^

little_ball 01-08-2004 04:20 PM

I can't do that, because I already have upgrade kernel package, And when i tried to upgrade it again, it skip the package because is installed :( Well I guess i would have to wait to next kernel release and update it whit the correct date. Thanks by the way.

poison 01-08-2004 04:23 PM

could you issue the following command ->
ls /var/log/packages/|grep kernel

and post the output ?

little_ball 01-08-2004 04:33 PM

root@Marian:/home/marian# ls /var/log/packages/|grep kernel

thats give me.

All times are GMT -5. The time now is 08:51 PM.