LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-26-2012, 11:13 AM   #1
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
problem: vlc 2.0.3 playing youtube videos


I have not played a youtube video in vlc for quite some time...
attempted to play some yesterday with no luck.

I am using Alien Bob's VLC 2.0.3.

When attempting to play a youtube video directly from VLC I get:
Quote:
lua demux error: Couldn't extract youtube video URL, please check for updates to this script
Attempted to locate a more up to date youtube.lua file on the forums for VLC but still no luck. I get:
Quote:
SWF compressed file detected
Is there anyone using VLC 2.0.3 and able to play youtube videos directly?

Or does anyone know where I might find a working lua file?

Thanks in advance...
Cheers
 
Old 09-26-2012, 12:17 PM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,092

Rep: Reputation: 186Reputation: 186
Is this helpful?
http://forum.videolan.org/viewtopic.php?f=13&t=102929
 
Old 09-26-2012, 12:56 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086
Copying the following git content as /usr/lib64/vlc/lua/playlist/youtube.lua (after removing /usr/lib64/vlc/lua/playlist/youtube.luac) made youtube videos in vlc-2.0.3 work again for me.

Code:
http://git.videolan.org/?p=vlc/vlc-2.0.git;a=blob_plain;f=share/lua/playlist/youtube.lua;hb=HEAD
Eric
 
Old 09-26-2012, 12:56 PM   #4
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 516

Rep: Reputation: Disabled
Are you using the restricted (or some name like that) version? I think that's the one that is required to play YouTube videos.
 
Old 09-26-2012, 01:06 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086
Quote:
Originally Posted by TommyC7 View Post
Are you using the restricted (or some name like that) version? I think that's the one that is required to play YouTube videos.
The "restricted" version does not have any additional playback capabilities. The only difference is the ability to encode mp3 and aac audio.

Sometimes a youtube movie requires an additional action like being logged on to Google or entering a date of birth. This is something VLC can not deal with. Perhaps that is the original problem.

Eric
 
Old 09-26-2012, 01:16 PM   #6
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 516

Rep: Reputation: Disabled
Ah ok, thank you Alien Bob.
 
Old 09-26-2012, 01:22 PM   #7
Beelzebud
Member
 
Registered: Oct 2010
Distribution: Arch & Slackware
Posts: 96

Rep: Reputation: 29
Quote:
Originally Posted by Alien Bob View Post
Copying the following git content as /usr/lib64/vlc/lua/playlist/youtube.lua (after removing /usr/lib64/vlc/lua/playlist/youtube.luac) made youtube videos in vlc-2.0.3 work again for me.

Code:
http://git.videolan.org/?p=vlc/vlc-2.0.git;a=blob_plain;f=share/lua/playlist/youtube.lua;hb=HEAD
Eric
Just came to see if anyone else was having this issue. This seems to have fixed it! Thanks.
 
Old 09-26-2012, 02:08 PM   #8
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
Thanks everyone for the help.
The link posted by Alien Bob got things working again.
Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
youtube videos download problem? shams Linux - Software 2 03-18-2012 01:35 AM
Problem playing videos on youtube (sound) devnull10 Slackware 7 09-11-2011 09:09 AM
[SOLVED] YouTube videos are playing in black and white piratesmack Slackware 5 03-08-2011 09:40 AM
System crashes when Youtube videos playing cantab Linux - Software 13 07-20-2010 06:01 PM
Fedora 11 Playing youtube videos ceantuco Linux - Newbie 14 11-11-2009 10:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration