-   Slackware (
-   -   Problem Solved - KDE 3.5.2 from Slack-Current (

KuriosD 04-05-2006 03:29 AM

Problem Solved - KDE 3.5.2 from Slack-Current
KDE 3.5.2 was recently added to Slack-Current, and upon upgrading, I found myself with a non-functional KDE. When trying to startx, I was getting an error (something to the effect of "kdeinit failed to start" or somesuch).

Turns out KDE 3.5.2 (et al) have a couple of new dependencies. If you're having the same problem, you likely need to hunt down:
acl -
attr -

Or I'm just stupid, and should have had them in the first place. Either way. :)

Bruce Hill 04-05-2006 04:47 AM

Did you upgrade your entire system to -current?
Both of those apps are in -current since Feb. 28

less /mnt/nfs/paul/backup2/ftp/pub/Linux/Slackware/slackware-current/ChangeLog.txt
Tue Feb 28 20:50:44 CST 2006
a/bash-3.1-i486-3.tgz:  Patched with additional official patches
  bash31-008 through bash31-011.
a/util-linux-2.12r-i486-1.tgz:  Upgraded to util-linux-2.12r.
a/xfsprogs-2.7.11-i486-1.tgz:  Upgraded to xfsprogs-2.7.11.
  Split acl, attr, dmapi, and xfsdump into separate packages and
  moved them into the AP series.  This location was a bit of a judgement
  call since acl, attr, and dmapi contain libraries, but so do some other
  packages outside L.  Anyway, it does seem to me that xfsdump should go
  in AP, and that these packages should all be found in the same place.
ap/acl-2.2.34-i486-1.tgz:  Upgraded to acl-2.2.34, split out of xfsprogs
ap/attr-2.4.28-i486-1.tgz:  Upgraded to attr-2.4.28, split out of xfsprogs

You need to check the ChangeLog before you upgrade less than everything.

Alien Bob 04-05-2006 05:08 AM

The cmplete picture: upgrading packages is not all there is to it... you need to scan the ChangeLog.txt for new packages too. You'll find that only with official Slackware releases it is enough to "upgrade packages", because after an official release no new packages will be added, only patched packages to fix bugs will be released.

Other packages that were added in slackware-current and thus do not become available using "upgradepkg" or tools like swaret and slapt-get if you let them "upgrade" your computer (from the top of my mind, there can be more that I forget):



Alien_Hominid 04-06-2006 01:13 PM

I will add to the list libmusicbrainz and libtunepimp.

dunric 04-06-2006 01:26 PM

I have to agree with Alien Bob.
New dependencies may surprise you only in Slackware-current(ie. testing/development branch). Upgrading only is safe just for releases. So use Current when you know what you are doing, wish to help with testing and don't use it on production boxes.

mdt78727 04-09-2006 11:56 PM

Ordinarily, dependency checking in swaret does resolve these issues -- when it is enabled, and after 'find' or 'slocate' doesn't come up with the relevant libraries.

There are, of course, exceptions -- upgrading to 3.5.2 swaret found attr and acl, but not libtunepimp, a dependency for amaroK (although you should get a warning from 'find' as I did).

All times are GMT -5. The time now is 12:05 AM.