-   Slackware (
-   -   PROBLEM!-Slackware10.1/Xorg on Dell Laptop video:intel Extreme Graphics 2 for mobile (

nofx_scotti 03-12-2005 07:27 PM

PROBLEM!-Slackware10.1/Xorg on Dell Laptop video:intel Extreme Graphics 2 for mobile
I can boot and login as root perfectly, but when I try to enter on X( startx )
I have this Errors:

(EE) VESA(0): No matching modes
(EE) Screen(s) found, but none have usable config

Fatal server ERROR:
no screens found

After that, i tried editing Xorg.conf but I am just a newbie so.. i couldnīt do nothing.
I tried to change HorizSync to 60 because the freq of the LCD is 60Hz but it didnīt worked the same.
Here is some of the Xorg.conf file (itīs just this because i had to copy them on a paper..ugh)

HorizSync 60


VertRefresh 40-90


Driver "VESA"
#Video Ram 4096
#Default Depth 24
Default Depth 32

512 Mb RAM
Intel Celeron 2.4
Intel(r) Extreme Graphics 2 For Mobile
82852/82855 GM/GME Graphics Controler
64Mb shared

chbin 03-13-2005 11:55 AM

$Xorg -configure
$mv /root/ /etc/X11/xorg.conf

nofx_scotti 03-13-2005 03:09 PM

Ok, i tried that and then when i replaced my old xorg.conf with the new one i realised that the new one was MUCH MUCH smaller (and when X runs with it it get a lot of parsing errors and font missing)
.. it was already done.. to undo the changes i replaced it back with xorg.conf-vesa (they seemed to be the same file with small changes)
to set this new xorg.conf i used:
xorgcfg -textmode

It enters on an pretty config form, there i found my Video Card and itīs driver.
The problem is that, now, the X is still not working, now it gets stuck in a black screen.. no way to get out, just rebooting at the power buttom.
If anyone knows the solution.. please help!!

nofx_scotti 03-13-2005 04:19 PM

this is the log file.. how to end font missing errors??(now that i have them)

nofx_scotti 03-16-2005 10:46 PM

Ok, I made it myself, anyway thanks...
here is my xorg.conf

xorg.conf for Dell Latitude 100L

All times are GMT -5. The time now is 10:50 AM.