LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   Problem on compiling mesa git on Slackware64 Multilib (http://www.linuxquestions.org/questions/showthread.php?t=4175446339)

rvdboom 01-19-2013 09:34 AM

Problem on compiling mesa git on Slackware64 Multilib
 
Hi,
I use a slackware64-current system with the latest AlienBob's multilib packages and everything works fine. I use the multilib mainly to run MS Office through Wine for my work.
I usually compile some stuff myself (x264, ffmpeg, libdrm, mesa, things like that, usually git pulls) without any problem.
However, I seem to have a problem compile mesa git recently, the last time I managed to compile it was the 22/12/2012.
Now it fails with the following messages :


Code:

gmake[2] : on entre dans le répertoire « /usr/src/CVS/mesa/src/gallium/targets »
Making all in dri-r300
gmake[3] : on entre dans le répertoire « /usr/src/CVS/mesa/src/gallium/targets/dri-r300 »
  CXXLD  r300_dri.la
/usr/lib/libexpat.so: could not read symbols: File in wrong format
collect2: error: ld returned 1 exit status
gmake[3]: *** [r300_dri.la] Erreur 1
gmake[3] : on quitte le répertoire « /usr/src/CVS/mesa/src/gallium/targets/dri-r300 »
gmake[2]: *** [all-recursive] Erreur 1

It obviously try to link with the 32bits lib instead of going for the 64bits one in /usr/lib64 but can't find out why. The build use proper ARCH and /usr/lib64 dir for libs, everything else compiles fine on this system and creates proper 64bits files. I suspect something wrong in the current mesa code but I'm not knowledgeable enough to know where to fix it.
I use basically the same build options for configure as the official mesa Slackbuild.
If anyone has a clue where to look for, I'm interested!

Alien Bob 01-19-2013 01:31 PM

Try to sneak in a "LDFLAGS=-L/usr/lib64" somewhere appropriate in the SlackBuild script. Slackware's scripts are not written with multilib in mind and sometimes you'll run into this situation where the 32-bit libraries are found first.

Eric

rvdboom 01-20-2013 10:24 AM

Hi, Eric, and thanks for the feedback.
I tried to set the LDFLAGS before configure, before make but to no avail : same problem.
Really weird. My guess is that either there is something weird in mesa's code or my system is a bit flacky.

ml4711 01-22-2013 01:47 PM

Just hide the "/usr/lib", during compilation:

Code:

mount --bind /home/ftp /usr/lib
It works very well.

Morten


All times are GMT -5. The time now is 11:24 AM.