LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-29-2017, 03:40 PM   #1
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Rep: Reputation: 140Reputation: 140
Problem mounting mtp devices in current


I can't mount mtp devices anymore after some of the new updates.
Camera mode that's read only still works in dolphin.
mtp-detect also seems to work.
Code:
I manually translated "File or catalog" and "doesn't exist." because the error message was localized.
File or catalog udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:10.0/usb1/1-2 doesn't exist.
Do anyone else have problem connecting smartphones with latest current?
 
Old 11-30-2017, 08:08 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,198

Rep: Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137
it seems to work here with my LG phone, I'm using pcmanfm as a file manager.

what I notice here is that everytime I switch the type of usb connection on the phone, keeping the cable connected, from "charge" to "file transfer" or viceversa, the usb id of the device increments (e.g. from Bus 002 Device 009 to Bus 002 Device 010) and this confuses a little the file manager, see https://i.imgur.com/dTVzhUm.png
 
1 members found this post helpful.
Old 12-01-2017, 11:05 AM   #3
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Quote:
Originally Posted by ponce View Post
it seems to work here with my LG phone, I'm using pcmanfm as a file manager.

what I notice here is that everytime I switch the type of usb connection on the phone, keeping the cable connected, from "charge" to "file transfer" or viceversa, the usb id of the device increments (e.g. from Bus 002 Device 009 to Bus 002 Device 010) and this confuses a little the file manager, see https://i.imgur.com/dTVzhUm.png
Thank you Ponce it tried xfce and there it works, but it's broken in KDE.
I used it in KDE November 28 but after that it stopped working.
Can you or someone else try it in KDE?
If it's KDE then i might try newer kio-mtp and so on.
 
Old 12-01-2017, 11:28 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,198

Rep: Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137Reputation: 2137
Quote:
Originally Posted by Nille_kungen View Post
Can you or someone else try it in KDE?
I can confirm that it doesn't work with dolphin here.
 
Old 12-01-2017, 11:30 AM   #5
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Quote:
Originally Posted by ponce View Post
I can confirm that it doesn't work with dolphin here.
Thanks for confirming that MTP broke in KDE with the last updates.
 
Old 12-22-2017, 03:41 PM   #6
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Updated to current dec20 and now it works again.
When i get some time i will upgrade kernel to 4.14 to see if that changes anything.
 
Old 12-22-2017, 04:52 PM   #7
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Tried kernel 4.14.7 and it doesn't work in KDE with that kernel, downgrading to 4.9.67 and it works again.
It's a bit strange that it works with xfce but not kde.
That's one more thing that 4.14 screws up.
 
Old 01-12-2018, 09:56 AM   #8
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Updated to current and 4.14.12 still breaks MTP.
I hope i can set some time aside to bisect the kernel.
Maybe i'm the only one on current using KDE4 still and MTP devices
 
Old 01-12-2018, 12:53 PM   #9
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,511

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Quote:
Originally Posted by Nille_kungen View Post
Updated to current and 4.14.12 still breaks MTP.
I hope i can set some time aside to bisect the kernel.
Maybe i'm the only one on current using KDE4 still and MTP devices
Yes, the proplem is the same here also , on kde4 and plasma5 with kernel 4.14, but
it work perfectly and even better as camera, or with the ptp protocole than with the mtp protocole.
 
Old 01-12-2018, 01:56 PM   #10
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Quote:
Originally Posted by gmgf View Post
Yes, the proplem is the same here also , on kde4 and plasma5 with kernel 4.14, but
it work perfectly and even better as camera, or with the ptp protocole than with the mtp protocole.
PTP has no write privileges so doesn't help me much.
 
Old 01-12-2018, 02:06 PM   #11
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 5,066

Rep: Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864
Quote:
Originally Posted by Nille_kungen View Post
PTP has no write privileges so doesn't help me much.
Ever since Android got rid of USB storage mode, I've had problems with the alternatives. MTP has always been hit or miss for me (both on Windows and Linux). So I stopped using it and pretty much just use either wireless transfers (usually sftp) or I plug it in and use adb. adb has always been faster for me than MTP, except you're then limited to CLI. But I'm usually just grabbing pictures, so I can just run:

Code:
adb pull /sdcard/DCIM/
 
Old 01-12-2018, 02:27 PM   #12
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 403

Rep: Reputation: 175Reputation: 175
I always use Thunar for MTP file transfers. Dolphin doesn't work for me, too.
 
Old 01-12-2018, 02:42 PM   #13
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 446

Original Poster
Rep: Reputation: 140Reputation: 140
Quote:
Originally Posted by bassmadrigal View Post
Ever since Android got rid of USB storage mode, I've had problems with the alternatives. MTP has always been hit or miss for me (both on Windows and Linux). So I stopped using it and pretty much just use either wireless transfers (usually sftp) or I plug it in and use adb. adb has always been faster for me than MTP, except you're then limited to CLI. But I'm usually just grabbing pictures, so I can just run:

Code:
adb pull /sdcard/DCIM/
I'm not trying to be the guy that's never happy with anything but that doesn't help me.
I use an sailfishX device (Sone Xperia X with sailfish OS) i can transfer with scp since it's pure linux and i can ssh to the device and bluetooth transfers also works, i can use sftp from dolphin.
I can get it working it's only that dolphin is my default and i want MTP to work again.
 
Old 01-12-2018, 02:52 PM   #14
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 5,066

Rep: Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864Reputation: 2864
Quote:
Originally Posted by Nille_kungen View Post
I'm not trying to be the guy that's never happy with anything but that doesn't help me.
I use an sailfishX device (Sone Xperia X with sailfish OS) i can transfer with scp since it's pure linux and i can ssh to the device and bluetooth transfers also works, i can use sftp from dolphin.
I can get it working it's only that dolphin is my default and i want MTP to work again.
I just provided it in case... There was someone else who decided to use adb as an alternative (at least temporarily) since MTP wasn't working for them.

I do miss the ease of use of browsing through dolphin, so I certainly understand that my setup doesn't work for everyone.
 
Old 04-11-2018, 02:32 PM   #15
slacktroll
Member
 
Registered: May 2011
Distribution: Slackware 14.2
Posts: 109

Rep: Reputation: 15
I think this is solved....

But https://github.com/whoozle/android-file-transfer-linux/ works for me!

Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] The process for the mtp protocol died unexpectedly when mounting Android devices Hasek39 Slackware 1 08-12-2015 02:33 PM
[SOLVED] Accessing MTP devices using Wine? rnturn Linux - Software 9 07-25-2014 07:27 PM
On slack-current: /usr/bin/mtp-getfile -> /tmp/package-libmtp/usr/bin/mtp-connect ? LuckyCyborg Slackware 3 05-03-2010 01:13 PM
Gnome: Auto mounting external devices as first user logged in, not current user yitzle Linux - Software 4 04-01-2008 09:43 AM
MTP Devices in VMware jkfff Linux - Hardware 4 01-17-2007 10:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration