LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-01-2009, 07:10 PM   #1
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian,Ubuntu,Slackware
Posts: 479

Rep: Reputation: 48
Problem mounting Ext4


I get this error:

EXT4-fs: sdb4: Filesystem with huge files cannot be mounted read-write without CONFIG_LSF
 
Old 05-01-2009, 07:24 PM   #2
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 90
This flag is only needed in kernels 2.6.17 up to 2.6.28 for Large Single Files.
And we're talking *LARGE* here: over 2TB...
See here for information on this flag.

If you really have files this large on your file system, how did you mount it before?

If not, there might be something wrong with your sdb4 partition...
Have you mounted it before? Was it OK?

<edit>
I just checked, the standard Slackware kernels all come with CONFIG_LSF=y set in the configuration file.
Have you compiled your own kernel with different settings?
</edit>

Last edited by niels.horn; 05-01-2009 at 07:34 PM.
 
Old 05-01-2009, 08:47 PM   #3
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian,Ubuntu,Slackware
Posts: 479

Original Poster
Rep: Reputation: 48
The Ext4 partition in question is a Ubuntu / partition.
I did in fact compile my own kernel...
Where is this CONFIG_LSF option? Would it be in the file systems section?

Thanks!

Update:
Sorry, found it. Just opened the .config file and set it by hand

Last edited by mattydee; 05-01-2009 at 08:51 PM.
 
Old 05-01-2009, 09:12 PM   #4
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 90
ok, on my notebook here I run the 2.6.29.2 kernel (that does not have this flag anymore) from slackware-current so I couldn't answer you right now where to find in it menuconfig...

Tell me if it worked setting it to "=y"... This message was something new for me and it seems that the new ext4 filesystem needs it.
I have played around with ext4, testing it on some systems but not on production machines yet and always with standard kernels.

We learn something new every day...
 
Old 05-01-2009, 10:44 PM   #5
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian,Ubuntu,Slackware
Posts: 479

Original Poster
Rep: Reputation: 48
Yep! That worked. Thanks!
 
Old 05-02-2009, 09:40 AM   #6
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 90
For the curious... (I'm at a standard Slackware 12.2 machine now with 2.6.27.7 kernel)

This option can be found in the configuration menu (make menuconfig) under:
Code:
-*- Enable the block layer  --->
[*]   Support for Large Single Files
The <Help> screen says:
Code:
  ┌─────────────────────────────────────────────────────────────────────────┐ 
  | CONFIG_LSF:                                                             │  
  │                                                                         │  
  │ Say Y here if you want to be able to handle very large files (2TB       │  
  │ and larger), otherwise say N.                                           │  
  │                                                                         │  
  │ If unsure, say Y.                                                       │  
  │                                                                         │  
  │ Symbol: LSF [=y]                                                        │  
  │ Prompt: Support for Large Single Files                                  │  
  │   Defined at block/Kconfig:60                                           │  
  │   Depends on: BLOCK && !64BIT                                           │  
  │   Location:                                                             │  
  │     -> Enable the block layer (BLOCK [=y])                              │
  └─────────────────────────────────────────────────────────────────────────┘
It is built-in by default in all Slackware kernels.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ext4 questions jmite Linux - Newbie 2 03-31-2009 07:50 AM
ext4 on current? grissiom Slackware 7 03-12-2009 08:27 AM
Ext4 and Slackware 12.2 installer problem Slacker Steve Slackware 9 03-04-2009 08:26 AM
From ext3 to ext4 rengo.Java Linux - Software 6 12-27-2008 10:58 AM
Ext4 aukuntin Linux - General 1 09-16-2008 10:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration