-   Slackware (
-   -   problem installing ffmpeg from sbo -- libxvid not found (

ahzthecat 12-01-2012 08:09 AM

problem installing ffmpeg from sbo -- libxvid not found
Hey gang, got a problem. I did a fresh install of Slackware 14 when it came out, and have been slowly reinstalling apps I had been using in 13.37

I have a video project to do, and just installed kdenlive to get it done. Upon running the setup wizard, I realized I'd forgotten to reinstall ffmpeg. No big deal, I wanted a do-over there anyway (when I installed it in 13.37 I failed to include several build options) so I fired up sbopkg, pulled up the ffmpeg package and added these options (all of which were kdenlive dependencies)

I then went to process the build, but it fails with the error:

ERROR: libxvid not found

When I look for libxvid in the sbo package list there is no such package. Has it been superceded by libxvidcore? Does the build script need to be edited? Or am I doing something wrong?

Any help would be much appreciated!

414N 12-01-2012 08:16 AM

It's just the way ffmpeg names xvid in its configure file.
Install xvidcore and the configure script will find it ;)

ahzthecat 12-01-2012 08:25 AM

Well, I thought I had installed xvidcore when I installed kdenlive (it is a dependancy after all) but for some reason the ffmpeg build script wasn't detecting the previous install. Adding xvidcore ahead of ffmpeg in the build cue seems to have done the trick tho.

Anyway, its building now. Thanks 414N.


ffmpeg build and installed, but kdenlive doesn't recognize it. Remove and reinstall kdenlive...

...and kdenlive is still not happy. Looks like I have a kdenlive problem.

vdemuth 12-01-2012 09:16 AM

Can you run it from a console and see what errors are produced. I seem to remember that all of the deps have to be built and installed in a particular order for it all to work, but it has been a while.

damgar 12-01-2012 10:48 AM

For future reference AlienBob as an ffmpeg package in his restricted slackbuilds.

414N 12-01-2012 03:25 PM

I just tried to build kdenlive from scratch using SBo SlackBuilds and I had not issue at all apart needing a more recent version of MLT (0.8.6) than the one used on SBo. On my system I have ffmpeg-1.0.

ahzthecat 12-01-2012 06:33 PM

When I run kdenlive from the terminal, I don't get errors per se. It starts and runs, but without support for the file formats and codecs that are a part of the xvidcore library. It will not import mp4 files, for example.

Apparently kdenlive is picky about where your libxvidcore is installed and if you have multiple copies it throws a fit. Consider this a fit thrown.

ahzthecat 12-01-2012 07:18 PM

Once again, doing things right has saved the day!

Reexamining the sbo docs for MLT, there were dependencies I didn't notice and therefore didn't install. REmove and reinstalled MLT (with all dependencies this time) xvidcore and kdenlive, and now it works. libquicktime and xvidcore need to be installed before MLT or else the whole thing is broken.

BTW, not a fan of how dependencies are specified in the Slack14 sbo. Now that I've figured it out tho, I guess it won't be a problem.

Anyway, yay Kdenlive! Mark this sucker solved!

All times are GMT -5. The time now is 05:10 AM.