-   Slackware (
-   -   problem installing AMD proprietary video driver (

gtludwig 04-05-2013 07:04 AM

problem installing AMD proprietary video driver
My home laptop is a Dell Inspiron 15R with the hybrid video card AMD Radeon HD 7730M.
Last night I installed Slackware64-14.0 (stable) and dropline gnome - which doesn't runs / installs on -current. (BTW, kudos for the great work!)
Then I followed proprietary_graphics_drivers's "AMD (ATI) Catalyst Driver Installation and Configuration" section to the letter.
The driver I got is "".
I blacklisted on /etc/modprobe.d/radeon_blacklist.conf both radeon and radeonhd.
After rebooting into runlevel 3 I ran "# aticonfig --initial -f".
But when I try to "$ startx", I get a segmentation fault at address 0x38 and X gives up.

What am I missing here?

adamk75 04-05-2013 09:50 AM

Pastebin your full /var/log/Xorg.0.log file, please.


gtludwig 04-05-2013 12:57 PM

here it goes:

pan64 04-05-2013 01:11 PM

sorry, probably a stupid question; do you have an intel card? probably it should be disabled in bios.

gtludwig 04-05-2013 01:15 PM

It's a hybrid card, it uses the CPU's intel for day-to-day and power saving stuff and AMD's for high performance. I'm pretty sure I can't disable either one in BIOS.

adamk75 04-05-2013 02:41 PM

Getting the AMD GPU working on a hybrid laptop is currently a hit or miss situation.. I'm not familiar with any sure-fire way to get it working, though I know others have, and it sounds to me like your result is definitely 'miss'.


gtludwig 04-05-2013 02:49 PM

Great... Let us see what happens in the next month or so!
I always preferred nVidia for my linux hardware, but nowadays all affordable laptops seem to come with these new hybrid GPUs.
At work I'm struggling with a nVidia optimus, but that's matter for another thread.

p431i7o 07-18-2013 10:11 AM

Any updates on this?
I have a dell inspiron 14z, with hybrid ati radeon and intel graphics.


lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames [Radeon 7500M/7600M Series]

is there any software like the optimus of Nvidia for this combination with ATI?

adamk75 07-18-2013 10:21 AM

No special software is needed like Bumblebee for Optimus laptops. Sometimes the fglrx driver supports these setups without any special work, and sometimes it doesn't. The only thing you can do is install the catalyst driver and try.


p431i7o 07-24-2013 03:03 PM

As a post note, I solved a problem with the driver loading on my slackware64.
It didn't found the driver of fglrx (of libGL, I believe, with the proprietary driver of ATI/AMD)

I checked the Xorg log and saw that it has been looked for in the wrong directory.
it was at /usr/lib64 directory, but the driver was looking for it on /usr/lib, so I created a hard link at /usr/lib/fglrx pointing to /usr/lib64/fglrx.

After that, the startx worked just fine.

gtludwig 07-24-2013 03:11 PM

That's sure worth a try! I still have a spare partition on my laptop and some free time still to play around with this.

All times are GMT -5. The time now is 04:02 PM.