LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-27-2004, 09:59 AM   #1
the_rydster
Member
 
Registered: Nov 2003
Location: UK mostly.
Distribution: Slackware 9.1
Posts: 103

Rep: Reputation: 15
Problem: depmod = Unresolved symbols


I am trying to get the 2.4.24 kernel up and running, but now I get lots of error messages during the boot:

depmod = *** Unresolved symbols in /lib/modules/2.4.24/kernel/driver/blah blah

I am using the 2.4.24 source from a magazine CD and the modules I ftp'd from slackware. This is not the first time I have attempted to compile/install this kernel and it worked ok last time (but I didn't configure it correctly).

I am not sure if I targetted the correct dir when I pkginstall'd (or is it installpkg??!!) the kernel module stuff. I have a /lib/modules/2.4.24 dir so should be ok I am thinking.

Should I do make modules & make modules_install after or before make & make install. I did them after.

Also this time I move the linux-2.4.24 directory to /usr/src changed the symlink to linux and then tried to install the kernel, last time I did it all in my home directory.

Can't even get X to start now and all this to get my camera to work!!
 
Old 02-27-2004, 01:44 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
yes.........
Code:
installpkg<whatever>.tgz
yes.......
Code:
/lib/modules/<version>
this is correct way
Code:
make dep
make clean
make bzImage
make modules
make modules_install
then copy System.map to /boot
and copy bzImage to /boot and re-name to vmlinuz
 
Old 02-27-2004, 02:39 PM   #3
the_rydster
Member
 
Registered: Nov 2003
Location: UK mostly.
Distribution: Slackware 9.1
Posts: 103

Original Poster
Rep: Reputation: 15
Thanks for the help !

If I start with the modules.tgz stuff in my home directory is it enough to do the installpkg command. Do I have to do anything else?

I am begining to doubt if I have the right modules package I have:

kernel-modules-2.4.24-i486-1.tgz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.7kernelCompilation:so many depmod: *** Unresolved symbols Sailaja Reddy Linux - Distributions 2 08-05-2004 08:41 AM
depmod -a error: Unresolved Symbols rose_bud4201 Linux - Software 2 04-23-2004 09:49 PM
depmod -a: *** Unresolved symbols in /lib/ .... qanopus Linux - General 11 01-20-2003 02:26 PM
unresolved symbols when doing depmod -a qanopus Linux - General 1 12-05-2002 11:43 PM
unresolved symbols w/depmod and modprobe dave408 Linux - General 6 11-23-2002 08:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration