-   Slackware (
-   -   Problem copying to ogg files from audio CD in -current (

rkelsen 03-04-2013 04:44 AM

Problem copying to ogg files from audio CD in -current
Problem: If you try to copy a song [in ogg format] from KDE's Audio CD browser to another location, it yields a very small [approx 25kb] and useless file. It appears to go through the motions of ripping and encoding, but this small, useless file is always the result.

It appears to work well enough with other formats - eg: wav, FLAC and mp3 (I had to install lame to make mp3 work though). It's just ogg which is the problem.

Using the KAudioCreator to rip to ogg works fine, so I assume that everything else is correct and that this seems like a bug in the audiocd io slave?

Has anyone seen this problem and been able to solve it?

etech3 03-05-2013 06:01 PM

Let me start by saying that I run a Gnome desktop on a couple of machines.

I do run K3b for burning.

Most of the time I have better luck from the command. I will rip the CD first or sometimes I extract from the GUI. Most of the time it's from the command line. I use OGG and tools most always and the will convert to wav or mp3 or whatever.

I help run the sound equipment on a project and learned the recordex and tascam equipment prefers OGG in fact the tascam won't run wav so a lot of times I have to convert the cd format and reburn a CD to get it to work properly.

Try from the command line and see what happens.

Just my :twocents:

rkelsen 03-10-2013 06:09 AM

The problem seems to be specific to KDE's audiocd slave.

Short story: I tried 4.10.0 and 4.10.1. Couldn't fix it, so I've gone back to KDE 4.8.5 for now. As an aside, I have to say that device handling seems a lot smoother in 4.10.x.

All times are GMT -5. The time now is 02:09 PM.