-   Slackware (
-   -   Prob compiling SBo kipi-plugins (Slackware 14 x64) (

spoovy 03-18-2013 03:08 PM

Prob compiling SBo kipi-plugins (Slackware 14 x64)
I can't tell what's going wrong here. It seems like the system can't find a lib, even though it looks like it's there. I've tried to build kipi-plugins from SBo and digikam from SBo which includes an internal kipi-plugins. Both fail at the same point with the same error:

Code: /usr/lib64/ /usr/lib64/qt/lib/ /usr/lib64/qt/lib/ /usr/lib64/qt/lib/ -lpthread -Wl,-rpath,/tmp/SBo/digikam-2.9.0/build/lib:/usr/lib64/qt/lib:
/usr/lib64/gcc/x86_64-slackware-linux/4.7.1/../../../../x86_64-slackware-linux/bin/ld: warning:, needed by /usr/lib64/gcc/x86_64-slackware-linux/4.7.1/../../../../lib64/, not found (try using -rpath or -rpath-link)
/usr/lib64/gcc/x86_64-slackware-linux/4.7.1/../../../../lib64/ undefined reference to `sane_read'

As I say, that lib seems to be present, and in the place the build script is looking too:


tappy@drbunsen:/usr/lib64$ ls -l | grep ksan
lrwxrwxrwx  1 root root      13 Feb 22 18:02 ->*
lrwxrwxrwx  1 root root      17 Feb 22 18:02 ->*
-rwxr-xr-x  1 root root  271688 Aug  7  2012*

Any help gratefully accepted.

ponce 03-18-2013 03:11 PM

the error is not about libksane, it's about, cointaned in the sane package.

remember that SBo scripts' warranty is valid only for full installs. ;)

spoovy 03-18-2013 03:13 PM

Ah you beat me to it!!

Just me not reading the filenames closely enough again.

All I need to do is make a forum entry then it hits me straight away. :)

Thanks anyway.

All times are GMT -5. The time now is 09:27 PM.