-   Slackware (
-   -   Printing Blank Pages (

Flat_Tire_ 10-06-2002 01:46 AM

Printing Blank Pages
I've got an HP DeskJet 880C. I've ran the apsfilter setup and tried using the hpdj driver (where it gives me an error message) and the official hp drivers (which doesn't give me an error) and it just prints blank pages. I've also installed the most recent ghostscript (instructed by apsfilter) but that didn't seem to have any affect on the problem. I don't want to set it up as a generic printer... I need color. So if anyone can help, I'd appreciate it. Thanks.

Aussie 10-07-2002 08:31 AM

I've never had much luck with apsfilter and my dj810c, cups on the other hand works great with foomatic and the ijs driver.

Flat_Tire_ 10-07-2002 06:38 PM

I'm in RedHat 8.0 right now. I got my printer to work with apsfilter here, but was unable to in Slack still. Before I go back to Slack and try CUPS, I decided to try CUPS 1.1.16 in RedHat and was unable to install it properly...
I read both the INSTALL.txt and the README.txt

I did the following:
tar xfvz cups
cd cups
./configure && make && make install

after that I was unable to run the program as described in the README:

So if anyone could give me some instructions on how to install CUPS, or another program that will configure my printer, for Slackware or Redhat (so i could try it out before switching back to slack) I would greatly appreciate it.

Flat_Tire_ 10-07-2002 07:59 PM

Alright, I've got the cupsconfig running.. which brings up my browser where I login using my root and root password.. It lets me select my printer and printer location and seems to work until the end where I get an error after selecting the appropriate driver that states: client-error-not-authorized
I tried both the hpdj and hpijs for my 880C. Any suggestions?

otbibb 10-23-2002 04:54 PM

I've just spent the last week trying to set up printing on my Slack 8.1 system. I am printing over an NT network to an HP LaserJet printer. I started with CUPS, and tried just about every combination I could come up with. The crazy thing was that I could connect to the printer with smbclient and print a text file from there, so the connection was possible, but I was never able to get the smb backend to work through CUPS. I got very close, but never quite made it.

Anyway, I encountered the error you cite very early in my process, and basically discovered through much reading and soul-searching (google is good for that!) that CUPS 1.1.16 has a bug that causes this client-error-not-authorized message. When I uninstalled and put CUPS 1.1.15 on instead, I got rid of that error. I was able to get through the driver set up without problems.

After that, I found that every print job I tried (including the test job from the webadmin program (localhost:631) was automatically cancelled. I figured out that the problem there was that I didn't have the ESP GhostScript package installed. After installing that, I was able to at least get jobs queued up, but never could get anything to print. My problem was with NT authorization through Samba. Also, the pstoraster filter was crapping out on me.

My advice to you: go back to CUPS 1.1.15 (available in the extra directory for Slack 8.1), and make sure you have ESP GhostScript. If you aren't connecting through a network, you might be able to get things working. Be sure to monitor the error log in /var/log/cups (I think) to see what exactly your messages are. I could have saved myself a lot of trouble if I had noticed the complaining about gs there.

In my case, I ended up going to LPRng and configuring it with lprngtool (extra download, not included in Slackware). That got things working very quickly. I ended up connecting through the lpd URI. After a test page printed from lprngtool worked, I tried to print from KDE applications unsucessfully. At that time, I realized that lprngtool had put my printcap file in /usr/local/etc. So, I copied that file to /etc, and then my printers were available in Kprint and my jobs printed beautifully.

I am still using the IFHP filter, though I may work on setting up APS to see if I get faster printing.

I hope these reflections help you along the way. It's certainly been therapeutic for me!


flgator 11-10-2002 12:31 AM

Thanks for the esp tip. I think I'm closer now. I still get errors in the log though. It used to be that jobs were cancelled immediately, now they are forever pending in the queue.

Here is what I've done. Installed cups, installed gimp-print, configured printer, no joy; gave up on the idea of ever printing while in slack. Found this board, installed esp ghostscript. Still no joy.

log extract:
I [10/Nov/2002:06:28:32 +0100] Started filter /usr/lib/cups/filter/pstops (PID 26130) for job 31.
I [10/Nov/2002:06:28:32 +0100] Started filter /usr/lib/cups/filter/pstoraster (PID 26131) for job 31.
I [10/Nov/2002:06:28:32 +0100] Started filter /usr/lib/cups/filter/rastertoprinter (PID 26132) for job 31.
E [10/Nov/2002:06:28:33 +0100] PID 26133 stopped with status 1!
I [10/Nov/2002:06:28:33 +0100] Hint: Try setting the LogLevel to "debug" to find out more.
I [10/Nov/2002:06:28:33 +0100] Started backend /usr/lib/cups/backend/usb (PID -26133) for job 31.
E [10/Nov/2002:06:28:33 +0100] [Job 31] Unable to open USB device "usb://EPSON/Stylus%20COLOR%20740?serial=,‡0@ƒ0@8@": No such device
E [10/Nov/2002:06:28:33 +0100] PID 26131 stopped with status 1!
I [10/Nov/2002:06:28:33 +0100] Hint: Try setting the LogLevel to "debug" to find out more.
E [10/Nov/2002:06:28:33 +0100] [Job 31] No pages found!
E [10/Nov/2002:06:28:33 +0100] PID 26132 stopped with status 1!
I [10/Nov/2002:06:28:33 +0100] Hint: Try setting the LogLevel to "debug" to find out more.

The one that has me worried is the "no such device" error for the printer.
Any suggestions? This is my last great obstacle, for the time being.

rje_NC 11-11-2002 10:28 PM

I am a new user trying to learn Slackware. I had similar problem getting printing to work in Slackware 8.1. I ran the Setup program in APSFilter and the text page printed fine, but I got pages of junk when I tried to print a document on Abiword.

I used a differt queue when I set up my printer, and APSFilter did not remove the LP queue for the generic printer in /etc/printcap, so I don't think it was using the correct driver when I tried to print. After commenting out the generic printer entry in printcap, my printing worked fine with lpr.

You might want to look at your printcap file and see that you do not have conflicting queues defined.


Cyclops 11-11-2002 11:49 PM

Oh man - I thought I'd never get my printer to work properly with Slack even after trying CUPS and APSfilter. I finally went with APSfilter and it works fine now, but it turned out to be nothing more than drivers issues. The driver that was supposed to work with my printer didn't, so I kept trying different choices until one finally worked.

Don't give up like I almost did. :o

flgator 11-12-2002 06:26 AM

I looked in /etc/printcap and there is only one printer listed epson .

I can do a cat /etc/fstab > /dev/usb/lp0 and the file prints. So my CUPS install has to be messed up.

How do I unistall CUPS, Gimp-print and ESP Ghostscript so that I can try APSFilter. I have an Epson Color Stylys 740. Is that supported by APSFilter?

Thanks for any help.

burp 11-28-2002 03:53 AM

I am having similar problem with nje_NC was experiencing. I had Slackware 8.1 installed and with apsfilter SETUP the test page printed fine but when I test print a web page in Galeon it printed pages and pages of junk. I am using Canon BJC265SP.

My problem was I could not stop the printing. That web page was only a short one page file ***I am losing ink***
1 craz@jaguar+230 A 230 (STDIN)
done craz@jaguar+640 A 604 (STDIN)

With #lprm -
I had
Printer lp@jaguar:
checking perms 'craz@jaguar+230'
dequeued 'craz@jaguar+230'

I checked back again
Printer: lp@jaguar (printing disabled, printing aborted)
Queue: no printable jobs in queue

!!!!!!!!!!but my printer continue to print to glory

#lpc status all
I noticed that I had 2 printers on board, probably reflecting what nje was pointing out.
lp@jaguar diabled enabled 0 none none
bjc265sp@jaguar enabled enabled 0 none none

I guess the bjc265sp which I had set earlier via apsfilter did not replace the lp.

Since my printer is still printing I decided to disable bjc265sp, but to no awail. I continues to print if I feeds with paper.

Short of switching off the power supply to the printer which I finally did, is there any other way I could stop printing of files.


burp 11-28-2002 03:59 AM

Thanks rje_NC. My BJC is running fine after commenting out the generic printer.

You are right.

NSKL 11-28-2002 04:41 AM

For Epson styluc color printer (mine is 900) i use APSfilter. In default Slack install some drivers for this printer were unavailable (that i used in salck 8.0) so i tried some other ones (from gimp-print section i THINK) and the printer works great, but rather slow, compared how it worked with the right drivers in slack 8.0, but since i rarely need to print something it doesn't bother me. I just hope they fix APSfilter in slack 9.0.

All times are GMT -5. The time now is 08:57 PM.