-   Slackware (
-   -   Printer woes : Canon iSensys MF 8040 CN (

kikinovak 10-25-2013 11:55 AM

Printer woes : Canon iSensys MF 8040 CN

I'm currently setting up a complete Slackware network (server and desktop clients) in a local radio station. So far, the server is working great, and I have two desktop clients for a start. Eventually all ten machines will be migrated to Slackware. Currently the other client machines are running a mix of Windows XP and Ubuntu.

The Slackware clients are running crisp and clean with KDE as desktop and centralized authentication. Everything's perfect, and the only remaining problem is the darn printer.

It's not natively supported by CUPS, but Canon does provide drivers on its website for... Fedora and Ubuntu. So I downloaded the driver package, extracted the compressed archive, found various DEB and RPM packages for 32-bit and 64-bit, and decided to install the 64-bit RPMs with rpm -ivh --nodeps. (The PC does have a multilib layer installed). I did an rpm -ql to see what was installed, and all the files seemed to be in the right place. Except the printer won't even raise an eyebrow.

So my question to the CUPS gurus in this forum. Through which burning loop do I have to jump in order to get this thing to work? I'm clueless here.



ruario 10-25-2013 12:25 PM

ldd the binaries within the package to make sure they have ask their dependencies fulfilled.

Also look at "rpm -q --scripts" for each package to check the post install scripts. they may have failed due to differences on slack.

Also why not extract the rpm contents with bsdtar or rpm2cpio and knock up a quick package?

ruario 10-25-2013 12:28 PM

rpm2tgz or src2pkg would have been two more options rather than installing the rpms directly.

Stuferus 10-25-2013 04:50 PM

i downloaded the driver to see whats in it.. i found a "source" folder in the zip file.. maybe youll try (makeing a slackbuild file and) compile from source?


allend 10-25-2013 07:35 PM

A wild guess based on this thread.

You may need a symlink like 'ln -s /lib64/ /lib64/'

hernanmedellin 10-25-2013 08:38 PM

Try this ...
Hi, I do not speak English, I'm using google translator ...

Is this the driver ???

Run rpm2txz AS ROOT to convert the 2 packages (cndrvcups-common and cndrvcups-ufr2). Install the packages ...

Restart the CUPS server.

Is the printer connected to the network ? Configure the printer port like this : lpd://printer_ip_adress/print (queue name in lowercase), then select the driver (Canon MF8000C Series UFRII LT).

Let us know the result ... Greetings from México...:cool:

kikinovak 10-25-2013 10:47 PM

Thanks everybody for all your numerous answers. I had to finish the install yesterday evening by any means, so in the end, I found a pragmatic solution. One of the desktop clients is supposed to remain with an Ubuntu LTS installation, so I simply connected the printer to this one client, installed the ready-made .deb drivers from Canon (which worked out of the box, well, sort of), activated printer sharing in Ubuntu's CUPS installation so all the Slackware clients can print to it. Not quite elegant, but it works. The folks at the radio station were happy, and I could go home at a decent hour.

Note to self: continue to boycott Canon for their crappy Linux support.

Didier Spaier 10-26-2013 02:43 AM

J'arrive après la bataille, but here is how Pat unpacks google-chrome's .deb tarball ( in /extra/google-chrome/google-chrome.SlackBuild):

ar p $CWD/google-chrome-${RELEASE}_current_${DEBARCH}.deb data.tar.lzma | lzma -d | tar xv || exit 1

Raveriux 10-26-2013 07:14 AM

I had a lot of problems with Cannon multifunctional and Slackware 14. Drivers compiled from source without problems, but printer refuses to work. problem was with CUPS 1.5.4 usb backend and kernel module usblp. Blacklisting that module solved all problems. In Slackware current the usblp is blacklisted now.

Stuferus 10-26-2013 11:53 AM

i would have pluged the printer in the network (at least it is a network printer) and compile the driver from the sourcefiles in the zip.. that way no computer would have to be running to print.. oh well.. as long as the people at the radio are happy all is fine.

ruario 10-28-2013 02:10 AM


Originally Posted by Didier Spaier (Post 5052573)
J'arrive après la bataille, but here is how Pat unpacks google-chrome's .deb tarball ( in /extra/google-chrome/google-chrome.SlackBuild):

ar p $CWD/google-chrome-${RELEASE}_current_${DEBARCH}.deb data.tar.lzma | lzma -d | tar xv || exit 1

That is one way to extract the contents of a deb but IMHO it is not the best way. I would rather use bsdtar instead:


bsdtar xOf $CWD/google-chrome-${RELEASE}_current_${DEBARCH}.deb data.tar.* | bsdtar xvf - || exit 1
The advantage of this method is that it will continue to work even if the internal compression method changes (e.g. to XZ) because bsdtar allows globbing when extracting files (i.e. data.tar.*), while ar does not. Additionally, bsdtar can detect and handle automatic decompression of archives received through a pipe without having to specify the compression type, unlike GNU tar.

All times are GMT -5. The time now is 07:02 AM.