-   Slackware (
-   -   Printer driver (

interndan 11-25-2012 12:59 PM

Printer driver
Has anyone been successful in getting a Dell V313w working with Slackware? I found drivers for RPM and DEB based systems, but have been unable to make them work with Slackware. Any help with this would be appreciated.

Thanks Dan

markush 11-25-2012 01:11 PM


how is the printer connected to your computer? USB or Lan? if USB, what does lsusb show?


interndan 11-25-2012 04:36 PM

It is connected by usb. output of lsusb is

Bus 001 Device 002: ID 413c:5233 Dell Computer Corp.

markush 11-25-2012 04:39 PM

And when you open the webinterface for cups at http://localhost:631 in a browser, can you see the printer? Do you have cups running correctly?


interndan 11-25-2012 06:40 PM

Yes I can see the printer in the CUPS interface. The problem is, there are no drivers for it and I have been unable to get the rpm or deb based ones to work. I tried src2pkg on both but neither will build a Slackware package.

markush 11-26-2012 12:41 AM

The file which cups needs for your printer is a *.ppd file. You could extract the rpm or the debian package and search there for a ppd file. This file can be installed via the cups-webinterface.


ljb643 11-26-2012 05:17 PM

A PPD file alone isn't going to help you, unless the printer understands PostScript or is supported by Ghostscript. This Dell isn't either, so their driver includes a PPD file and I assume a program to convert the data stream from CUPS Raster, and who knows what else. Although it is possible their Ubuntu (or other) driver can be made to work on Slackware, it is unlikely to be easy to debug... sorry I can't offer more advice here.

interndan 11-26-2012 05:21 PM

Unpacking the file seems to only give me a script file.

ljb643 11-26-2012 07:15 PM

They seem to distribute it as tar.gz file, which unpacks to the self-extracting shell script package you found above; you are supposed to run that from the shell and it unpacks itself, and I think it creates a .rpm or .deb file... the one I looked at had a Java runtime and a whole bunch of LUA scripts too... I don't know why they used such a strange, twisted method of packaging their driver... but if you can get it to an .rpm file, you can try rpm2tgz and then unpack the result, and you just might find something usable.

ReaperX7 11-26-2012 08:45 PM

Basically do this:

Download the tar.gz file from here:

Open the Downloads folder and run these sequential commands:


tar -xzf


rpm2tgz R293771.rpm

installpkg ./R293771.tgz

Dell's website has this as an excerpt:


Manually adding the Printer in CUPS:
1. Attach the printer via USB to the Linux machine.

2. Run a browser and open "http://localhost:631"

3. Click "Add Printer" and fill out the details, such as name and description. In the Device dropdown list, select "Dell USB Backend #1 (Dell )" or "Dell Network Backend #1 (Dell )". Make sure you select the correct device. The printer is not detected by the machine if you cannot see its model in the list. On some distro, you may have to reboot the machine so it can be detected. You can also Browse for the PPD file if the device is not on the list. The ppd files are located in folder /usr/dellinkjet/dell09/etc/.

The following are the different models supported by this driver and with their matching ppd file:

Printer PPD
Dell V310-V510 Series ..... dlV310-V510.ppd

4. Select your Dell printer model name. After adding the printer, you should see the "Printer Options". Click the "Set Printer Options" (optional) or proceed to the next step.

5. You can access the printer admin directly by typing this address in the browser: http://localhost:631/printers/. The name of the printer is what you entered in step 3.

6. Print a test page to make sure the software has been successfully installed.

interndan 11-27-2012 12:26 PM

When I tried this it did not work. The tar command created the same file as my earlier post. When I tried to run that, it started a nix installer program that then failed with a bunch of missing dependencies. I did not check all of the "missing" dependencies but the ones I did check are in fact installed on my system.

markush 11-27-2012 12:35 PM


Originally Posted by interndan (Post 4838118)
... I did not check all of the "missing" dependencies but the ones I did check are in fact installed on my system.

Probably you should edit the installerscript and find out if it searches the correct pathes, they may differ between Ubuntu/debian and Slackware.


ReaperX7 11-27-2012 09:30 PM

You should check the dependencies and then reattempt this. Remember Slackware requires manual dependency checking and if it doesn't find something it will let you know you have to look for it and then install the package it's in. 9 time sout of 10 all the packages you'll need are at anyway.

There's a good chance that this package requires lua which is available from as well as possibly the packages for libgnomecups, libgnomecanvas, libgnomeprint, and libgnomeprintui which are also available there.

Remember you do have to do all the dependency checks yourself on Slackware.

All times are GMT -5. The time now is 07:29 PM.