LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-18-2017, 04:48 PM   #1
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 659

Rep: Reputation: 201Reputation: 201Reputation: 201
Post for talk with ponce (audacity.slackbuild)


Hi , i see new audacity version (2.1.3).

I have "suggested" changes , for the audacity.slackbuild.

I see best way to "autodetect" installed libraries in the archlinux build , simply use

Code:
autoreconf -vi
after this , only configure and usr prefix and lib"SUFFIX" ...


I test and works nicely ... only for consideration , i put the patch with changes in pastebin.


http://pastebin.com/ZM8tiGKa


If you doubt , can test with and exit after configure to see how configuration link to SYSTEM libraries if are available ..if not , link to LOCAL.


Thanks for your time!
 
Old 03-19-2017, 01:20 PM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
Hi USUARIONUEVO,

first let me say that if you want to get in touch with me directly you can use a pm or also by email (it's pretty easy to find it) if you open a topic in a forum usually is because you want to discuss thing in public so other people can also partecipate.

then, on the matter of the topic: the issue with the newer release of audacity is that the audacity people left a stale configure file in their tarball.
as you have noticed too, regenerating a new one with "autoreconf -vif" fixes the dependency detection.

I prefer to specify what has to be enabled using switches mainly because I prefer to use as dependencies what we have available on SBo, preferring that to the third-party sources that the audacity people ship with their tarballs: some versions ago they don't ship anything and they have the habit of not being very consistent with those in the past (they sometimes work fine, other times not), so, if I have to support a build script, I prefer to do it with whatever I have the possibility to test extensively.
also, if you make the audacity build system autodetect everything you have in the system, if it doesn't find a dependency it will automatically use the corresponding one from the third-party bundled sources, so, if you prefer to enable only some of the functionality in audacity disabiling others, you would have to disable them specifically in the script editing it: I personally prefer to have them disabled if they're not available in the system.
that said, regarding an handful of specific dependencies like libsoxr, I prefer to use the version shipped with the sources.

Last edited by ponce; 03-19-2017 at 01:29 PM.
 
Old 03-19-2017, 03:20 PM   #3
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 659

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
OK , more flexible build if people can choose what enable and what disable.

Probably cause i think ever in enable all possible options , but not all users want this.

I try modifications, cause have a trouble with actual script , if remove libflac , he not link the system version , and later get an error cause the script remove the libsrc in audacity project, at this point can remove in the list of folder to delete , "flac" and then build, but using audcity flac version.


In some case this post is only for talk , and i apreciate developers lost time on help other users , thanks !
 
Old 03-19-2017, 04:01 PM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
Quote:
Originally Posted by USUARIONUEVO View Post
I try modifications, cause have a trouble with actual script , if remove libflac , he not link the system version , and later get an error cause the script remove the libsrc in audacity project, at this point can remove in the list of folder to delete , "flac" and then build, but using audcity flac version.
consider that every script on SBo assumes that you are using a Slackware full installation to run it, so I personally don't even put in account the case in which you have removed the shipped libflac from your system.
 
Old 03-19-2017, 04:22 PM   #5
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 659

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
No , you no understand.

I have fully install ..

your slackbuild ..do this

# ensure we use the system headers for these: note that we do this after the
# configure as this last wants to run sub-configures in these dirs
for i in ffmpeg expat libid3tag libflac libmad libresample libsndfile libvamp lv2 soundtouch twolame; do
rm -rf lib-src/$i
done



if no run autoreconf -vi , then audacity try to build own libflac ...but script removed from source = ERROR ON BUILD

cause no system version linked (no autoreconf -vi) , audacity now wants that...or try compile in own version of libreries.

In some case , when you try ..you see.



that --> --with-libflac=system \

no work if not link system librarie ... :=)
thats the same , for the rest of list .... if delete but no linked , build LOCAL libraries , pay attention after configure..says what are SYSTEM and LOCAL linked.

Last edited by USUARIONUEVO; 03-19-2017 at 04:37 PM.
 
Old 03-20-2017, 02:10 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
Quote:
Originally Posted by USUARIONUEVO View Post
if no run autoreconf -vi , then audacity try to build own libflac ...but script removed from source = ERROR ON BUILD
sorry, I think I had explained this earlier: you *have to* run autoreconf in case of audacity-2.1.3, because the configure shipped is broken, that's why it doesn't use the system libflac.
 
Old 03-20-2017, 06:38 AM   #7
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 659

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Ha ha ha , ok.

Have nice day man !
 
Old 03-20-2017, 10:46 PM   #8
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.2 64-bit with multilib
Posts: 2,398

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Successfully able to compile 2.1.3 after adding autoreconf -vi , now if only I knew enough how to properly add audacity-manual-2.1.3.zip to the slackbuild, instead of just manually unzipping to
Code:
/usr/share/audacity
per http://manual.audacityteam.org/man/u...he_manual.html
 
Old 03-21-2017, 02:50 AM   #9
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
you have to unzip it into /usr/share/audacity/help/manual but, IMHO, it's not that useful to package it because it's just a bunch of html files (20 Mb) that are opened in the browser once you select "Help" -> "Manual" from the menu, so it's not that different to reading them online: you can set up audacity to read them also remotely, it doesn't change anything for the program as it opens an external browser.
I'll add an option to package it but I'll leave it disabled by default, the only people who will need it will be the ones wanting to read it without an internet connection.

Last edited by ponce; 03-21-2017 at 02:53 AM.
 
Old 03-21-2017, 02:53 AM   #10
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.2 64-bit with multilib
Posts: 2,398

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Quote:
Originally Posted by ponce View Post
you have to unzip it into /usr/share/audacity/help/manual but, IMHO, it's not that useful to package it because it's just a bunch of html files that are opened in the browser once you select "Help" -> "Manual" from the menu, so it's not that different to reading them online: you can set up audacity to read them also remotely, it doesn't change anything for the program as it opens an external browser.
I'll add an option to package it but I'll leave it disabled by default, the only people who will need it will be the ones wanting to read it without an internet connection.
If you can add the .zip as some kind of optional dependency, and then just add MANUAL=yes for the slackbuild assuming the zip file is downloaded along with the source, that would be ideal. I just prefer having things offline
 
Old 03-21-2017, 02:56 AM   #11
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
Quote:
Originally Posted by Jeebizz View Post
If you can add the .zip as some kind of optional dependency, and then just add MANUAL=yes for the slackbuild assuming the zip file is downloaded along with the source, that would be ideal. I just prefer having things offline
I have done exactly like that
Code:
diff -Naur audacity.orig/README audacity/README
--- audacity.orig/README        2017-03-19 08:53:11.582204339 +0100
+++ audacity/README     2017-03-21 07:00:31.200734315 +0100
@@ -5,3 +5,7 @@
 Optional dependencies (autodetected) are ffmpeg, jack-audio-connection-kit,
 ladspa_sdk, lame, soundtouch, twolame, vamp-plugin-sdk and lilv + suil
 (for lv2 support).
+
+The manual is packaged with the application only if you pass the script
+the additional option
+  MANUAL=yes
diff -Naur audacity.orig/audacity.SlackBuild audacity/audacity.SlackBuild
--- audacity.orig/audacity.SlackBuild   2017-03-19 08:53:11.583204339 +0100
+++ audacity/audacity.SlackBuild        2017-03-21 07:34:32.553179714 +0100
@@ -1,9 +1,9 @@
 #!/bin/sh

-# Slackware build script for Audacity
+# Slackware build script for audacity

 # Copyright 2006-2010 Chess Griffin <chess@chessgriffin.com>
-# Copyright 2011-2016 Matteo Bernardini <ponce@slackbuilds.org>
+# Copyright 2011-2017 Matteo Bernardini <ponce@slackbuilds.org>
 # All rights reserved.
 #
 # Redistribution and use of this script, with or without modification, is
@@ -31,7 +31,7 @@

 PRGNAM=audacity
 SRCNAM=Audacity
-VERSION=${VERSION:-2.1.2}
+VERSION=${VERSION:-2.1.3}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}

@@ -63,6 +63,7 @@
 fi

 if [ -x /usr/bin/listplugins ];      then do_ladspa="--with-ladspa";          else do_ladspa="--without-ladspa";   fi
+if [ $(which lame) ];                then do_lame="-lame=system";             else do_lame="out-lame";             fi
 if pkg-config --exists libavcodec;   then do_ffmpeg="-ffmpeg=system";         else do_ffmpeg="out-ffmpeg";         fi
 if pkg-config --exists soundtouch;   then do_soundtouch="-soundtouch=system"; else do_soundtouch="out-soundtouch"; fi
 if pkg-config --exists twolame;      then do_twolame="-libtwolame=system";    else do_twolame="out-libtwolame";    fi
@@ -91,6 +92,8 @@
 # fix building against ffmpeg-2.6.x, patch from archlinux
 patch -p1 < $CWD/audacity-ffmpeg.patch

+autoreconf -fi
+
 # libsoxr is the new default resampling library
 LDFLAGS="-L/usr/lib$LIBDIRSUFFIX" \
 CFLAGS="$SLKCFLAGS" \
@@ -109,6 +112,7 @@
   --with-libsoxr \
   --with-portaudio \
   $do_ladspa \
+  --with$do_lame \
   --with$do_ffmpeg \
   --with$do_lv2 \
   --with$do_soundtouch \
@@ -131,10 +135,10 @@

 # We're going to overwrite the included audacity.desktop file with ours,
 # and the icon isn't added at all by upstream, so we'll do that here
-install -D -m 0644 $CWD/audacity.desktop \
-  $PKG/usr/share/applications/audacity.desktop
+install -D -m 0644 $CWD/$PRGNAM.desktop \
+  $PKG/usr/share/applications/$PRGNAM.desktop
 install -D -m 0644 images/AudacityLogo48x48.xpm \
-  $PKG/usr/share/pixmaps/audacity.xpm
+  $PKG/usr/share/pixmaps/$PRGNAM.xpm

 # Move manpage directory to the proper location
 mv $PKG/usr/share/man $PKG/usr
@@ -145,6 +149,11 @@
 cp LICENSE.txt README.txt todo.txt $PKG/usr/doc/$PRGNAM-$VERSION
 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

+if [ "${MANUAL:-no}" = "yes" ]; then
+  mkdir -p $PKG/usr/share/$PRGNAM/help/manual
+  unzip $CWD/$PRGNAM-help-$VERSION.zip -d $PKG/usr/share/$PRGNAM/help/manual
+fi
+
 mkdir -p $PKG/install
 cat $CWD/slack-desc > $PKG/install/slack-desc
 cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff -Naur audacity.orig/audacity.info audacity/audacity.info
--- audacity.orig/audacity.info 2017-03-19 08:53:11.583204339 +0100
+++ audacity/audacity.info      2017-03-21 06:54:53.114765327 +0100
@@ -1,8 +1,10 @@
 PRGNAM="audacity"
-VERSION="2.1.2"
+VERSION="2.1.3"
 HOMEPAGE="http://audacity.sourceforge.net"
-DOWNLOAD="https://github.com/audacity/audacity/archive/Audacity-2.1.2.tar.gz"
-MD5SUM="84488cd755fe14cbc39769dd1abb7113"
+DOWNLOAD="https://github.com/audacity/audacity/archive/Audacity-2.1.3.tar.gz \
+          http://ponce.cc/slackware/sources/repo/audacity-help-2.1.3.zip"
+MD5SUM="82e7216ae4b9bb597ed6f291bd44f45 \
+        5e32b26a48f79e82438998c3334fe117"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
 REQUIRES="wxGTK3"
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackpkg+ fatal errors with Ponce and SlackOnly repos denydias Slackware 7 04-17-2017 03:24 AM
[SOLVED] slackpkgplus greylist (or blacklist) SBo/ponce nivieru Slackware 3 06-10-2016 01:04 PM
[SOLVED] ERROR running audacity.SlackBuild script Ztcoracat Slackware 47 12-15-2015 10:21 PM
Slackbuild for Audacity 2.0.6 fails with VAMP=yes slacksam Slackware 7 06-18-2015 10:06 AM
[SOLVED] Help to create a slackbuild from post-install.py script theCapitain Slackware 4 09-07-2010 04:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration