LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-22-2005, 12:29 PM   #1
firebug1
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Rep: Reputation: 0
ports


my open ports on Slack 10 are

37/tcp time
113/tcp auth
631/tcp ipp

how i can close them....?

also i want to know how i can close ports
80/tcp
21/tcp

also i want to ask if i should always have all ports closed...is it harmless for the system?

can you propose me a good firewall program?

## sorry for my english!!! ##
 
Old 09-22-2005, 12:40 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
I'd imagine you'd close them by stopping the services that have them open.

631 is for CUPS, so it'd probably be something like "/etc/rc.d/rc.cups stop".

80 is for a webserver. For Apache, you could try "/etc/rc.d/rc.httpd stop" or maybe just "httpd stop".

21 is for FTP but I dunno what script you'd use for that as I don't have an FTP server running on my machine.

Not sure about the others. Remember you need to run these commands as root and without the quotes.
 
Old 09-22-2005, 03:40 PM   #3
nukey
Member
 
Registered: Dec 2004
Location: Netherlands
Distribution: Slackware
Posts: 173

Rep: Reputation: 30
First check out your /etc/inetd.conf

Comment what you don't need.

Port 80, apache is running.

To stop it,

apachectl stop

And to make sure it won't start next time

chomd -x /etc/rc.d/rc.httpd



And off course you could always use iptables to close your ports.
 
Old 09-22-2005, 07:53 PM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,467

Rep: Reputation: Disabled
Quote:
How to deny remote connection to the CUPS daemon ?

To be sure the CUPS daemon only listens on your local computer, you can edit the /etc/cups/cupsd.conf file and replace the following line :

Port 631

with :

Listen 127.0.0.1:631
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Open Mail Server Ports 25, 110, and 220. Other Ports will open. Binxter Linux - Newbie 9 11-29-2007 02:03 AM
need help with ports alagenchev Linux - Security 5 10-22-2005 07:29 PM
all ports down chiggly Linux - Newbie 10 10-16-2005 06:09 PM
? about ports bwoodwar Linux - Networking 3 09-19-2005 04:33 PM
ports Pedroski Linux - Newbie 5 11-20-2004 03:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration