-   Slackware (
-   -   Porting SlackBuild of Scilab from Slackware 12 to Slackware64 13 (

Alexvader 11-10-2009 08:09 AM

Porting SlackBuild of Scilab from Slackware 12 to Slackware64 13
Hi Forum

I have been trying to create a pkg of Scilab from Slackware 12 in Slackware64 13...

But the slackbuild abotrs with an error about the version of Tcl...

... So far I have not tinkered with the Tcl version of Slackware... thing is "as installed"...

checking for PVM architecture... UNKNOWN
configure: WARNING: PVM unable to find architecture: I will not use PVM
checking for main in -ldl... yes
checking for header file tcl.h... found in /usr/include
checking if tcl is version 8.4 or later... (8.5) yes
checking for tcl library tcl8.5... configure: error: header file tcl.h has been found for 8.4* but no corresponding tcl library (ie

I suppose one could make some sort of hackerish trick like ln -s /../../ /../../ just to see it it works...

...but this is a bad principle... messing around with system libs...

So, does anybody have any suggestion...

...I managed to set the python of Slackware64 13 to 2.5 using a slackbuild of a previous version... It did not overwrote anything bcause it installs to a separate source tree... only thing changed is a symlink...

Can I ( Do i Really Need to ) do this with tcl in order to have scilab working...?



Johncc330 11-10-2009 09:43 AM

I have the impression there is some confusion in your Tcl installation.
(or maybe in the SciLab configure macros).

1) The script detects Tcl version 8.5,
2) but it is still looking for libraries of version 8.4x

Maybe, when you installed the 64 version you parcially install Tcl (or still
have some older header files around? Check if you have any old libtcl8.4* left on
your machine.

I compiled Scilab recently on a clean Slackware64 system, and I had no problems.


Alexvader 11-10-2009 10:14 AM

Hi Johncc330

I won´t be with my Slackware lappy until tonite... but I will check on this...


But Just tell me, did you make any update...? Or are you using Slackware64 13 install "as is"...?

Ivshti 11-10-2009 10:20 AM

Do you have compatibility libraries installed? That may be the problem.
I suggest reinstalling tcl just in case, and I guess that you have a old tcl package that you haven't uninstalled.

If that doesn't work, download a new version of scilab and compile it with src2pkg.

I can compile 5.1.1 on a 32 bit system if you like. If that won't do, I'll compile a 64 bit one.

Alexvader 11-10-2009 10:30 AM

Hi Ivsthi

Thkx for yr help... :-)

As soon as I get back home, I'll put my hands on the job... :-)



Alien Bob 11-10-2009 10:34 AM

Try this SlackBuild - it should work on 64bit as far as I can see.


Alexvader 11-10-2009 10:46 AM


Originally Posted by Ivshti (Post 3751725)
I can compile 5.1.1 on a 32 bit system if you like. If that won't do, I'll compile a 64 bit one.

AFAIK Scilab 5.1.1 requires a lot of extra packages... I tried to build it 64 without PVM and UMFPACK... so I built lapack qhull blas java and ant from Sllackbuilds... Had to build ocaml from INRIA ( Some sort of Objective C compiler they use in Scilab ) as an external dependency, and proceeded to Build Scilab, but it aborted in make with some funny error, do not recall exactly what, but I guess it would not find some headers inside some folders in Scilab 5.1.1 Source tree...

I just left it for the time being...

Have you managed to build it 64...? awesome... :-D



Ivshti 11-10-2009 11:00 AM

I assume you have src2pkg installed. Just type this

cd /tmp; src2pkg -I
This will download, compile, and install the package for you.

Edit: try using the source of an older version then.

Alexvader 11-10-2009 11:17 AM

Hi @Alien Bob, @Ivshi

I will try this as soon as I get back home... :-)

THX a lot ppl, I will post back the results tomorrow...

Once again thanks PPL...

knudfl 11-10-2009 01:13 PM

There is a 'Suitesparse' slackbuild here

... also providing the Umfpack libraries etc. etc.

Johncc330 11-10-2009 05:26 PM


Originally Posted by Alexvader (Post 3751712)
Hi Johncc330
But Just tell me, did you make any update...? Or are you using Slackware64 13 install "as is"...?

Well, I did install the 32 bit compatibility libraries, which aren't installed by default, but SciLab was compiled in 64 mode, so that shouldn't be the difference.


Alexvader 11-11-2009 09:43 AM

Hi @Ivshti,@knudfl,@Alien Bob

@ Ivshti :

So.... I grabbed the tarball of Scilab... ( do not have net access at home, and I have 2 lappies, one of them has OpenFOAM installed which i need for my wrk... the Other has Slackware, where I am trying to build my Engineering apps, did no build openFoam yet, so i leave it at home untill I can have everything that i need, built... ) and src2pkg it, it complained about ant from apache, so ... will grab it today, and install it... and try again... may also grab caml from Inria... in case Scilab build complains about that too... more news tomorrow... I am two lazy to bring two lappies along... :-)

@ knudfl :

Great... :-) that slackbuild worked allright... Will try again tonite with the most recent version of SuiteSparse

@ Alien Bob :

I will try your SBuild tonite...

...ppl... a guy comes home exhausted after a 2 hour training of Kyokushin Kai karate, or Kenjutsu... ( depends on the day of the week...) after a hard day of work aroud CAD applications, simulation stuff.. waiting for iterations after iterations in front of a workstation screen... Sometimes I feel that 24 hrs are just not enough... :-)

Thanks a lot ppl....



Alexvader 11-13-2009 05:35 PM

Hi Ivshti

'da niewz :

Grabbed the Scilab 5.1.1 tarball, tried to src2pkg it but it aborted...

bash-3.1# cd /tmp; src2pkg -I
Downloading sources with wget from:
Sources downloaded to: /tmp/scilab-5.1.1-src.tar.gz
Deleting old build files - Done
Creating working directories:
Unpacking source archive - Done
Correcting source permissions - Done
Checking for patches - None found
Found configure script - Done
Configuring sources using:
LDFLAGS="-L/lib64 -L/usr/lib64" CFLAGS="-O2 -fPIC -m64" ./configure --prefix=/usr --libdir=/usr/lib64
ERROR! Configuring sources has failed!
This may be because of some missing libraries, or you may
need to pass extra options to configure using EXTRA_CONFIGS.
Sorry! No Dependency or Requirements information found.

Notice - Showing short options in a separate xterm.

back to ./conf make...

It complained about missing dependencies like Java flexdock, so I grabbed and untared Scilab pre-requirements ( it untars to the same folder as Scilab... ) and ran conf --help; based on output I decided to exclude pvm, matio, and ocaml... ran conf, and make... aborted due to the fact that a Scicos ( this is a "must have" for me... :-( ) toolbox would not find the get_time function, so I make clean, configure again --without-scicos...






This created a package in /tmp which I installed... Tried to run some of the demos...

But the graphical window displays ( they pop up allright ) with Transfer function values outputs, and graphs, remain white... although the simulation completes alright...

#1) How can I build Scicos... ( what must I do so that building of Scicos finds get_time...) ?
#2) What must I do to enable graphical displays...?

More news 2morrow about Scilab 4.1.2



Alexvader 11-14-2009 12:05 PM

Hi Forum, @Alien Bob


Originally Posted by Alien Bob (Post 3751742)
Try this SlackBuild - it should work on 64bit as far as I can see.


Downloaded the SlackBuild from the site, as well as the diff and Manifest files to a folder...

Changed ARCH to x86_64, and launched ./scilab.SlackBuild, It downloads the source tarball to ./scilab and stops...

bash-3.1# pwd
bash-3.1# ls
scilab-4.1.2.diff scilab.SlackBuild
bash-3.1# ./scilab.SlackBuild
--2009-11-14 18:02:34--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 15892277 (15M) [application/x-gzip]
Saving to: `/home/alex/Desktop/buu/SciLabBuild/scilab/scilab-4.1.2-src.tar.gz'

100%[==================================================================================================== ======================================================================>] 15,892,277 460K/s in 46s

2009-11-14 18:03:21 (339 KB/s) - `/home/alex/Desktop/buu/SciLabBuild/scilab/scilab-4.1.2-src.tar.gz' saved [15892277/15892277]


How do I need to change the SlackBuild for this to build...?



knudfl 11-14-2009 01:03 PM

# 13 : How about " ScicosLab "

git clone

cd scicoslab/
### Uncomment line 3...14 , .
./configure && make

Notice : 'g77' or similar is required.

All times are GMT -5. The time now is 04:04 AM.