-   Slackware (
-   -   porteus please assist to help auto start wifi (

mtdew3q 12-26-2013 08:41 PM

porteus please assist to help auto start wifi

I installed Porteus on my flash drive. I used the pns-tool. It asked me if I wanted to make it a module. I said yes. I activated the module, but it doesn't seem to connect on boot. I can deactivate the module and use the command line tool again to access the Internet. It seems that somehow it would be nice to not have to enter those answers on the command line to questions re: my network setup, each time I want to connect. I am curious. I read about network manager and wicd. I did connect successful with pns-tool.

The module for starting the wifi is in a peculiar place in my home account. I can see where the other modules are and group it there, but I am not sure if it matters where I put these modules once they are activated.

I tried to launch firefox hoping that it was connecting in the background and nothing really happened in terms of connectivity. I kept wondering isn't there supposed to be a message or an indicator in terms of the pns-tool auto connecting with status?

I don't like the network manager very much, as when I try to run it, all the boxes are grayed out. I am not worried about the network manager running because I read in slack ware, unless you make the init script executable, it won't run. That is fine with me.

Please offer any cool suggestions.

I think Porteus is very cool so far. I have the razorQT desktop set up. It looks really neat. I tried crunchbang and puppylinux but Porteus looks like the coolest yet.

I hope a slackware user that uses porteus can answer this question. I figure someone out there heard how cool porteus is that uses slackware and runs both.


mtdew3q 12-26-2013 09:20 PM


On a quick note, I copied from the temp directory to /etc the files I saved after I ran pns-tool. It connected okay, so I am thinking there is something interfering with that on boot up. At the start of pns-tool, it asks me to shutdown network services. Not sure why it didn't take off on reboot. I copied the files using the command line instead of making it into a module because I am not sure how this module thing works exactly yet. I am going to read about network services on startup.


mtdew3q 12-27-2013 12:48 AM


The only tool that I could get to work consistently was pns-tool. I had xpns-tool working, but then it stopped working. I am more interested in focusing on learning a little about slackware and porteus. The wizards aren't working on the automatic connect on reboot option for me. I have to run the pns-tool each time.

In contrast, my ubuntu machine takes for ever somtimes to connect with the usb wifi adaptor. I think there are conflicting device signals in my building, so actually, in a weird way, it is faster to use pns-tool than my usual usb adapter to ubuntu connection.

It is a cool command line setup tool, and I am happy it works.


kikinovak 12-27-2013 03:08 AM


Originally Posted by mtdew3q (Post 5087384)
Please offer any cool suggestions.

I suggest you use the Porteus forum, since this is a Porteus-specific problem. With Slackware, you would only have to activate the NetworkManager, and you'd be up and running. Porteus seems to require additional steps.

All times are GMT -5. The time now is 09:43 AM.