-   Slackware (
-   -   Porblems continue with intel 965 chipset in slack 12 (

kilgoretrout 07-16-2007 01:00 AM

Porblems continue with intel 965 chipset in slack 12
Slackware 12 does not appear to be able to detect my optical ide drives on my intel 965 core 2 duo motherboard. This is an old problem caused by the kernel not supporting the marvell ide controller used on these motherboards and was previously reported here for slack 11:

The history of the problem is further seen here:

Oddly, the problem was supposed to be fixed from kernels 2.6.19 onwards but apparently it persists, at least for me, in slack 12 with its 2.6.21 kernel. I get the identical "not found" message for slack 12 no matter what bios settings I've tried.

My question is has anyone been able to successfully install slack 12 on an intel 965 motherboard and if so, what's the secret?

Qwello 07-17-2007 01:52 PM

How to install Slack 12 on a i965 core 2
Here's how I installed Slackware 12 on a i965 core 2 Intel board using a USB drive.

I don't know if it is the best way to do this, but it works!

First, copy everything from the /slackware folder to a USB drive.

Next, boot from the Slackware installation DVD like normal, and start the installation process.

Plug in your USB drive once booted, and when the setup ask you where to find the slackware source, just use the option "Install from a hard drive partition".

This way, the installation has been done correctly.

kilgoretrout 07-17-2007 10:07 PM

Thanks for the tip. Worked fine except I had to have my usb drive plugged in and powered on before booting the install dvd for it to be detected. Once I did that the install went very smoothly from the external hard drive. I suppose I could have just as easily copied the /slackware folder to an existing partition on an internal hard drive since I had several available that weren't going to be used for the slack install. Odd thing is that the optical drives are detected and function perfectly after the install but not during the install.

Anyway thanks again; glad to have my slack back.

All times are GMT -5. The time now is 01:55 PM.