LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


View Poll Results: What is the Slacker's choice FS?
ext2 5 2.58%
ext3 87 44.85%
JFS 29 14.95%
ReiserFS 53 27.32%
XFS 20 10.31%
Voters: 194. You may not vote on this poll

Reply
  Search this Thread
Old 07-08-2008, 03:46 PM   #61
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291

From my experience, 'bongs' (I'm guessing those are the large cones that are supposed to lead air directly to the CPU fan from outside the case) are worthless. In fact, just recently I had my brother's computer getting rather hot. So, I looked in the case and saw only one 80 mm fan in the rear and a 'bong' for the CPU fan. The CPU then was running at around 50-60 C on idle ... not too good. So, I increased the rear fan to 90 mm, removed the bong and added another 90 mm fan where the bong was, this has the idle temp down to 30-40 C, much better. Oh, and it's also much much quieter, the bong tends to amplify the sound of the CPU fan (one of the louder type of fans).

Last edited by H_TeXMeX_H; 07-08-2008 at 04:57 PM.
 
Old 07-08-2008, 04:05 PM   #62
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by onebuck View Post
Hi,

Erv, what type cooler do you use on your cpu?
The one which comes with AMD 5000+ box edition.

Quote:
Originally Posted by onebuck View Post
There was a discussion some time ago about cooling here on LQ. I'll see if I can find it.
With new fans box is cool at the place where HDDs are, neither warm or cold overall, and there is a warm spot below GeForce 8400. Right now air is sucked in through front panel, passes through both HDDs, then goes out through chassis fan and PSU fan (both on back panel), removing hot air coming from CPU. However this stream doesn't include air coming down from video card, so that's why there is a "warm spot". Maybe I'll toy around with all this tomorrow (it's worth trying reversing chassis fan). "Warm spot" could be probably removed but adding yet another fan under geforce, but that'll require box modification.

Quote:
Originally Posted by onebuck View Post
By placing a 'bong' in front of the cpu cooler that allows exit of the hot air. Then making sure that the fan for the CPU cooler is blowing into to bong therefore exiting the heat outwards from the CPU you will be pulling air from the vents into the chassis. If your side panel doesn't have a means to mount a bong, it is easy to cut a hole. You can get the assembly at a good computer shop.
What exactly do you mean by "bong"(unfamiliar word, I've checked wikipedia already)? Something like this or this?
Anyway, cutting the side panel is not an option. First, with chassis fan + additional hdd fan hot air from CPU now is being removed (or it looks like this to me). Second, I'm pretty sure that I'll badly damage side panel in the process, since I'm not good with modding, cutting metal, etc. Pricing for new chassis in local shops is a bit high for my taste, and no one seem to sell chassis parts or chassis without PSU.

Quote:
Originally Posted by onebuck View Post
I really think temperature is your problem.
Right now place where both HDDs reside seems to be coldest place in the whole box (cool to the touch). I'll be testing all this for some time, but right now I don't see improvements in "dma being disabled" problem.
I'll see tomorrow how it all operates, since it's 0:00 already...

Last edited by ErV; 07-08-2008 at 04:10 PM.
 
Old 07-09-2008, 02:04 AM   #63
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 17.3+18.3+19.0, MX-17
Posts: 4,199

Rep: Reputation: Disabled
You might try a check of the RAM of your machine. DMA accesses it directly, after all, and Linux uses memory differently from Windows.

What I don't really get is how the DMA setting is changed at all. Where is it stored? Data region of the driver? What is accessing that?
 
Old 07-09-2008, 05:55 AM   #64
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by JZL240I-U View Post
You might try a check of the RAM of your machine. DMA accesses it directly, after all, and Linux uses memory differently from Windows.
IMHO, that's really unlikely the problem.

Quote:
Originally Posted by JZL240I-U View Post
What I don't really get is how the DMA setting is changed at all. Where is it stored? Data region of the driver? What is accessing that?
AFAIK, DMA state is stored either within kerenel or device. There are might be some DMA settings in BIOS, but I don't think kernel looks at them. You can also pass enable dma flags to the kernel during the boot (ide0=dma or something). But as I know the only way to turn it on and setup your HDD mode (i.e. "enable 32bit io", "keep settings", and set udma mode) is to call hdparm during startup. As you can see in my older posts, the problem is that device encounters error:
Code:
hdc: status error: status=0x58 { DriveReady SeekComplete DataRequest }
ide: failed opcode was: unknown
hdc: DMA disabled
hdd: DMA disabled
hdc: drive not ready for command
And then kernel disables DMA. It looks like I'll end either writing to linux-kernel mailing list or digging kernel sources.
 
Old 07-09-2008, 06:01 AM   #65
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 17.3+18.3+19.0, MX-17
Posts: 4,199

Rep: Reputation: Disabled
From your own post it seems obvious that hdparm sets the values / parameters permanently. Thus they must be set in the drive, i.e. no kernel-hacking or source digging. Seems rather that communication during normal I/O is not stable under linux (as opposed to your Win-installation). Now what ... do you use 80 lines cables (as opposed to 40 lines) for the hard disks?
 
Old 07-09-2008, 06:59 AM   #66
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by JZL240I-U View Post
From your own post it seems obvious that hdparm sets the values / parameters permanently.
It doesn't set values permanently. You can enable DMA with hdparm, then you after you'll get "DMA disabled" in dmesg (see error above), it's switched off, and hdparm reports DMA is not set anymore. This can happen several hours after enabling DMA (it's rarely can hold that long), or several minutes later. Mostly it doesn't hold more than everal minutes, especially if there are a lot of disk operations going on (like downloading something from p2p with 400 kB/sec, but it doesn't happen only with p2p). And dma is turned off by kernel, you can verify it by digging sources. "DMA disabled" is kernel message produced by ide_dma_off(), which is located in drivers/ide/ide-dma.c, line 410 (in linux-2.6.25.7 sources). Also all hdparm settings are reset after system restart.

Last edited by ErV; 07-09-2008 at 07:11 AM.
 
Old 07-09-2008, 07:20 AM   #67
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 17.3+18.3+19.0, MX-17
Posts: 4,199

Rep: Reputation: Disabled
Well, on my system it stays on through the next boot, without me or a script calling hdparm (as far as I know) that's why I thought it gets set permanently in the disk itself. I'll have to look at my dmesg output, obviously.

Still, your system diagnoses I/O as unstable(?) or something. What creates the diagnostic value of "unstable -> disable DMA"?
 
Old 07-09-2008, 08:58 AM   #68
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by JZL240I-U View Post
Well, on my system it stays on through the next boot, without me or a script calling hdparm (as far as I know) that's why I thought it gets set permanently in the disk itself. I'll have to look at my dmesg output, obviously.
you are using Suse, and I don't know how exactly your system behaves during boot. For example, on Ubuntu there is /etc/hdparm.conf which is being read by some of the init scripts which call hdparm after that, your system might use something similar. Also see here: http://www.linuxforums.org/forum/sus...47-hdparm.html

Quote:
Originally Posted by JZL240I-U View Post
Still, your system diagnoses I/O as unstable(?) or something. What creates the diagnostic value of "unstable -> disable DMA"?
See first message here (dmesg output, HDD models, etc.).

Last edited by ErV; 07-09-2008 at 09:00 AM.
 
Old 07-09-2008, 09:10 AM   #69
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 17.3+18.3+19.0, MX-17
Posts: 4,199

Rep: Reputation: Disabled
That's not what I meant. The kernel obviously evaluates some signals (from the hd?) and then decides that DMA is unstable. Where do the signals originate from? Why?

Did you check the cables (40 vs. 80 lines)?
 
Old 07-09-2008, 10:40 AM   #70
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by JZL240I-U View Post
That's not what I meant. The kernel obviously evaluates some signals (from the hd?) and then decides that DMA is unstable. Where do the signals originate from? Why?
You are asking "which condition makes kernel decide to switch DMA off?", am I correct? If so, then right now I don't know what makes kernel decide to disable DMA. I can try to figure that out, but that'll require digging through kernel source. Also dmesg messages doesn't say DMA is "unstable", it's just notifies that "DMA is disabled".

Quote:
Originally Posted by JZL240I-U View Post
Did you check the cables (40 vs. 80 lines)?
Visually they appear to be in good condition, but they aren't new.
 
Old 07-09-2008, 10:59 AM   #71
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 17.3+18.3+19.0, MX-17
Posts: 4,199

Rep: Reputation: Disabled
Quote:
Originally Posted by ErV View Post
You are asking "which condition makes kernel decide to switch DMA off?", am I correct?
No, I meant where does that signal originate and why is it generated there.
Quote:
Originally Posted by ErV View Post
If so, then right now I don't know what makes kernel decide to disable DMA. I can try to figure that out, but that'll require digging through kernel source. Also dmesg messages doesn't say DMA is "unstable", it's just notifies that "DMA is disabled".
Not necessary, there will be some threshold or some such. But why is it triggered at all?
Quote:
Originally Posted by ErV View Post
Visually they appear to be in good condition, but they aren't new.
Again: 40 or 80 lines?? I had that issue with a CD-Recorder and DMA ... has some bearing on signal quality or signal to noise ratio.

Last edited by JZL240I-U; 07-09-2008 at 11:01 AM.
 
Old 07-09-2008, 12:36 PM   #72
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by JZL240I-U View Post
No, I meant where does that signal originate and why is it generated there.
Then I don't understand you. What signal are you talking about? I was thinking about kernel code, but you clearly mean something different.

Quote:
Originally Posted by JZL240I-U View Post
Again: 40 or 80 lines?? I had that issue with a CD-Recorder and DMA ... has some bearing on signal quality or signal to noise ratio.
Both drives with dma problem are connected to single 40-lines cable.
--EDIT--
I've replaced 40-lines cable with newer 80-lines cable, and disabled my own "rc.hdparm" script, so system will decide automatically which mode to use. Right now I'm testing it. With newer cable (and without hdparm script) system picked up good mode automatically (udma5 transfer, dma on, 32bit-io on, unmask irq on, udma5 didn't work before - any attempt to use it resulted in system hang). I'll write later (several hours later or tomorrow) if new cable cured problem or not.

Last edited by ErV; 07-09-2008 at 01:17 PM.
 
Old 07-09-2008, 10:43 PM   #73
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,238
Blog Entries: 29

Rep: Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437
Hi,

The modern HDD sets the best fit for 'DMA'. If you have a '80' vs '40' then most certainly there can be a issue. With the '40' your dma will be limited.
 
Old 07-10-2008, 03:58 AM   #74
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 17.3+18.3+19.0, MX-17
Posts: 4,199

Rep: Reputation: Disabled
Well, obviously you are on to something. Good luck there.
Quote:
Originally Posted by ErV View Post
Then I don't understand you. What signal are you talking about? I was thinking about kernel code, but you clearly mean something different...
Just to clarify: The kernel must use some criterion to decide to switch off dma-mode -- after all, the mode runs for some minutes until this happens. What is that criterion? And don't say a bad connection, somehow the kernel must "measure" the quality of the connection and then decide "well, now it isn't good enough anymore".

Since I presume the kernel delegates the measurement, I asked where in the system is the measurement executed and by whom, what signal is generated and how is that transmitted to the kernel.

Reason: perhaps one could deceive the "measuring agency" or somehow else change the signal...

Last edited by JZL240I-U; 07-10-2008 at 05:08 AM.
 
Old 07-10-2008, 07:15 AM   #75
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by JZL240I-U View Post
Well, obviously you are on to something. Good luck there.
Great thanks for the mention about 40-lines cable.
It looks like after replacing cable DMA problem is gone (don't know yet about accidental data losses, maybe this fixed them too). After several hours of disk IO, there is only one error in dmesg, and dma is still enabled on both drives. I never thought it could be because of 40-lines cable, and almost given up hope of fixing that problem (it was hugest annoyance on my system). It's funny that it took so much time (several months) to fix this, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
new laptop help making choice (more laptops add to poll) italiano40 Linux - Laptop and Netbook 16 05-01-2008 10:12 AM
LXer: Poll: No easy choice between open source, commercial LXer Syndicated Linux News 0 10-06-2006 11:33 AM
Members' choice awards: Show the poll choices? vharishankar LQ Suggestions & Feedback 0 01-08-2005 06:24 AM
Poll: MP3/CD player of choice for KDE rikkulinux Debian 2 08-19-2003 11:12 PM
terminals in members choice award poll? doublefailure LQ Suggestions & Feedback 2 04-01-2003 08:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration