Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 05-22-2014, 07:19 AM   #1
Sefid par
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware Current, Ubuntu server 18.04, Debian 9
Posts: 127

Rep: Reputation: 26
Question PolicyKit1-KDE

at every KDE starting I get the message with title of "PolicyKit1-KDE":
an application is attempting to perform an action that requires privileges. Authentication is required to perform this action.
and asks for root password.


Action: Folder Watch limit

How can I find out why this message show, and what to do to get rid of it?
Old 05-22-2014, 12:12 PM   #2
Senior Member
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,491
Blog Entries: 2

Rep: Reputation: Disabled
Hi Sefid, how's life treating you?

How can I find out why this message show
It's a bug in KDE as far as I can tell having looked here and here and here.
I didn't dig into all the threads looking for the solution however the one I dig into didn't have one in it.

As far as a best guess as to why it's happening

FileWatch: Use KAuth to automatically raise the inotify watch limit if
we run out of watches.

When we run out of watches, use a KAuth action to double the inotify
watch limit (by writing to /proc/sys/fs/inotify/max_user_watches).
At the same time, make the new setting persist across reboots by writing
So a workaround might be look at /proc/sys/fs/inotiy/max_user_watches (mines set to 8192) and tweak it, or perhaps it's your /etc/sysctl.d/97-kde-nepomuk-filewatch-inotify.conf (My Slackware install doesn't have that directory,but I've never booted KDE so...maybe you do.)
IF that doesn't work....
Here's the KDE bug tracker for bugs involving "policykit", or you might post a question on our KDE maintainers blog.

Last edited by dijetlo; 05-22-2014 at 12:45 PM.
2 members found this post helpful.
Old 11-25-2014, 08:33 AM   #3
Senior Member
Registered: Nov 2013
Location: Brazil
Distribution: Slackware
Posts: 1,223

Rep: Reputation: 195Reputation: 195
OP, how did you solve this problem? I am running Slackware 14.1 with KDE 4.13.3 and I am with the same problem.

I tried a few things I've found:

# echo 10240 > /proc/sys/fs/inotify/max_user_watches
It didn't work, the limit was raised but it didn't solve the problem. Now the limit went back to the normal value (8192).

Removing local nepomuk entries:
$ rm -rf ~/.kde/share/apps/nepomuk/
It seems this is the solution but Slackware doesn't have /etc/systcl.d. Where are those files located?
Old 11-25-2014, 10:22 AM   #4
Registered: Jun 2009
Location: Cloverdale, northern california
Distribution: Slackware 14.2
Posts: 185

Rep: Reputation: 153Reputation: 153
I don't notice this bug, but permanent settings on Slackware 14.1 can go in /etc/sysctl.conf with
fs.inotify.max_user_watches = 10240
then reboot, it's set here
/etc/rc.d/rc.S:    /sbin/sysctl -e -p /etc/sysctl.conf
I looked for inotify like this
sysctl -A | grep inotify
and set up sysctl.conf like the man page suggests. HTH
2 members found this post helpful.
Old 11-25-2014, 03:57 PM   #5
Senior Member
Registered: Nov 2013
Location: Brazil
Distribution: Slackware
Posts: 1,223

Rep: Reputation: 195Reputation: 195
Thanks, I've set it to 20480 and it worked


authentication, kde, policykit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed cccc Debian 3 07-07-2016 01:25 PM
polkit: Lost the name org.freedesktop.PolicyKit1 - exiting McZ Linux - Software 1 12-04-2012 03:02 AM
LXer: KDE Science: Thomas Friedrichsmeier on RKWard, Toolkits and the KDE Platform LXer Syndicated Linux News 0 09-13-2010 11:30 PM
Aborted KDE 3.5.1 Install while using KDE 3.4 and KDE and Gnome Won't Boot cheetahman SUSE / openSUSE 5 03-04-2006 12:03 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:42 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration