LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-06-2008, 04:21 PM   #1
Chaves
Member
 
Registered: Mar 2008
Posts: 33

Rep: Reputation: 15
Please help: using Fn buttons on laptop keyboard. KDE


Hi everyone.

Just migrated to Slackware 12 from KUbuntu a week ago and found some problems using the Fn buttons on my laptop.

when I was using ubuntu, my Fn buttons were configured automatically, so I had no problems with them.
However, Slack did not configure them, so I searched for some howtos on this topic.
I've used xev to determine the key codes for +-sound. Unfortunately it gave no output for brightness, mute sound and sleep mode buttons at all, however these are not as important for me as sound control.

Then I edited /etc/X11/xinit/.Xmodmap with
keycode 174 = XF86AudioLowerVolume
keycode 176 = XF86AudioRaiseVolume

The next step is to edit the window manager keyboard config file, but I can't find any info on where it is for KDE wm. The howtos I found were only for icewm and fluxbox and were not of help to me =\

thank you for your help

Roman

Last edited by Chaves; 03-06-2008 at 05:01 PM.
 
Old 03-06-2008, 04:38 PM   #2
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,623

Rep: Reputation: Disabled
I'm not in KDE, but you should be able to configure shortcuts from the Settings->Regional & Accessibility->Keyboard Shortcuts (or something similar). A whole list of actions should be there such as mute and volume control. Select an action and the press the key(s) you want to associate with that action.

In order for the screen brightness to work you will need the "video" module. "lsmod | grep video" to see if you have it and "modprobe video" to load it if you don't (and then add it/uncomment it in /etc/rc.d/rc.modules so that it loads automatically if you reboot).

Brian
 
Old 03-06-2008, 04:54 PM   #3
Chaves
Member
 
Registered: Mar 2008
Posts: 33

Original Poster
Rep: Reputation: 15
Thanks Brian.
I'll try to set the video up.

The sound Fn buttons can't be set up with Settings tab in KDE, since the system is not recognizing the Fn button combination. For instance, I can set the shortcut for Win+F5 to increase volume, but it does not assign Fn+F5.

That's why i tried to xev it. xev's output gave 174 and 176 keycodes as stated before, but had no output for Fn+F7/8 for brightness/sleepmode.

What i'm trying to do now is to assign these keycodes to +-sound, but can't find the right config file.
For icewm it is supposed ot be in ~/.icewm/keys but its different from kde =(
 
Old 03-06-2008, 05:12 PM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,623

Rep: Reputation: Disabled
Perhaps you need to change the keyboard layout. It should be in the same general area of the kde settings.

Brian
 
Old 03-06-2008, 05:47 PM   #5
C-Sniper
Member
 
Registered: Dec 2006
Distribution: Slackware
Posts: 507

Rep: Reputation: 33
tried that with my Hp zv6000. doesn't work.
 
Old 03-06-2008, 05:52 PM   #6
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,623

Rep: Reputation: Disabled
Quote:
Originally Posted by C-Sniper View Post
tried that with my Hp zv6000. doesn't work.
Very strange. Which layout did you choose? I've got a hp zv5000 and the Fn key works fine with the Generic 105-key intl layout.

Brian
 
Old 03-06-2008, 08:21 PM   #7
C-Sniper
Member
 
Registered: Dec 2006
Distribution: Slackware
Posts: 507

Rep: Reputation: 33
i did not try the generic 105-intl, i went digging through all of the laptop versions for HP.
 
Old 03-07-2008, 08:49 AM   #8
Chaves
Member
 
Registered: Mar 2008
Posts: 33

Original Poster
Rep: Reputation: 15
Ok, problem solved.

I just changed 104 to 105 in xorg.conf

Thanks for help
 
Old 03-17-2008, 08:33 PM   #9
MrAexo
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by Chaves View Post
Thanks Brian.
I'll try to set the video up.

The sound Fn buttons can't be set up with Settings tab in KDE, since the system is not recognizing the Fn button combination. For instance, I can set the shortcut for Win+F5 to increase volume, but it does not assign Fn+F5.

That's why i tried to xev it. xev's output gave 174 and 176 keycodes as stated before, but had no output for Fn+F7/8 for brightness/sleepmode.

What i'm trying to do now is to assign these keycodes to +-sound, but can't find the right config file.
For icewm it is supposed ot be in ~/.icewm/keys but its different from kde =(
I'm trying to set my Gateway laptop (with the same 174/176 codes)

I'm using fluxbox, and there's a ~/.fluxbox/keys file, but I'm not sure what I'm doing once in the file. Could you explain what you were intending to put there? Was it those two lines in the first post? They don't work for me, gives a command not found when just entering "XF86AudioRaiseVolume" on the term window.

Last edited by MrAexo; 03-17-2008 at 08:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Customize your laptop keyboard with X and KDE LXer Syndicated Linux News 0 07-27-2007 04:46 PM
How do I use the extra buttons on my keyboard? (SuSE, KDE) Nebetsu Linux - General 4 12-18-2006 05:06 AM
Help binding mouse buttons to keyboard buttons Eckstona Linux - Hardware 6 09-24-2006 08:28 AM
I need help with keyboard buttons (compaqeak8) sonicbhoc Linux - Hardware 4 08-23-2006 01:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration