LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-15-2011, 04:13 AM   #1
fdeak
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware-14.0, Slackware-current
Posts: 21

Rep: Reputation: 2
Exclamation please check httpd-2.2.21-x86_64-1_slack13.0 (web server will not start)


I have the following error in syslog (and a dead httpd server) under salck64-13.0 after upgrading http-2.2.21 today:

Code:
httpd: Syntax error on line 112 of /etc/httpd/httpd.conf: Cannot load /usr/lib64/httpd/modules/mod_negotiation.so into server:/usr/lib64/httpd/modules/mod_negotiation.so: undefined symbol: ap_set_accept_ranges
I reverted to the previous version (2.2.20) with a great panic . I have no time now to examine the problem, but be warned...

Please check/verify this.
If you have such a system and have a succesfull upgrade please answer to this thread, and I will check it again, but be prepared to be able revert this patch.

Sorry if it is a false alarm but I think it's better to say a warning than leave other systems to fail.

Please note that this is not a spelling syntax error in httpd.conf, this is an error in the mod_negotiation module.


fdeak

Last edited by fdeak; 10-15-2011 at 04:39 AM.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 10-15-2011, 05:14 AM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,390

Rep: Reputation: Disabled
I had this on 13.37 (32).

I didn't see that error but I didn't check syslog.

I restarted httpd again and it 'seemed' to be ok. I'll keep an eye on it though.

Last edited by dive; 10-15-2011 at 05:15 AM.
 
Old 10-15-2011, 05:32 AM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
I have the following error in syslog (and a dead httpd server) under salck64-13.0 after upgrading http-2.2.21 today:
I've just restarted my system after the latest upgrades and my apache server won't start - same problem with mod_negotiation.so. This is on a Slackware64 13.37 system. I don't have a copy of the previous update to
httpd-2.2.20-x86_64-1_slack13.37.txz or the time to investigate further so I've had to resort back to the original httpd-2.2.17-x86_64-3.txz. Not at all ideal but it'll do for now till things get looked into.
 
Old 10-15-2011, 12:43 PM   #4
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,757

Rep: Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604Reputation: 5604
Hi,

A thousand pardons and I'm looking into this as soon as possible. Luckily OSUOSL is no longer blocked. BTW, it's not Slackware specific:

http://icesquare.com/wordpress/apach...n-freebsd-8-2/

Cheers,

Pat
 
4 members found this post helpful.
Old 10-15-2011, 12:55 PM   #5
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Thanks a lot for the prompt feedback.
 
Old 10-17-2011, 03:14 AM   #6
fdeak
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware-14.0, Slackware-current
Posts: 21

Original Poster
Rep: Reputation: 2
Just a quick note: if you restart httpd twice it will run fine.
[#2 says the same, but I would like to be clear on this, because bgeddy reverted the patch, while a double restart is solves the problem, or at least it seems to be solve ]

Last edited by fdeak; 10-17-2011 at 03:31 AM.
 
1 members found this post helpful.
Old 10-18-2011, 10:46 AM   #7
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Gentoo
Posts: 2,125

Rep: Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780
Thank you for posting that tip. I upgraded Apache today in a Slackware 13.1 server install and ran into the same problem. It complained about not being able to load mod_negotiation.so and pointed to the line in httpd.conf. My initial reaction was to turn this feature off, which allowed the server to start. What puzzled me was that I kept my old configuration file after looking at the differences, meaning that this was not a totally new module. After reading your post, I turned it back on, and restarted again. This time it was fine with the option. Apparently something about the patch causes a change that creates a temporary error.
 
Old 10-18-2011, 11:59 PM   #8
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 229Reputation: 229Reputation: 229
Just curious here...

Did you stop httpd before the upgrade or did you upgrade while the server was still running?
 
Old 10-19-2011, 07:38 AM   #9
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Gentoo
Posts: 2,125

Rep: Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780
I let it upgrade while it was running. Sometimes I will stop the process(es) before running the upgrade, but then I also anticipate that the script will automatically stop the process before changing files and then restart it after the changes. Perhaps I am spoiled from other distributions, but it would be best for the upgrade scripts to not make any assumptions and stop and start the process.

Do you think that this is the cause of this problem?
 
Old 10-19-2011, 07:57 AM   #10
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,193
Blog Entries: 18

Rep: Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914
Quote:
Originally Posted by Noway2 View Post
Perhaps I am spoiled from other distributions, but it would be best for the upgrade scripts to not make any assumptions and stop and start the process.
But by thinking it's ok to stop and start the processes the script would be making assumptions.

That's one of the fundamental differences between Slackware and other distros. The Slackware wisdom is that it's best to leave those sorts of decisions to the humans. This may occasionally catch someone out when they're not paying attention, but on the whole I believe it's for the best.
 
Old 10-19-2011, 02:08 PM   #11
fdeak
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware-14.0, Slackware-current
Posts: 21

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by mRgOBLIN View Post
Just curious here...

Did you stop httpd before the upgrade or did you upgrade while the server was still running?
I'm not stopped it, but I never stopped apache before for an upgrade, and it was ok until this patch.

fdeak
 
Old 10-19-2011, 03:56 PM   #12
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Gentoo
Posts: 2,125

Rep: Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780Reputation: 780
This problem appears to be somewhat common and distribution agnostic and I am really starting to wonder if this was the cause of the problem. Something to note for the future and a potential 'wrinkle' to complicate using the text base slackpkg tool, which tells you what upgrades are available and performs the operation(s) on your behalf.
 
Old 10-19-2011, 09:37 PM   #13
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
This httpd update did not cause issues here (13.37 x86_64). I look at which updates there are (mailing list, changelog, slackpkg dialog). Stop services pertaining to the updates, apply updates, start services. Web server is functional. Nothing in systemlog, dmesg, httpd/error_log ....

You wouldn't try to keep firefox open while upgrading it would you (kind of hard to do that if you follow the book )
 
Old 10-19-2011, 09:47 PM   #14
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
For server activities often a live upgrade is the preferred method...for example, when upgrading ssh remotely, restarting sshd still hangs onto existing connections. Obviously stopping the service before the upgrade is not possible. For other services perhaps the same situation does not apply but certainly any downtime for a web server should be minimized and upgrading over the existing installation and restarting the service has been a fine solution in the past.

It should be noted that I did not get bitten by this but the above still stands, and I don't think a live upgrade is as silly as some are making it out to be.
 
1 members found this post helpful.
Old 10-19-2011, 10:14 PM   #15
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
The downtime involved in stop, update, start, is less than - apply update, restart, WTF!!!! why didn't it work!!!
An ounce of prevention is worth a pound of cure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Breakage occasioned by xrdb-1.0.9-x86_64-1_slack13.1 catkin Slackware 1 05-02-2011 12:04 PM
RHEL 5.1 after installing mod_ssl, httpd server wont start athreyavc Linux - Server 5 04-11-2010 09:52 PM
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 07:24 AM
Can't start httpd server on fedora core 5 pompadir Linux - Server 8 05-30-2007 03:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration