LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Plasma5 - SDDM black screen after kernel/mesa/xorg update (https://www.linuxquestions.org/questions/slackware-14/plasma5-sddm-black-screen-after-kernel-mesa-xorg-update-4175575167/)

michelino 03-17-2016 12:57 PM

Plasma5 - SDDM black screen after kernel/mesa/xorg update
 
On my machine running slackware-current and Eric's Plasma5 set of packages, I've upgraded all together kernel-4.4.5, mesa-11.1.2 and xorg-server-1.18.2, and sddm login stopped working.
Booting in runlevel 4 I get only a black screen with blinking cursor on the top-left side of the monitor.
Everithing works flawlessy booting in runlevel 3 and using "startx".
Nothing has changed with the latest "KDE 5_16.03" upgrade.

In /var/log/messages I find lot of

Code:

kernel: [  158.167700] traps: sddm-greeter[1367] trap invalid opcode ip:7ffb34613646 sp:7fffac74c8a0 error:0
and

Code:

kernel: [ 4620.217407] sddm[6332]: segfault at 430 ip 0000000000000430 sp 00007ffd2b1a1e28 error 14 in sddm[400000+67000]
kernel: [ 4615.310438] sddm[6316]: segfault at 7f217a4bbe58 ip 00007f217a
4bbe58 sp 00007ffdd53e3f88 error 15 in libc-2.23.so[7f217a4bb000+2000]

wile in /var/log/sddm I find

Code:

Initializing...
[18:00:10.858] (II) DAEMON: Starting...
[18:00:10.858] (II) DAEMON: Adding new display on vt 7 ...
[18:00:10.870] (II) DAEMON: Display server starting...
[18:00:10.870] (II) DAEMON: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{1d085634-52e9-4bf5-a2a1-eb7bcb8fefec} -background none -noreset -displayfd 17 vt7
[18:00:12.706] (II) DAEMON: Running display setup script  "/usr/share/sddm/scripts/Xsetup"
[18:00:12.743] (II) DAEMON: Display server started.
[18:00:12.743] (II) DAEMON: Socket server starting...
[18:00:12.747] (II) DAEMON: Socket server started.
[18:00:12.749] (II) DAEMON: Greeter starting...
[18:00:12.749] (II) DAEMON: Adding cookie to "/var/run/sddm/{1d085634-52e9-4bf5-a2a1-eb7bcb8fefec}"
[18:00:12.821] (II) DAEMON: Greeter session started successfully
[18:00:13.385] (II) DAEMON: Message received from greeter: Connect
[18:00:19.043] (WW) DAEMON: Auth: sddm-helper exited with 4
[18:00:19.043] (II) DAEMON: Greeter stopped.
[18:04:52.115] (II) DAEMON: Display server stopped.
[18:04:52.115] (II) DAEMON: Running display stop script  "/usr/share/sddm/scripts/Xstop"
[18:04:52.129] (II) DAEMON: Socket server stopping...
[18:04:52.129] (II) DAEMON: Socket server stopped.
[18:04:52.129] (II) DAEMON: Removing display ":0" ...

Googling around it seems related to the kernel, does anyone have the same problem?

P.S.: I've a skylake processor.

Drakeo 03-18-2016 06:13 AM

I did a full upgrade yesterday it went flawless. and I run multi lib.
I skipped two upgrades and did this one.
after downloading the latest stable current 5.
First I upgraded all my slackware and made sure all my sbo-builds would be updated with any new additions.
then this is the script I used. after I uninstalled nvidia.

Code:

#!/bin/bash
  slackpkg update
  slackpkg install-new
  slackpkg upgrade-all
 
  slackpkg install ConsoleKit2
  slackpkg install eigen2
  slackpkg  install xapian-core

  slackpkg re-install ConsoleKit2
  slackpkg re-install eigen2
  slackpkg  re-install xapian-core
 
  removepkg ConsoleKit
  removepkg grantlee-qt5
  removepkg kgamma
  removepkg pairs
  removepkg LoginKit
  removepkg kdeconnect4
  rsync -r -a -v --bwlimit=200 --delete --progress --stats rsync://rsync.slackware.org.uk/people/alien/multilib/current/ /var/cache/multilib/
  cd /var/cache/multilib
  upgradepkg  --install-new *.t?z
  cd /var/cache/multilib/slackware64-compat32
  upgradepkg --install-new *?/*.t?z
 
  cd /root/5
 upgradepkg --reinstall --install-new x86_64/deps/*.t?z
 echo deps installed
 sleep 2
 upgradepkg --reinstall --install-new x86_64/deps/telepathy/*.t?z
  echo telepathy installed
 sleep 2
 upgradepkg --reinstall --install-new x86_64/kde/*/*.t?z
 slackpkg new-config
 echo kde installed

then I rebooted with the vmlinuz-huge telinit 3
created an intrid.gz. then I ran my linux setup scripts.
then rebooted with the generic kernel
then rebuilt the latest nvidia.
after logging in the theme manager would not change. so I logged out.
init 3 logged in as root and deleted ~/home/.kde and .config and .cache of my user.
then logged using init 4
signed in as the user and things where ok. The only issue I find is fonts are going blurry they do not seem to refresh at times.
after that I rebuilt all my media ffmpeg vlc patents yes rebuilt pulseaudio so it would use my jackd2 then rebuilt mplayer to use patents yes.
rebuilt my alsa-plugins so they would build against ffmpeg and jack2 and pulse audio rebuilt speex from slackbuilds.
That is my experience.
I only blacklist I have alien and compat32.

michelino 04-26-2016 09:23 AM

Ok, I solved the issue, for reasons that I don't know, "sddm" no longer wasn't in "video" group.
Adding sddm user to the video group did the trick.

Michelino


All times are GMT -5. The time now is 01:46 PM.