LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   plasma-desktops does not respond (but hasn't crashed) to mouse movements (https://www.linuxquestions.org/questions/slackware-14/plasma-desktops-does-not-respond-but-hasn%27t-crashed-to-mouse-movements-839605/)

nass 10-21-2010 01:21 PM

plasma-desktops does not respond (but hasn't crashed) to mouse movements
 
Hello everyone.
Well the title only states half the problem. and the truth is I am not even sure how to phrase this problem as a google search in order to get some search-hits... so here it goes:
I am running slackware-current on a laptop, the gpu is ATI radeon X300 and the gpu driver is 'radeon'.

now, the problem seems to be with plasma-desktop application of kde4. when I log on to an X session (i'm usually booting in runlevel3 and if I want gui i do 'startx') things seem to load up fine until the point that the task-bar appears. Then, NO mouse action ((double)-click, right-click) is interpreted, meaning that the K-menu doesn't pop up, nor i can open up any menus (on the desktop or the task-bar).

what i can do:
-I can still move the mouse.
-I can press Alt+F2 to get a run prompt
-A konsole window I had left open from a previous session is still gonna start up and I can type in it.
-I can even click and drag the window around!

'top' doesn't show anything wrong (X and plasma-desktop seem to chew on resources sensibly) and plasma-desktop hasn't crashed.

Things didn't always used to be like that. kde4 worked fine up to the point I decided to start a session once from a windows machine (that is to say a remote X session).
To do that I used 'X-win32' and 'Putty' to ssh -X (well the windows equivalent of that) to my laptop and then do 'startkde'. The remote X session worked fine. and I can log on again and again from remotely and the X session will continue working fine.
But trying to startx (or startkde) locally on the laptop will leave me with a non responsive desktop...

Could it have something to do with 3d acceleration? - when i log in remotely, all the 'sweet' effects of kde4 (like fade in, or moving in of windows and menus is disabled).

But listen to this:
I did a bold move and deleted my account (its ok i only recently installed slackware in this laptop- so i don't have much stuff in it yet). then added a new user again and voila. logging in X locally is possible again.
so i wonder if something is 'released' properly after the remote X kde session. something like a pid file, or some script. There must be something I can delete (instead of the whole account, or the .kde folder) in order to 'reset' the session.

Final note: using xfce as gui, works equally well from local and remote log ons to X.

Any help or guidance as to what to do with this will be appreciated.
Thank you


All times are GMT -5. The time now is 12:30 AM.