LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-12-2019, 01:13 PM   #1
Geremia
Member
 
Registered: Apr 2011
Distribution: slackware64-current
Posts: 359

Rep: Reputation: 39
Unhappy Plasma 5.14.4 + Nvidia = slow responsiveness


I'm experiencing very slow Plasma responsiveness and not-very-fluid cursor with a GeForce GT 710 on a very fast machine, with both the recent short- and long-term Nvidia drivers. It doesn't matter what the resolution is or what the refresh rate is set at, the Application Launcher menu, for example, takes 1-2 seconds to pop up, and I have desktop effects and compositing off!

Firefox, however, renders webpages fast, but menus etc. pop up just as slowly. Plasma with the VESA driver is fast. It's some combination of Plasma with the Nvidia drivers that seems to be causing the slowdown. I'm using KDE Plasma 5.14.4.

I tried the tricks mentioned in this thread, but they didn't help.

Anyone else experiences these slowdown issues?
 
Old 01-13-2019, 10:52 AM   #2
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 928

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Are you using forcefullcomposition pipeline?

Under Section "Screen" you could try using the old NVIDIA composition pipeline with:
Code:
Option         "UseNvKmsCompositionPipeline" "false"
 
Old 01-14-2019, 01:08 PM   #3
Geremia
Member
 
Registered: Apr 2011
Distribution: slackware64-current
Posts: 359

Original Poster
Rep: Reputation: 39
Quote:
Originally Posted by RadicalDreamer View Post
Are you using forcefullcomposition pipeline?

Under Section "Screen" you could try using the old NVIDIA composition pipeline with:
Code:
Option         "UseNvKmsCompositionPipeline" "false"
Here's my Section "Screen":
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "3840x2160_24 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

    # from: https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Avoid_screen_tearing
    #Option         "AllowIndirectGLXProtocol" "off"
    #Option         "TripleBuffer" "on"

    # from: https://www.linuxquestions.org/questions/slackware-14/plasma-5-14-4-nvidia-%3D-slow-responsiveness-4175646069/#post5948506
    Option         "UseNvKmsCompositionPipeline" "false"

    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Your suggestion, and also what I commented out, didn't improve latency.
Do these composition options even matter? I have KDE compositing disabled. In fact, I get the same sluggishness regardless if KDE's compositing is on or off.

Is the Nvidia GT 710 just a really slow graphics card?

Last edited by Geremia; 01-14-2019 at 01:20 PM.
 
1 members found this post helpful.
Old 01-14-2019, 01:50 PM   #4
LuckyCyborg
Member
 
Registered: Mar 2010
Posts: 366

Rep: Reputation: 155Reputation: 155
Quote:
Originally Posted by Geremia View Post
Is the Nvidia GT 710 just a really slow graphics card?
No, the Nvidia GT 710 is a really nice entry level graphics card.

However, the Plasma5 issues are famous with the NVidia graphics cards and proprietary drivers.

A very skilled user here, Darth Vader who dedicated on 2018 a box just for testing Plasma5 under Slackware, said somewhere that to understand the Plasma5 state on NVidia, is better to believe that the KDE developers just hate the NVidia proprietary drivers and do their best to make those graphics cards to behave as slow as possible.

Still, the Plasma5 plays quite nice with the NVidia cards, if is used the open-source driver Nouveau.

I have a quite old NVidia GeForce 210 which drives well the current Plasma5 using Nouveau, and forcing the performance level on boot. In my case is on "/etc/rc.d/rc.local"
Code:
# Switch the GeForce 210 graphics card to max performance.
if [ -f /sys/kernel/debug/dri/0/pstate ]; then
    echo 0f > /sys/kernel/debug/dri/0/pstate
fi
But maybe I am just lucky.

Last edited by LuckyCyborg; 01-14-2019 at 02:06 PM.
 
Old 01-14-2019, 02:06 PM   #5
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,619

Rep: Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627Reputation: 3627
I have a much higher-end NVidia card (a GTX 970), but I can report that Plasma 5 works great for me. I have this as my entire X configuration (/etc/X11/xorg.conf.d/10-local.conf):

Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
That's with the binary drivers of course.

Last edited by dugan; 01-14-2019 at 02:11 PM.
 
2 members found this post helpful.
Old 01-14-2019, 02:55 PM   #6
Geremia
Member
 
Registered: Apr 2011
Distribution: slackware64-current
Posts: 359

Original Poster
Rep: Reputation: 39
Solution: Use Nouveau, not closed-source Nvidia drivers!

Quote:
Originally Posted by LuckyCyborg View Post
Plasma5 plays quite nice with the NVidia cards, if is used the open-source driver Nouveau.
I'll try it.

Update: Wow, Nouveau is so much better, even with compositing enabled! Thanks for the suggestion!
Thank God for open source (⋙ closed source drivers*)!

(*Update #2: Except for 3D, in which case the Nvidia driver is faster (except a close tie in the Plot 3D subtest); cf. Nouveau 1.0.15 vs. Nvidia 415.25)

Last edited by Geremia; Yesterday at 10:21 AM.
 
Old 01-14-2019, 03:40 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,322

Rep: Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513Reputation: 5513
Thank all of you for this very informative thread.
 
Old 01-14-2019, 08:21 PM   #8
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 928

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Quote:
Originally Posted by Geremia View Post
Code:
    Option         "metamodes" "3840x2160_24 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
When I used a GT 930 I found that "ForceFullCompositionPipeline=On" made things more sluggish. I don't see any reason to use it because "ForceCompositionPipeline=On" takes care of the screen tearing. Nice monitor!
 
Old 01-14-2019, 10:22 PM   #9
Geremia
Member
 
Registered: Apr 2011
Distribution: slackware64-current
Posts: 359

Original Poster
Rep: Reputation: 39
Quote:
Originally Posted by RadicalDreamer View Post
Nice monitor!
Yes, I'm pleased by it. It's a 24", the smallest 4K one I could find on PC Part Picker.
 
Old Yesterday, 10:28 AM   #10
Geremia
Member
 
Registered: Apr 2011
Distribution: slackware64-current
Posts: 359

Original Poster
Rep: Reputation: 39
xorgsetup

Quote:
Originally Posted by Alien Bob View Post
Thank all of you for this very informative thread.
BTW, I had to comment out lines 198-254 of xorgsetup; otherwise, it'd throw a syntax error regarding a paren in the dialog command. Perhaps it has to do with my using Dvorak layout.
 
  


Reply

Tags
kde, nvidia, plasma, slackware, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow mouse responsiveness in X, is this normal? orgee Linux - Software 20 10-25-2004 03:46 PM
UI responsiveness yaBoy Linux - Laptop and Netbook 1 05-21-2004 06:23 PM
Improving USB Keyboard Responsiveness? dumtruck51 Linux - Newbie 4 12-26-2003 11:54 AM
USB problems with 2.6.0test11 - LOW system responsiveness GD_19 Linux - Hardware 1 12-03-2003 02:31 AM
Kernel tweaks/patches to improve responsiveness? sb73542 Linux - General 3 08-26-2003 03:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration