-   Slackware (
-   -   Pitivi (

interndan 04-16-2014 02:49 PM

Has anyone had luck making this run? I have tried twice to install this using SBOpkg with now luck.The first time I carefully built a queue file manually, the second try I used sqg to generate a queue file. In both instances the build appeared to work, but Pitivi fails to start when I try to run the program.

maciuszek 04-16-2014 03:54 PM

Well why is it failing? invoke it from a cli and post the out.
I haven't used pitivi ever, but it seems you can get alot of information setting the PITIVI_DEBUG variable.

interndan 04-16-2014 04:03 PM

running from command line I get the following:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Traceback (most recent call last):
  File "/usr/bin/pitivi", line 134, in <module>
  File "/usr/bin/pitivi", line 122, in _run_pitivi
    import pitivi.application as ptv
  File "/usr/lib/pitivi/python/pitivi/", line 44, in <module>
    from pitivi.settings import GlobalSettings
  File "/usr/lib/pitivi/python/pitivi/", line 29, in <module>
    import xdg.BaseDirectory as xdg_dirs  # Freedesktop directories spec
ImportError: No module named xdg.BaseDirectory

Apparently I'm missing something. A google search suggests I need xdg. That however isn't listed as a dependency.

maciuszek 04-16-2014 04:13 PM

source: . if it doesnt work reproduce the err with more verbosity `PITIVI_DEBUG=6 pitivi` .

Also go ahead and mention this to the maintainer of the SBo!

interndan 04-16-2014 04:23 PM

pyxdg did the trick looks like. Thanks for the help. Will mark this solved.

Mark Pettit 04-17-2014 10:47 AM

Whenever you get a situation like this, look up who the slacbkuild maintainer is, and then drop him/her a very friendly email, noting the issue, preferably with some notes about your efforts. And don't forget to thank him/her for their efforts, for which we make no payment.

interndan 04-17-2014 10:53 AM

Did that

All times are GMT -5. The time now is 08:12 PM.