LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-27-2019, 08:11 PM   #1
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Rep: Reputation: Disabled
pip does not connect: no ssl


I'm trying to install a package with pip, and I get this message. A quick web search suggests that pip may be out of date or in need of a recompile.

TIA

John.

WARNING: pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.",)': /simple/protobuf/
WA
 
Old 11-27-2019, 10:34 PM   #2
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,529

Rep: Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886Reputation: 1886
You might want to mention what version of Slackware you are running and if you have applied all of the updates.

That will help us help you, after all.
 
Old 11-28-2019, 12:14 AM   #3
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,107

Rep: Reputation: Disabled
And this should be an issue with your installation or configuration unless your Slackware be very old as this module is shipped in the python packages since Slackware 13.0

Last edited by Didier Spaier; 11-28-2019 at 12:15 AM.
 
Old 11-28-2019, 08:55 AM   #4
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Original Poster
Rep: Reputation: Disabled
Yeah. I shudda told you what I was running. It's slackware64-current, and I am up-to-date with the latest good stuff with slackpkg-plus.

Anyway, my pip is toast for SSL stuff right now, which is not good.

John.
 
Old 11-28-2019, 10:32 AM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,107

Rep: Reputation: Disabled
Please post the out put of:
Code:
find /usr/lib64 -name ssl.py
 
Old 11-28-2019, 11:01 AM   #6
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Original Poster
Rep: Reputation: Disabled
That find statement shows this.

/usr/lib64/python3.7/ssl.py
/usr/lib64/python2.7/ssl.py

I added the 3.7 a few days ago for something else; /usr/bin/python points to the 2.7 version.

John.
 
Old 11-28-2019, 12:08 PM   #7
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,107

Rep: Reputation: Disabled
How did you install pip? Do you use a virtual environment? If yes how is it set up?
 
Old 11-29-2019, 11:09 AM   #8
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Original Poster
Rep: Reputation: Disabled
How did I install pip? I did not, but slackware did.

So does it work for you?

When I run pip list, I get this:

WARNING: pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.",)) - skipping
 
Old 11-29-2019, 01:05 PM   #9
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,107

Rep: Reputation: Disabled
Which Slackware version are you running? pip is not shipped in Slackware version 14.2

Last edited by Didier Spaier; 11-29-2019 at 01:47 PM.
 
Old 11-29-2019, 01:45 PM   #10
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Original Poster
Rep: Reputation: Disabled
Please read #4 above. (Hint: It's slackware64-current)

BTW: I can forget about this issue because I solved it another way.

What I was doing was trying to build mysql-workbench for my slack installation. I've got all of the deps built now, but the mysql-workbench build is stopping with an error around 90 percent. I've got a bug report into mysql, but if anyone knows a handy way to get a gui for the mysql installation, it would be welcomed.

John.
 
Old 11-29-2019, 01:54 PM   #11
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,107

Rep: Reputation: Disabled
Quote:
Originally Posted by jkh2cpu View Post
Please read #4 above. (Hint: It's slackware64-current)
Yes, but in post #6 you wrote:
Quote:
Originally Posted by jkh2cpu View Post
I added the 3.7 a few days ago for something else; /usr/bin/python points to the 2.7 version.
This is not consistent, as Python 3.7 is shipped in Slackware current, so you shouldn't have added it yourself. Unless you did a partial installation in which case you are on your own.

So my current assumption is that somehow you managed to create the issue you mention. Without more information about your configuration I can't help you, sorry

Last edited by Didier Spaier; 11-29-2019 at 01:56 PM.
 
Old 11-29-2019, 01:59 PM   #12
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Original Poster
Rep: Reputation: Disabled
That's true, but it does not affect pip that runs with python-2.7.

How is there a problem?

My big issue is the gui for the database.

John.
 
Old 11-29-2019, 10:17 PM   #13
HQuest
LQ Newbie
 
Registered: Jan 2018
Location: 2001:470:c2d0::/56
Distribution: Anyone that I can interface with
Posts: 15

Rep: Reputation: Disabled
Make sure you have curl installed.
 
1 members found this post helpful.
Old 12-01-2019, 11:10 AM   #14
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 69

Original Poster
Rep: Reputation: Disabled
HQuest sent me on the right path, and I'm now fixed. I'll explain how.

I spent the last few days futzing with curl and openssl. The problem was that I used slackpkg+ to keep current. What I did not know until a few minutes ago was that the multilib versions did not do a full install. I just slackpkg reinstall curl and slackpkg reinstall openssl. It works again, and goodies like darktable build again :-)

I'll get back to mysql-workbench in a few days. I really want to do some sql stuff for fun and entertainment.

Thanks again HQuest.

John.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot upgrade Python/Pip, SSL errors Zeno McDohl Linux - Newbie 1 06-01-2018 09:01 AM
LXer: pip Uninstall | Uninstall a Package Installed with pip LXer Syndicated Linux News 0 03-01-2018 11:30 AM
Hello, Bon Jour, Pip Pip SocaSpice LinuxQuestions.org Member Intro 3 11-14-2010 09:22 AM
Apache with SSL does not load the 2nd SSL certificate janstapel Linux - Newbie 1 06-17-2010 10:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration