LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-07-2003, 04:55 PM   #1
madhaquer
LQ Newbie
 
Registered: May 2003
Distribution: Slack
Posts: 18

Rep: Reputation: 0
Unhappy php on slack


Hi,
I canty seem to get my Apache/1.3.27 2 work with php
here is a peek of my error_log file.
What could I have done wrong ?
_____________________________
[Wed May 7 23:11:08 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed May 7 23:11:13 2003] [notice] caught SIGTERM, shutting down
[Wed May 7 23:11:22 2003] [notice] Apache/1.3.27 (Unix) configured -- resuming normal operations
[Wed May 7 23:11:22 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
______________________________

Thanks
 
Old 05-07-2003, 05:33 PM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
What does your http.conf look like? To get php to work with apache you need to do the following:

Make sure you have the following commands in your http.conf file:
LoadModule php4_module libexec/libphp4.so
AddModule mod_php4.c
Include /etc/apache/mod_php.conf

Make sure you have the mod_php.conf file and the php.ini file in your /etc/apache directory.

Did you install the php package from the slackware cd? or did you compile it yourself. If so you need to make sure you compiled it with the right options, like enabling AXPS support.
 
Old 05-07-2003, 05:34 PM   #3
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
also, if you have command line php compiled (slackware package includes it) do the following:

php -info > php_info.html

Open php_info.html in a web browser and see if there are any problems.
 
Old 05-07-2003, 07:28 PM   #4
madhaquer
LQ Newbie
 
Registered: May 2003
Distribution: Slack
Posts: 18

Original Poster
Rep: Reputation: 0
Thanx alot
editing my httpd.conf has solved the problem.

I have however noted that apache does not start automatically on boot.
did I do something wrong?
 
Old 05-07-2003, 10:59 PM   #5
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
you need to make sure that the rc.httpd file in /etc/rc.d is chmod 775
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slack apache and php zuessh Slackware 4 04-23-2005 08:40 PM
Command Line PHP in Slack 10 Trano Slackware 4 02-12-2005 06:16 PM
Cannot See info.php in Apache 1.3.33 Slack 10 grimlaur Slackware 3 02-05-2005 04:27 PM
Slack 9.1 apache + php Greg21 Slackware 2 01-23-2004 01:22 PM
php and slack 9.0 bm1 Slackware 4 01-22-2004 05:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration