LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Photosmart D110 doesn't print images properly in Slackware 13.37 (https://www.linuxquestions.org/questions/slackware-14/photosmart-d110-doesnt-print-images-properly-in-slackware-13-37-a-934949/)

dracolich 03-17-2012 10:51 AM

Photosmart D110 doesn't print images properly in Slackware 13.37
 
I'm running Slackware 13.37 with an HP Photosmart D110. The printer was detected and setup easily in CUPS using the hpcups backend and I print to it wirelessly. There are no problems printing from XP on the same computer and also from a circa 2001 laptop running Ubuntu 10.10.

Text always prints fine but pictures don't. At first pictures would print with black background and messed up colors. I'm not sure how to describe it: inverted colors or negative mode? I thought it was a Firefox problem and searching led to bug reports of Firefox not handling png transparent backgrounds. I found an upgrade for Ghostscript to 9.02 and that helped but didn't completely fix it. More recently I tried printing some pdf documents using xpdf. Text is ok but in pictures darker colors are printing as red, green and yellow. I've checked the printer's settings in hp-toolbox and localhost:631. The only thing I know that I haven't tried is connecting the printer with usb.

This is annoying and it wastes ink when I have to pull out my portable Deskjet 450 and plug it in to reprint things. I should also mention that I never had any problems with a Deskjet 3520 connected with usb, and also wirelessly when it was connected to a Puppy Linux server.

As soon as I logged into LQ I found a thread mentioning a new Ghostscript
http://www.linuxquestions.org/questi...3-37-a-934428/

I'll give it a try later but would still like to know if anyone else has any ideas.

H_TeXMeX_H 03-18-2012 04:45 AM

It looks like an issue with ghostscript and printing pdfs. Have you tried printing just images, not in pdfs ?

What I did as a solution for a long while is convert the pdfs to djvu then print them. This fixed the problem, but it's a workaround. The fix is listed in the thread you linked to.

dracolich 03-18-2012 07:42 AM

Thanks for the reply H_TeXMeX_H. After upgrading gostscript from the 9.0 that came with Slack13.37 to 9.02 from -current I did successfully print files from GIMP, Firefox and from inserted into LibreOffice. The quality isn't as high as I'd like, certainly not as high as the printer is capable of, but it's tolerable for normal stuff.

I downloaded the ghostscript 9.05 src and a SlackBuild script and installed it last night. When trying to print only page1 of one of a pdf doc the result was even worse. I got 4 pages, each with a solid black square taking half the page. It would've kept going if I didn't cancel the job.

I often do woodburning art and I need to be able to print my patterns with clear, smooth lines. I'll try your djvu workaround and maybe connecting via usb which will involve physically moving the printer. Experimenting for a solution has already drained 1 black cartridge.

dracolich 03-18-2012 07:01 PM

I just finished trying with the printer connected with usb and installing a new color cartridge since the old one was low. Same results. The CUPS test page prints perfectly, but a simple jpg from GIMP, for example:
http://www.zumodrive.com/share/fNEiM2ViMW , prints nicely as gray scale, but in color the hourglass is green and the edges of the spider are speckled with white and red. The background and letters come out nice. Currently I'm using kernel 3.1.1 custom, cups 1.4.6, ghostscript 9.02 and hpijs/hpcups 3.11.3a. I tried to build pdf2djvu but it failed. I might explore it more later.

Again, I don't have this problem printing from XP, and I don't have any problems printing to usb Deskjet models.

Thanks in advance for any ideas.

dracolich 04-27-2012 04:04 PM

Finally figured it out. It was always using the hpcups driver chosen by the CUPS auto detection. When I noticed that and remembered my old Deskjet used hpijs I changed this one to hpijs and now my jpg files printed beautifully from GIMP.


All times are GMT -5. The time now is 02:17 AM.