-   Slackware (
-   -   Phoenix BIOS PXE boot question (

astrogeek 12-01-2012 12:23 AM

Phoenix BIOS PXE boot question
This is not Slackware specific and not an error - but an annoyance I'd like to fix.

I have just received a nice new machine (new to me anyway!) and am about to install Slackware 14-64 on it.

It has W7 installed on a 320GB WD drive, and I have successfully used a GParted live CD to shrink the NTFS partition to 40GB and prepared partitions for my Slackware installation. Everything works as far as I can tell.

My preference is to install from PXE on my LAN. I have a PXE server running and have verified it is working by booting another box from it.

But my new machine steadfastly refuses to boot from the LAN even though it appears to support it. I have tried all the obvious choices from the CMOS setup and have verified the device is working on my LAN under W7.

In the Phoenix BIOS setup I find the following:

Under Advanced BIOS Features >> Hard Disk Boot Priority
1. Legacy LAN
3. Hard Disk

There is also an option for "Boot Other Device" with choices of enable and disable - set to Enable.

Then, under Integrated Peripherals I have "PCI LAN boot ROM" set to Enabled.

Moving the CDROM ahead of the hard disk in the boot order does allow me to boot from CD, but the LAN boot is simply ignored, and I see no boot messages at all indicating it was tried and failed.

Curiously, removing the hard disk from the list entirely is also ignored - it still boots to the disk.

Any Phoenix BIOS gurus out there with an insight?

The machine is about 2 years old, no-brand custom build, AMD Phenom II X2 3.1Ghz, WD 320GB PATA, Nvidia nForce ethernet plus Ralink RT2800 80211.n.

Is it possible that the wireless device could mask the ehternet LAN at this stage?

Any ideas appreciated.

yuchankit 12-01-2012 01:21 AM

Have you tried to go to the boot menu (Probably press F12 during POST) and choose Network boot or some LAN boot?

astrogeek 12-01-2012 01:45 AM

I had tried F12 - no dice... then all the other Effs...

But just discovered that ESC does the trick and brings up a boot option selection!

Among the choices are "Boot from LAN" - which does not work - it continues to the HD.

But I tried each choice and "Nvidia boot age" makes it boot to the PXE server.

Thanks - now installing!

TobiSGD 12-01-2012 06:34 AM

Tip for the future: If you have a question that is not related to Slackware, but for example to hardware, like in this case, put it in the Hardware forum.
There is no need to clutter up the Slackware forum with non-Slackware questions.

Please mark this thread as solved using the thread tools at the top of the thread.

All times are GMT -5. The time now is 06:27 PM.