LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-05-2018, 06:16 AM   #1
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Persistent naming and kernel panic - part III


This is my third thread on this - the other two are here and here. The reason I am making a third is because I can't amend the OPs of the others and any responses would be to those OPs rather than this.

Nevertheless I believe I'm very close to sorting this out. I am still getting a kernel panic after I plug in my other two internal drives. I have set fstab up by UUIDs for my main drive and I have changed lilo.conf to point to it.

Here is fstab:

Code:
#below partition is /dev/sda2 - swap
UUID=3973ae50-15b7-4d57-a211-54b4cf951506        swap             swap        defaults         0   0

#below partition is /dev/sda1 - root
UUID=ff624ae7-b3d4-4ef5-887a-8d505669bfd0        /                ext4        defaults         1   1

#below partition is /dev/sda3 - home
UUID=3a2a529f-9216-43f6-9458-ae64cca849a2        /home            ext4        defaults         1   2

# /dev/sda5
LABEL=Data                                     /share/Music and Media Drive     ext4    defaults                             0 2

# /dev/sdb5
PARTLABEL="Linux filesystem"                   /share/Backup Drive  ext4    defaults                             0 2

#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
and lilo.conf

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:

append=" vt.default_utf8=0"
#boot = /dev/sda
boot = /dev/disk/by-id/ata-INTEL_SSDSA2M080G2GC_CVPO012502X3080JGN

#compact        # faster, but won't work on all systems.

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and 
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 100
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
#vga=791
# VESA framebuffer console @ 1024x768x32k
#vga=790
# VESA framebuffer console @ 1024x768x256
#vga=773
# VESA framebuffer console @ 800x600x64k
#vga=788
# VESA framebuffer console @ 800x600x32k
#vga=787
# VESA framebuffer console @ 800x600x256
#vga=771
# VESA framebuffer console @ 640x480x64k
#vga=785
# VESA framebuffer console @ 640x480x32k
#vga=784
# VESA framebuffer console @ 640x480x256
#vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
initrd = /boot/initrd-4.4.144.gz
# root = /dev/sda1
  root = /dev/disk/by-uuid/ff624ae7-b3d4-4ef5-887a-8d505669bfd0
  label = Linux
  read-only
# Linux bootable partition config ends
I am sure that there is something small I have missed here in getting the other two internal hard drives hooked up correctly and so I don't get a kernel panic. I've looked at bass's page on Persistent Naming a few times.

EDIT: seems I'm missing an initrd. I'll come back to this topic anon, apologies.

EDIT2: lilo.conf updated

Last edited by Lysander666; 08-05-2018 at 07:45 AM.
 
Old 08-05-2018, 07:29 AM   #2
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
This now works. Thanks to bassmadrigal. It took me three threads and a while to figure it out.

Here's what I did:

1. attained UUIDs for each partition in my main drive via the blkid command and inserted the UUIDs into fstab accordingly [see OP].

2. changed lilo to boot by drive id [rather than /dev/sdx] through

Code:
ls -la /dev/disk/by-id
[see lilo.conf in OP]

3. changed root command at end of lilo.conf to boot by uuid attained through blkid or ls -la /dev/disk/by-uuid

4. used mkinitrd to generate an initrd

Code:
/usr/share/mkinitrd/mkinitrd_command_generator.sh -k 4.4.144
then inserted the UUID of my root partition into the output:

e.g.

Code:
mkinitrd -c -k 4.4.144 -f ext4 -r "UUID=ff624ae7-b3d4-4ef5-887a-8d505669bfd0" -m jbd2:mbcache:ext4 -u -o /boot/initrd-4.4.144.gz
[this is just an example]

The lilo.conf section and LABEL and UUID section here are very important:

https://docs.slackware.com/howtos:sl...sistent_naming

5. ran the command.

6. Inserted the other drives into fstab re the OP.

7. reran lilo -v and rebooted.

It seems simple now but this took me the longest to get my head around out of any computer problem in recent memory. Thanks to all that helped in the previous threads, but mostly thanks to bassmadrigal.

Now df -h gives

Code:
lysander@psychopig-xxxiv:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
tmpfs            32M  1.1M   31M   4% /run
devtmpfs        8.0M     0  8.0M   0% /dev
/dev/sdc1        30G   14G   15G  49% /
tmpfs           2.5G  3.5M  2.5G   1% /dev/shm
cgroup_root     2.5G     0  2.5G   0% /sys/fs/cgroup
/dev/sdc3        39G   18G   20G  48% /home
cgmfs           100K     0  100K   0% /run/cgmanager/fs
/dev/sdb5       149G  143G  6.5G  96% /run/media/lysander/Backup Drive
/dev/sda5       299G  298G  389M 100% /run/media/lysander/Music and Media Drive
lsblk- f

Code:
lysander@psychopig-xxxiv:~$ lsblk -f
NAME   FSTYPE LABEL                 UUID                                 MOUNTPOINT
fd0                                                                      
sda                                                                      
|-sda1                                                                   
`-sda5 ntfs   Music and Media Drive 01C962C5B094A220                     /run/media/lysander/Music and Media Drive
sdb                                                                      
|-sdb1 ntfs   System Reserved       E01E06371E06076E                     
|-sdb2                                                                   
`-sdb5 ntfs   Backup Drive          01CB901A6E183220                     /run/media/lysander/Backup Drive
sdc                                                                      
|-sdc1 ext4                         ff624ae7-b3d4-4ef5-887a-8d505669bfd0 /
|-sdc2 swap                         3973ae50-15b7-4d57-a211-54b4cf951506 [SWAP]
`-sdc3 ext4                         3a2a529f-9216-43f6-9458-ae64cca849a2 /home
sr0                                                                      
sr1                                                                      
lysander@psychopig-xxxiv:~$
The UUIDs for the other two internal drives haven't changed since the Debian install, interestingly.

Notes: fstab and lilo.conf in the OP are what I'm currently using.

EDIT: I'm getting a parse error at lines 11 and 14 of fstab, but everything still mounts fine. Looks like sysv is ignoring the errors.

Last edited by Lysander666; 08-05-2018 at 07:51 AM.
 
1 members found this post helpful.
Old 08-05-2018, 09:34 AM   #3
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,407

Rep: Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861
Quote:
Originally Posted by Lysander666 View Post
EDIT: I'm getting a parse error at lines 11 and 14 of fstab, but everything still mounts fine. Looks like sysv is ignoring the errors.
Code:
/dev/sdb5       149G  143G  6.5G  96% /run/media/lysander/Backup Drive
/dev/sda5       299G  298G  389M 100% /run/media/lysander/Music and Media Drive
You're getting a parse error because these are Windows labels. You need to escape the spaces:
Code:
/run/media/lysander/Backup\ Drive
/run/media/lysander/Music\ and\ Media\ Drive
Or just create new mount points and mount them as follows:
Code:
/backup
/music-media
 
Old 08-05-2018, 02:07 PM   #4
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Thanks Gerard, I'm still getting these errors though. I've tried changing the type to UUID, escaping the spaces with your suggestions, with \040, it doesn't work. Here is fstab now:

Code:
#below partition is /dev/sda2 - swap
UUID=3973ae50-15b7-4d57-a211-54b4cf951506  swap  swap  defaults  0  0

#below partition is /dev/sda1 - root
UUID=ff624ae7-b3d4-4ef5-887a-8d505669bfd0  /  ext4  defaults  1  1

#below partition is /dev/sda3 - home
UUID=3a2a529f-9216-43f6-9458-ae64cca849a2  /home  ext4  defaults  1  2

#/dev/sda5
LABEL=Data  /run/media/lysander/Music\ and\ Media\ Drive  ntfs  defaults  0  2

#/dev/sdb5
PARTLABEL="Linux filesystem"  /run/media/lysander/Backup\ Drive  ntfs  defaults  0  2

#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
I may just live with these errors for now though at lines 11 and 14, they're pretty inconsequential, and booting is fast. I can still mount and access the drives fine.

Last edited by Lysander666; 08-05-2018 at 02:08 PM.
 
Old 08-05-2018, 03:33 PM   #5
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,407

Rep: Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861
Quote:
Originally Posted by Lysander666 View Post
Thanks Gerard, I'm still getting these errors though. I've tried changing the type to UUID, escaping the spaces with your suggestions, with \040, it doesn't work.
I may just live with these errors for now though at lines 11 and 14, they're pretty inconsequential, and booting is fast. I can still mount and access the drives fine.
OK. Just one last suggestion - try enclosing the path in quotes.
 
Old 08-06-2018, 02:30 PM   #6
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Quote:
Originally Posted by Gerard Lally View Post
OK. Just one last suggestion - try enclosing the path in quotes.
Thanks Gerard. This didn't work either so in the end, since the parse errors said "ignore entry at lines 11" and 14, and since I had tried everything I could think of, I took it to mean that the problem was that the lines were there at all. So I commented them out - now, after a reboot, there are no errors and I can mount the drives and access them, play through Audacious etc.

I don't know if this is an acceptable workaround but there are no issues now. But isn't it odd that I can access drives that are effectively not in fstab?

EDIT, looking at this, I think this means that those lines were never correct, for some reason, and I guess that Slackware will mount drives not in fstab automatically at /run/media/<user>/. Since /, swap and /home are specified by UUIDs which are also in lilo.conf, Slack does not get confused on boot and mounts them correctly, then throws the other drives in /run/media/<user> for wont of a better solution.

Is this acceptable? Well, it's workable - and a solution - but probably not the best solution. In order to get that, I would have to work out what went wrong with those lines in the first place, but I think this is OK for now.

EDIT2: I should specify that the drives are not automounting, but I don't want them to automount anyway. I like mounting them manually. I also think that, since I had to manually mount in Debian, that fstab was also wrong there too. Oh well, it works for me though.

Last edited by Lysander666; 08-06-2018 at 02:38 PM.
 
Old 08-06-2018, 04:48 PM   #7
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,211

Rep: Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986
Is the label and partlabel correct for the ntfs drives? It isn't normal for an NTFS drive to be labeled as "Linux Partition"

Oh, and you don't need the "root" entry in your /etc/lilo.conf anymore since it is specified in your initrd using the -r option.

But as you hopefully realized, you can't use the backslash to escape spaces in your /etc/fstab. You have to use \040 in place of a space (/run/media/lysander/Backup\040Drive). Have you thought about naming the folders without spaces to get rid of that difficulty? Just have the first one be "Backup" and the second be "Media" (since music falls under media).

If you're still running into parsing issues, it could be an invalid character that has accidentally copy/pasted in without you realizing it. Common issues are the curved quotes (which many office programs will convert to automatically). So, it could be a good idea to erase the lines and retype them manually.
 
2 members found this post helpful.
Old 08-07-2018, 08:31 AM   #8
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Quote:
Originally Posted by bassmadrigal View Post
Is the label and partlabel correct for the ntfs drives?
Probably not. I wasn't sure about that part. I'm pretty sure that blkid didn't give me a label or partlabel though for the ntfs drives, only file type and UUID.

Quote:
Originally Posted by bassmadrigal View Post
It isn't normal for an NTFS drive to be labeled as "Linux Partition"
Definitely not then. I missed that small detail.

Quote:
Originally Posted by bassmadrigal View Post
Oh, and you don't need the "root" entry in your /etc/lilo.conf anymore since it is specified in your initrd using the -r option.
Understood, though I'm nervous about removing it. If I can't boot again for whatever reason, things could get problematic so I may just leave it for now.

Quote:
Originally Posted by bassmadrigal View Post
But as you hopefully realized, you can't use the backslash to escape spaces in your /etc/fstab. You have to use \040 in place of a space (/run/media/lysander/Backup\040Drive).
I tried that but it didn't have any effect. In fact, changing the name of the folders causes boot time to quadruple. If I do so, for both folders, I am told there is a parse error just at line 14 [no longer 11] but then sysv takes a lot longer to boot to login.

Quote:
Originally Posted by bassmadrigal View Post
Have you thought about naming the folders without spaces to get rid of that difficulty? Just have the first one be "Backup" and the second be "Media" (since music falls under media).
As above, I did exactly what you suggested yesterday and with the same names. I changed them via ntfslabel and then in fstab, and boot time shot up. It really doesn't like my changing the names of the folders.

Quote:
Originally Posted by bassmadrigal View Post
If you're still running into parsing issues, it could be an invalid character that has accidentally copy/pasted in without you realizing it. Common issues are the curved quotes (which many office programs will convert to automatically). So, it could be a good idea to erase the lines and retype them manually.
Yep, I may type the whole thing out again in nano. Apparently that's preferable to Leafpad, which is what I was using before.
 
Old 08-07-2018, 10:16 AM   #9
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,211

Rep: Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986
Quote:
Originally Posted by Lysander666 View Post
Probably not. I wasn't sure about that part. I'm pretty sure that blkid didn't give me a label or partlabel though for the ntfs drives, only file type and UUID.

Definitely not then. I missed that small detail.
You should be able to run ls -l /dev/disk/by-label/ to find the labels of the drives if you want to use those. I'm not sure if NTFS drives support PARTLABEL (never looked into it).

Quote:
Originally Posted by Lysander666 View Post
Understood, though I'm nervous about removing it. If I can't boot again for whatever reason, things could get problematic so I may just leave it for now.
If you're using an initrd with the -r option, then that entry is not being used at all.

Quote:
Originally Posted by Lysander666 View Post
I tried that but it didn't have any effect. In fact, changing the name of the folders causes boot time to quadruple. If I do so, for both folders, I am told there is a parse error just at line 14 [no longer 11] but then sysv takes a lot longer to boot to login.

As above, I did exactly what you suggested yesterday and with the same names. I changed them via ntfslabel and then in fstab, and boot time shot up. It really doesn't like my changing the names of the folders.

Yep, I may type the whole thing out again in nano. Apparently that's preferable to Leafpad, which is what I was using before.
It might be worth to simplify the entries first. I'd suggest using the /dev/sdb5 and /dev/sda5 entries and then use a folder that doesn't have spaces. Something like:

Code:
/dev/sda5                   /run/media/lysander/Media     ntfs    defaults      0 2
/dev/sdb5                   /run/media/lysander/Backup    ntfs    defaults      0 2
And did you actually want them mounted to /run/media/lysander/ or /share/? You had /share/ in your initial post, but under /run/ later on.
 
1 members found this post helpful.
Old 08-07-2018, 11:00 AM   #10
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Right, I think I've sorted this out now. The drives, being NTFS, wouldn't use UUID. And seeing as I'm using an MBR, I can't use PartLabel or PartUUID. For some reason, blkid is giving me no label. For instance, when running the commands bass gave above, I just get:

Code:
lysander@psychopig-xxxiv:~$ ls -l /dev/disk/by-label/
total 0
lrwxrwxrwx 1 root root 10 Aug  7 16:51 Backup\x20Drive -> ../../sdb5
lrwxrwxrwx 1 root root 10 Aug  7 16:51 Music\x20and\x20Media\x20Drive -> ../../sda5
lrwxrwxrwx 1 root root 10 Aug  7 16:51 System\x20Reserved -> ../../sdb1
lysander@psychopig-xxxiv:~$
So this really only gave me one option, which was to list the drives [well, the partitions] by ID. Which is what I did. Also, it seems the other reason why sysv was getting confused is that /run/media/lysander is only generated on manual mount, so it couldn't see the mount point. Indeed, running mount -fav before I mounted the drives said the mount point didn't exist.

Therefore I changed the mount point to /media/Media and /media/Backup. I also changed the drive labels using ntfslabel. Now fstab looks like this:

Code:
#below partition is /dev/sda2 - swap
UUID=3973ae50-15b7-4d57-a211-54b4cf951506  swap  swap  defaults  0  0

#below partition is /dev/sda1 - root
UUID=ff624ae7-b3d4-4ef5-887a-8d505669bfd0  /  ext4  defaults  1  1

#below partition is /dev/sda3 - home
UUID=3a2a529f-9216-43f6-9458-ae64cca849a2  /home  ext4  defaults  1  2

#/dev/sda5
/dev/disk/by-id/ata-Hitachi_HDP725032GLA360_GEC434RF1TAWGE-part5  /media/Media  ntfs  noauto  0  2

#/dev/sdb5
/dev/disk/by-id/ata-SAMSUNG_HD160JJ_S08HJ1ULA30904-part5  /media/Backup  ntfs  noauto  0  2

#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
No errors no boot, and everything is automounted. The only issue being that I don't want sda5 and sdb5 to be automounted, I like doing it manually. Still, I can find out how to do that.

EDIT: Found out how to prevent automount: by adding 'noauto' instead of 'defaults' [without quotes]. fstab above updated.

Last edited by Lysander666; 08-07-2018 at 11:23 AM.
 
1 members found this post helpful.
Old 08-07-2018, 11:34 AM   #11
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,211

Rep: Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986
Quote:
Originally Posted by Lysander666 View Post
Right, I think I've sorted this out now. The drives, being NTFS, wouldn't use UUID.
They don't technically have a proper UUID, but they do still have one you can use. The below is copy/pasted from your above output from lsblk.

Code:
NAME   FSTYPE LABEL                 UUID
sda5   ntfs   Music and Media Drive 01C962C5B094A220
sdb5   ntfs   Backup Drive          01CB901A6E183220
You can use those UUIDs in your fstab

Quote:
Originally Posted by Lysander666 View Post
And seeing as I'm using an MBR, I can't use PartLabel or PartUUID. For some reason, blkid is giving me no label. For instance, when running the commands bass gave above, I just get:

Code:
lysander@psychopig-xxxiv:~$ ls -l /dev/disk/by-label/
total 0
lrwxrwxrwx 1 root root 10 Aug  7 16:51 Backup\x20Drive -> ../../sdb5
lrwxrwxrwx 1 root root 10 Aug  7 16:51 Music\x20and\x20Media\x20Drive -> ../../sda5
lrwxrwxrwx 1 root root 10 Aug  7 16:51 System\x20Reserved -> ../../sdb1
lysander@psychopig-xxxiv:~$
This is listing your labels as "Backup Drive" and "Music and Media Drive".

Quote:
Originally Posted by Lysander666 View Post
No errors no boot, and everything is automounted. The only issue being that I don't want sda5 and sdb5 to be automounted, I like doing it manually. Still, I can find out how to do that.
Just add noauto after defaults

Code:
UUID=01CB901A6E183220   /media/Backup  ntfs  defaults,noauto  0  2
UUID=01C962C5B094A220   /media/Media  ntfs  defaults,noauto  0  2
 
1 members found this post helpful.
Old 08-07-2018, 12:48 PM   #12
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Quote:
Originally Posted by bassmadrigal View Post
You can use those UUIDs in your fstab
You are correct! I tried it and it works, fstab updated again:

Code:
#below partition is /dev/sda2 - swap
UUID=3973ae50-15b7-4d57-a211-54b4cf951506  swap  swap  defaults  0  0

#below partition is /dev/sda1 - root
UUID=ff624ae7-b3d4-4ef5-887a-8d505669bfd0  /  ext4  defaults  1  1

#below partition is /dev/sda3 - home
UUID=3a2a529f-9216-43f6-9458-ae64cca849a2  /home  ext4  defaults  1  2

#/dev/sda5
UUID=01C962C5B094A220  /media/Media  ntfs  defaults,noauto  0  2

#/dev/sdb5
UUID=01CB901A6E183220  /media/Backup  ntfs  defaults,noauto  0  2

#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0

Quote:
Originally Posted by bassmadrigal View Post
This is listing your labels as "Backup Drive" and "Music and Media Drive".
Aherm, yes. Well, I decided to keep the names and mount points this time, it makes a bit more sense.


Quote:
Originally Posted by bassmadrigal View Post
Just add noauto after defaults
Did do so, thank you. I think this warrants a blog post. I feel I've cracked it now, thanks to your help. And look, my fstab is *nearly* as neat as yours.
 
Old 08-07-2018, 04:04 PM   #13
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
I've written a mini blog post about my experience with this. Thanks to everyone who helped, it was very important to get it sorted. It was a big leap forward in my experiences with Slack.

https://www.linuxquestions.org/quest...ackware-37799/

Last edited by Lysander666; 08-07-2018 at 04:26 PM.
 
1 members found this post helpful.
Old 08-07-2018, 05:46 PM   #14
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,211

Rep: Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986
I'll have to read that blog post later, but a quick glance looks good.

From your experiences, if you have any suggestions for the SlackDocs article, I'm more than willing to try and address any confusing parts or add additional clarification.

Congrats on getting it working! I know when it finally sunk in with me and I understood it, it was a great feeling.
 
1 members found this post helpful.
Old 08-07-2018, 05:55 PM   #15
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 528
Blog Entries: 1

Original Poster
Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Quote:
Originally Posted by bassmadrigal View Post

Congrats on getting it working! I know when it finally sunk in with me and I understood it, it was a great feeling.
It's quite a relief, certainly so in contrast to the distress I remember experiencing the time I got that first kernel panic and I had no idea what was going on, let alone knowing how I was going to fix it.

Without wishing to sound too lavishing with my compliments, to be honest, it's people like you who make user experiences with Slackware so fruitful. I don't think there's any way I would have been able to address this issue without your Slackdocs article, and the refinement you provided through helping in this thread. People here often go quiet when they're complimented, but really it's the immensely important assistance that influential individuals provide which benefit users in ways they can't always see. So, I'll be a little vocal about it, since I wouldn't have succeeded without your input. And really, don't we want users to benefit from the knowledge we impart and which allows them to carry their learning forward? Great work.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Persistent naming with three internal HDDs Lysander666 Slackware 16 01-16-2018 05:58 AM
Persistent Naming of a Block Device CentOS 6 bluefish1 Linux - Server 9 10-05-2012 08:05 PM
Persistent naming of /dev/sd[a-z] devices. How could I achieve this? Devyn Linux - Server 5 12-26-2011 10:55 PM
persistent device naming problem d-niX Linux - Server 7 02-24-2011 02:42 AM
Changing UDEV persistent naming schemes orbit Slackware 5 04-21-2008 09:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration